summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2012-10-17 09:08:04 +0000
committerChristoph Junghans <ottxor@gentoo.org>2012-10-17 09:08:04 +0000
commitf2411c9f8eb785d56c1351481b5683ae8876da72 (patch)
treebbcc046b2d223bcc7f5bee9c056811022d73c68b /dev-java
parentBump, restricting pythons (diff)
downloadgentoo-2-f2411c9f8eb785d56c1351481b5683ae8876da72.tar.gz
gentoo-2-f2411c9f8eb785d56c1351481b5683ae8876da72.tar.bz2
gentoo-2-f2411c9f8eb785d56c1351481b5683ae8876da72.zip
added prefix support (bug #435276)
(Portage version: 2.2.0_alpha140/cvs/Linux i686, signed Manifest commit with key C2000586)
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/ant-eclipse-ecj/ChangeLog7
-rw-r--r--dev-java/ant-eclipse-ecj/ant-eclipse-ecj-3.7.2.ebuild5
-rw-r--r--dev-java/ant-eclipse-ecj/ant-eclipse-ecj-4.2.ebuild5
3 files changed, 11 insertions, 6 deletions
diff --git a/dev-java/ant-eclipse-ecj/ChangeLog b/dev-java/ant-eclipse-ecj/ChangeLog
index 92302d7abfcb..36e25cb2cfa4 100644
--- a/dev-java/ant-eclipse-ecj/ChangeLog
+++ b/dev-java/ant-eclipse-ecj/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-java/ant-eclipse-ecj
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/ant-eclipse-ecj/ChangeLog,v 1.33 2012/07/11 21:04:13 caster Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/ant-eclipse-ecj/ChangeLog,v 1.34 2012/10/17 09:08:04 ottxor Exp $
+
+ 17 Oct 2012; Christoph Junghans <ottxor@gentoo.org>
+ ant-eclipse-ecj-3.7.2.ebuild, ant-eclipse-ecj-4.2.ebuild:
+ added prefix support (bug #435276)
*ant-eclipse-ecj-4.2 (11 Jul 2012)
@@ -150,4 +154,3 @@
+files/compiler-settings-3.3, +metadata.xml,
+ant-eclipse-ecj-3.3.0.ebuild:
Initial version imported from gcj-overlay.
-
diff --git a/dev-java/ant-eclipse-ecj/ant-eclipse-ecj-3.7.2.ebuild b/dev-java/ant-eclipse-ecj/ant-eclipse-ecj-3.7.2.ebuild
index 35e1dbb2ffb3..97785654a472 100644
--- a/dev-java/ant-eclipse-ecj/ant-eclipse-ecj-3.7.2.ebuild
+++ b/dev-java/ant-eclipse-ecj/ant-eclipse-ecj-3.7.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/ant-eclipse-ecj/ant-eclipse-ecj-3.7.2.ebuild,v 1.1 2012/03/03 22:15:57 caster Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/ant-eclipse-ecj/ant-eclipse-ecj-3.7.2.ebuild,v 1.2 2012/10/17 09:08:04 ottxor Exp $
EAPI=4
@@ -14,7 +14,7 @@ HOMEPAGE="http://www.eclipse.org/"
SRC_URI="http://download.eclipse.org/eclipse/downloads/drops/${DMF/.0}/ecjsrc-${PV}.jar"
LICENSE="EPL-1.0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x86-solaris"
SLOT="3.7"
IUSE=""
@@ -48,4 +48,5 @@ src_install() {
java-pkg_dojar ${PN}.jar
insinto /usr/share/java-config-2/compiler
doins "${FILESDIR}/ecj-${SLOT}"
+ sed -i "s/^JAVAC=/&${EPREFIX}:" /usr/share/java-config-2/compiler/ecj-${SLOT}
}
diff --git a/dev-java/ant-eclipse-ecj/ant-eclipse-ecj-4.2.ebuild b/dev-java/ant-eclipse-ecj/ant-eclipse-ecj-4.2.ebuild
index 448142a989d8..2ebcd6c579e4 100644
--- a/dev-java/ant-eclipse-ecj/ant-eclipse-ecj-4.2.ebuild
+++ b/dev-java/ant-eclipse-ecj/ant-eclipse-ecj-4.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/ant-eclipse-ecj/ant-eclipse-ecj-4.2.ebuild,v 1.1 2012/07/11 21:04:13 caster Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/ant-eclipse-ecj/ant-eclipse-ecj-4.2.ebuild,v 1.2 2012/10/17 09:08:04 ottxor Exp $
EAPI=4
@@ -14,7 +14,7 @@ HOMEPAGE="http://www.eclipse.org/"
SRC_URI="http://download.eclipse.org/eclipse/downloads/drops4/${DMF/.0}/ecjsrc-${PV}.jar"
LICENSE="EPL-1.0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x86-solaris"
SLOT="4.2"
IUSE=""
@@ -48,4 +48,5 @@ src_install() {
java-pkg_dojar ${PN}.jar
insinto /usr/share/java-config-2/compiler
doins "${FILESDIR}/ecj-${SLOT}"
+ sed -i "s/^JAVAC=/&${EPREFIX}:" /usr/share/java-config-2/compiler/ecj-${SLOT}
}