summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2011-01-18 14:06:58 +0000
committerMiroslav Šulc <fordfrog@gentoo.org>2011-01-18 14:06:58 +0000
commiteced9f2528630d912542791242b8d9c28b63adde (patch)
tree3e8593ca2127865c3d87fcc74367a04c6b21dbd2 /dev-java
parentx86 stable, bug 348987 (diff)
downloadgentoo-2-eced9f2528630d912542791242b8d9c28b63adde.tar.gz
gentoo-2-eced9f2528630d912542791242b8d9c28b63adde.tar.bz2
gentoo-2-eced9f2528630d912542791242b8d9c28b63adde.zip
dev-java/junit: applied patch from bug #287757
(Portage version: 2.1.9.33/cvs/Linux x86_64)
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/junit/ChangeLog9
-rw-r--r--dev-java/junit/files/gentoo-manifest.mf1
-rw-r--r--dev-java/junit/junit-4.8.2-r1.ebuild87
-rw-r--r--dev-java/junit/junit-4.8.2.ebuild73
4 files changed, 96 insertions, 74 deletions
diff --git a/dev-java/junit/ChangeLog b/dev-java/junit/ChangeLog
index fa21cb5ee54d..0dc59abcd4cd 100644
--- a/dev-java/junit/ChangeLog
+++ b/dev-java/junit/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-java/junit
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/junit/ChangeLog,v 1.59 2011/01/18 13:37:33 fordfrog Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/junit/ChangeLog,v 1.60 2011/01/18 14:06:58 fordfrog Exp $
+
+*junit-4.8.2-r1 (18 Jan 2011)
+
+ 18 Jan 2011; Miroslav Šulc <fordfrog@gentoo.org> -junit-4.8.2.ebuild,
+ +junit-4.8.2-r1.ebuild, +files/gentoo-manifest.mf:
+ Applied patch from bug #287757 (thanks to Daniel Solano Gómez
+ <gentoo@sattvik.com>) and did some adjustments of the ebuild
*junit-4.8.2 (18 Jan 2011)
diff --git a/dev-java/junit/files/gentoo-manifest.mf b/dev-java/junit/files/gentoo-manifest.mf
new file mode 100644
index 000000000000..f78474422035
--- /dev/null
+++ b/dev-java/junit/files/gentoo-manifest.mf
@@ -0,0 +1 @@
+Class-Path: ../../hamcrest-core/lib/hamcrest-core.jar
diff --git a/dev-java/junit/junit-4.8.2-r1.ebuild b/dev-java/junit/junit-4.8.2-r1.ebuild
new file mode 100644
index 000000000000..913869d4772d
--- /dev/null
+++ b/dev-java/junit/junit-4.8.2-r1.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/junit/junit-4.8.2-r1.ebuild,v 1.1 2011/01/18 14:06:58 fordfrog Exp $
+
+# WARNING: JUNIT.JAR IS _NOT_ SYMLINKED TO ANT-CORE LIB FOLDER AS JUNIT3 IS
+
+EAPI="3"
+JAVA_PKG_IUSE="doc examples source test"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="Simple framework to write repeatable tests"
+SRC_URI="https://github.com/downloads/KentBeck/${PN}/${PN}${PV}.zip"
+HOMEPAGE="http://www.junit.org/"
+LICENSE="CPL-1.0"
+SLOT="4"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+CDEPEND="dev-java/hamcrest-core:0"
+RDEPEND=">=virtual/jre-1.5
+ ${CDEPEND}"
+DEPEND=">=virtual/jdk-1.5
+ userland_GNU? ( >=sys-apps/findutils-4.3 )
+ ${CDEPEND}"
+
+S="${WORKDIR}/${PN}${PV}"
+
+EANT_BUILD_TARGET="jars"
+
+src_unpack() {
+ default
+
+ # Unpack source JAR
+ mkdir -p "${S}/src/main/java" "${S}/src/test/java" \
+ || die "Unable to create source directories"
+ pushd "${S}/src/main/java" >/dev/null
+ jar xf "${S}/${P}-src.jar" || die "Unable to unpack sources."
+ popd >/dev/null
+
+ # copy Gentoo manifest to working directory
+ cp "${FILESDIR}/gentoo-manifest.mf" "${S}"
+}
+
+java_prepare() {
+ # fix javadoc compilation
+ if use doc ; then
+ cp "${S}"/javadoc/stylesheet.css "${S}" \
+ || die "Unable to copy Javdoc stylesheet"
+ fi
+
+ # remove binary and other generated files
+ rm -rf javadoc temp.hamcrest.source *.jar \
+ || die "Unable to clean generated files."
+ find . -name "*.class" -delete \
+ || die "Unable to remove distributed class files"
+
+ # Let Ant know where its hamcrest went
+ EANT_EXTRA_ARGS="-Dhamcrestlib=$(java-pkg_getjars hamcrest-core)"
+
+ # Add Gentoo manifest information to generated JAR files
+ java-ant_xml-rewrite -f build.xml -c \
+ -e jar -a manifest -v "gentoo-manifest.mf"
+}
+
+src_test() {
+ mkdir classes || die "Unable to create build directory for tests"
+
+ local cp=$(java-pkg_getjars hamcrest-core):${S}/${PN}${PV}/${PN}-dep-${PV}.jar
+ ejavac -classpath ${cp} -d classes $(find junit/tests -name "*.java")
+
+ java -classpath ${cp}:classes org.junit.runner.JUnitCore junit.tests.AllTests \
+ || "Tests failed."
+}
+
+src_install() {
+ java-pkg_newjar ${PN}${PV}/${PN}-dep-${PV}.jar
+ dodoc README.html doc/ReleaseNotes${PV}.txt || die
+
+ use examples && java-pkg_doexamples org/junit/samples
+ use source && java-pkg_dosrc src/main/java/org src/main/java/junit
+
+ if use doc; then
+ dohtml -r doc/*
+ java-pkg_dojavadoc ${PN}${PV}/javadoc
+ fi
+}
diff --git a/dev-java/junit/junit-4.8.2.ebuild b/dev-java/junit/junit-4.8.2.ebuild
deleted file mode 100644
index cd57a311160e..000000000000
--- a/dev-java/junit/junit-4.8.2.ebuild
+++ /dev/null
@@ -1,73 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/junit/junit-4.8.2.ebuild,v 1.1 2011/01/18 13:37:34 fordfrog Exp $
-
-# WARNING: JUNIT.JAR IS _NOT_ SYMLINKED TO ANT-CORE LIB FOLDER AS JUNIT3 IS
-
-JAVA_PKG_IUSE="doc examples source test"
-
-inherit java-pkg-2 java-ant-2
-
-DESCRIPTION="Simple framework to write repeatable tests"
-SRC_URI="https://github.com/downloads/KentBeck/${PN}/${PN}${PV}.zip"
-HOMEPAGE="http://www.junit.org/"
-LICENSE="CPL-1.0"
-SLOT="4"
-KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
-IUSE=""
-
-CDEPEND="=dev-java/hamcrest-core-1.1*"
-RDEPEND=">=virtual/jre-1.5
- ${CDEPEND}"
-DEPEND=">=virtual/jdk-1.5
- userland_GNU? ( >=sys-apps/findutils-4.3 )
- app-arch/unzip
- ${CDEPEND}"
-
-S="${WORKDIR}/${PN}${PV}"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- mkdir -p src/main/java src/test/java || die
- unzip -qq -d src/main/java ${P}-src.jar || die "unzip failed"
-
- # fix javadoc compilation
- if use doc ; then
- cp "${S}"/javadoc/stylesheet.css "${S}" || die
- fi
-
- rm -rf javadoc temp.hamcrest.source *.jar || die
- find . -name "*.class" -delete || die
-}
-
-src_compile() {
- eant build jars -Dhamcrestlib=$(java-pkg_getjars hamcrest-core) $(use_doc javadoc)
-}
-
-src_test() {
- mkdir classes || die
- cd junit/tests || die
- local cp=$(java-pkg_getjars hamcrest-core):${S}/${PN}${PV}/${PN}-dep-${PV}.jar
- ejavac -sourcepath java -classpath ${cp} -d "${S}"/classes $(find . -name "*.java")
-
- cd "${S}"/classes || die
- for FILE in $(find . -name "AllTests\.class"); do
- local CLASS=$(echo ${FILE} | sed -e "s/\.class//" | sed -e "s%/%.%g" | sed -e "s/\.\.//")
- java -classpath .:${cp} org.junit.runner.JUnitCore ${CLASS} || die "Test ${CLASS} failed"
- done
-}
-
-src_install() {
- java-pkg_newjar ${PN}${PV}/${PN}-dep-${PV}.jar
- dodoc README.html doc/ReleaseNotes${PV}.txt || die
-
- use examples && java-pkg_doexamples org/junit/samples
- use source && java-pkg_dosrc src/main/java/org src/main/java/junit
-
- if use doc; then
- dohtml -r doc/*
- java-pkg_dojavadoc ${PN}${PV}/javadoc
- fi
-}