summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetteri Räty <betelgeuse@gentoo.org>2007-06-11 18:05:10 +0000
committerPetteri Räty <betelgeuse@gentoo.org>2007-06-11 18:05:10 +0000
commiteb0b81ecf4c21f7944d397222dd12e123d8f1cd3 (patch)
treef068d04a505f3e7a7a2802f4e01083154ebb01e1 /dev-java
parentStable on ppc wrt bug 181584 (diff)
downloadgentoo-2-eb0b81ecf4c21f7944d397222dd12e123d8f1cd3.tar.gz
gentoo-2-eb0b81ecf4c21f7944d397222dd12e123d8f1cd3.tar.bz2
gentoo-2-eb0b81ecf4c21f7944d397222dd12e123d8f1cd3.zip
Version bump.
(Portage version: 2.1.2.9)
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/sun-jre-bin/ChangeLog8
-rw-r--r--dev-java/sun-jre-bin/files/digest-sun-jre-bin-1.5.0.126
-rw-r--r--dev-java/sun-jre-bin/sun-jre-bin-1.5.0.12.ebuild129
3 files changed, 142 insertions, 1 deletions
diff --git a/dev-java/sun-jre-bin/ChangeLog b/dev-java/sun-jre-bin/ChangeLog
index df2a3e9660a5..e2ef411a8072 100644
--- a/dev-java/sun-jre-bin/ChangeLog
+++ b/dev-java/sun-jre-bin/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-java/sun-jre-bin
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jre-bin/ChangeLog,v 1.95 2007/06/05 05:12:52 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jre-bin/ChangeLog,v 1.96 2007/06/11 18:05:10 betelgeuse Exp $
+
+*sun-jre-bin-1.5.0.12 (11 Jun 2007)
+
+ 11 Jun 2007; Petteri Räty <betelgeuse@gentoo.org>
+ +sun-jre-bin-1.5.0.12.ebuild:
+ Version bump.
05 Jun 2007; Christian Faulhammer <opfer@gentoo.org>
sun-jre-bin-1.6.0.01-r1.ebuild:
diff --git a/dev-java/sun-jre-bin/files/digest-sun-jre-bin-1.5.0.12 b/dev-java/sun-jre-bin/files/digest-sun-jre-bin-1.5.0.12
new file mode 100644
index 000000000000..cb5005dff8c2
--- /dev/null
+++ b/dev-java/sun-jre-bin/files/digest-sun-jre-bin-1.5.0.12
@@ -0,0 +1,6 @@
+MD5 948295f3e252670eb9328cbbc422e3a6 jdk-1_5_0_12-dlj-linux-amd64.bin 43854594
+RMD160 b9790d2cc33c7c7f749f6fd055da2b215c054dff jdk-1_5_0_12-dlj-linux-amd64.bin 43854594
+SHA256 7be91d7544ac682c28bfcad60fa7856303e70fbf8e9857a93d701553dc40c144 jdk-1_5_0_12-dlj-linux-amd64.bin 43854594
+MD5 9b0d717810953e78d5c40969e382e1ae jdk-1_5_0_12-dlj-linux-i586.bin 49646174
+RMD160 0865c93170fcf443c61a83660228cbc4a91523b9 jdk-1_5_0_12-dlj-linux-i586.bin 49646174
+SHA256 2a9b782300930a239c88e93c9c4e0c34715fb6dddb88cb82ba214dba3f4c9eb0 jdk-1_5_0_12-dlj-linux-i586.bin 49646174
diff --git a/dev-java/sun-jre-bin/sun-jre-bin-1.5.0.12.ebuild b/dev-java/sun-jre-bin/sun-jre-bin-1.5.0.12.ebuild
new file mode 100644
index 000000000000..10b8e3388fbe
--- /dev/null
+++ b/dev-java/sun-jre-bin/sun-jre-bin-1.5.0.12.ebuild
@@ -0,0 +1,129 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jre-bin/sun-jre-bin-1.5.0.12.ebuild,v 1.1 2007/06/11 18:05:10 betelgeuse Exp $
+
+inherit pax-utils eutils java-vm-2
+
+MY_PVL=${PV%.*}_${PV##*.}
+MY_PVA=${PV//./_}
+#S="${WORKDIR}/jdk${MY_PVL}"
+
+X86_AT="jdk-${MY_PVA}-dlj-linux-i586.bin"
+AMD64_AT="jdk-${MY_PVA}-dlj-linux-amd64.bin"
+
+DESCRIPTION="Sun's J2SE Development Kit, version ${PV}"
+HOMEPAGE="http://java.sun.com/j2se/1.5.0/"
+SRC_URI="x86? ( http://download.java.net/dlj/binaries/${X86_AT} )
+ amd64? ( http://download.java.net/dlj/binaries/${AMD64_AT} )"
+SLOT="1.5"
+LICENSE="dlj-1.1"
+KEYWORDS="-* ~amd64 ~x86"
+RESTRICT="nostrip"
+IUSE="X alsa nsplugin"
+
+RDEPEND="
+ sys-libs/glibc
+ alsa? ( media-libs/alsa-lib )
+ X? (
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXi
+ x11-libs/libXp
+ x11-libs/libXt
+ x11-libs/libXtst
+ )"
+
+DEPEND=""
+
+JAVA_PROVIDE="jdbc-stdext jdbc-rowset"
+
+QA_TEXTRELS_x86="opt/${P}/lib/i386/motif21/libmawt.so
+ opt/${P}/lib/i386/libdeploy.so"
+
+src_unpack() {
+ if [ ! -r ${DISTDIR}/${A} ]; then
+ die "cannot read ${A}. Please check the permission and try again."
+ fi
+
+ mkdir bundled-jdk
+ cd bundled-jdk
+ sh "${DISTDIR}/${A}" --accept-license --unpack || die "Failed to unpack"
+
+ cd ..
+ bash ${FILESDIR}/construct.sh bundled-jdk sun-jdk-${PV} ${P} || die "construct.sh failed"
+}
+
+src_install() {
+ # Set PaX markings on all JDK/JRE executables to allow code-generation on
+ # the heap by the JIT compiler.
+ pax-mark m $(list-paxables ${S}/bin/*)
+
+ local dirs="bin lib man"
+ # only X86 has the plugin and javaws
+ use x86 && dirs="${dirs} javaws plugin"
+ dodir /opt/${P}
+
+ cp -pPR ${dirs} "${D}/opt/${P}/" || die "failed to copy"
+
+ dodoc CHANGES README THIRDPARTYLICENSEREADME.txt || die
+ dohtml Welcome.html || die
+
+ if use nsplugin; then
+ local plugin_dir="ns7-gcc29"
+ if has_version '>=sys-devel/gcc-3' ; then
+ plugin_dir="ns7"
+ fi
+
+ if use x86 ; then
+ install_mozilla_plugin /opt/${P}/plugin/i386/$plugin_dir/libjavaplugin_oji.so
+ else
+ eerror "No plugin available for amd64 arch"
+ fi
+ fi
+
+ # TODO Don't think we still needs these -nichoj
+ # create dir for system preferences
+ #dodir /opt/${P}/jre/.systemPrefs
+ # Create files used as storage for system preferences.
+ #touch ${D}/opt/${P}/jre/.systemPrefs/.system.lock
+ #chmod 644 ${D}/opt/${P}/jre/.systemPrefs/.system.lock
+ #touch ${D}/opt/${P}/jre/.systemPrefs/.systemRootModFile
+ #chmod 644 ${D}/opt/${P}/jre/.systemPrefs/.systemRootModFile
+
+ # FIXME figure out how to handle the control pannel conflict with
+ # sun-jdk-bin
+
+ # install control panel for Gnome/KDE
+# sed -e "s/INSTALL_DIR\/JRE_NAME_VERSION/\/opt\/${P}\/jre/" \
+# -e "s/\(Name=Java\)/\1 Control Panel ${SLOT}/" \
+# ${D}/opt/${P}/plugin/desktop/sun_java.desktop > \
+# ${T}/sun_java-${SLOT}.desktop
+
+# domenu ${T}/sun_java-${SLOT}.desktop
+
+ # bug #56444
+ insinto /opt/${P}/lib/
+ newins "${FILESDIR}"/fontconfig.Gentoo.properties \
+ fontconfig.properties || die
+
+ set_java_env
+}
+
+pkg_postinst() {
+ # Set as default VM if none exists
+ java-vm-2_pkg_postinst
+
+ if ! use X; then
+ local xwarn="virtual/x11 and/or"
+ fi
+
+ echo
+ ewarn "Some parts of Sun's JDK require ${xwarn} virtual/lpr to be installed."
+ ewarn "Be careful which Java libraries you attempt to use."
+
+ echo
+ elog "Beginning with 1.5.0.10 the hotspot vm can use epoll"
+ elog "The epoll-based implementation of SelectorProvider is not selected by"
+ elog "default."
+ elog "Use java -Djava.nio.channels.spi.SelectorProvider=sun.nio.ch.EPollSelectorProvider"
+}