summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVlastimil Babka <caster@gentoo.org>2010-06-30 20:46:26 +0000
committerVlastimil Babka <caster@gentoo.org>2010-06-30 20:46:26 +0000
commite0e85deffc319e6b2076ebd97fc77e35498b206c (patch)
tree324c5a3818bb0d6f80b2bab07301c4e7d61bd971 /dev-java
parentAdd more multilib compatibility (diff)
downloadgentoo-2-e0e85deffc319e6b2076ebd97fc77e35498b206c.tar.gz
gentoo-2-e0e85deffc319e6b2076ebd97fc77e35498b206c.tar.bz2
gentoo-2-e0e85deffc319e6b2076ebd97fc77e35498b206c.zip
Cleanup.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/jdbc-mysql/ChangeLog7
-rw-r--r--dev-java/jdbc-mysql/files/do-not-filter-png.diff18
-rw-r--r--dev-java/jdbc-mysql/jdbc-mysql-5.0.8.ebuild74
-rw-r--r--dev-java/jdbc-mysql/jdbc-mysql-5.1.10.ebuild93
-rw-r--r--dev-java/jdbc-mysql/jdbc-mysql-5.1.6.ebuild4
5 files changed, 8 insertions, 188 deletions
diff --git a/dev-java/jdbc-mysql/ChangeLog b/dev-java/jdbc-mysql/ChangeLog
index 5722445bc2e0..e99678261d95 100644
--- a/dev-java/jdbc-mysql/ChangeLog
+++ b/dev-java/jdbc-mysql/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-java/jdbc-mysql
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/jdbc-mysql/ChangeLog,v 1.71 2010/05/16 19:42:02 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jdbc-mysql/ChangeLog,v 1.72 2010/06/30 20:46:26 caster Exp $
+
+ 30 Jun 2010; Vlastimil Babka <caster@gentoo.org> -jdbc-mysql-5.0.8.ebuild,
+ jdbc-mysql-5.1.6.ebuild, -jdbc-mysql-5.1.10.ebuild,
+ -files/do-not-filter-png.diff:
+ Cleanup.
16 May 2010; Markus Meier <maekke@gentoo.org> jdbc-mysql-5.1.11.ebuild:
amd64/x86 stable, bug #309109
diff --git a/dev-java/jdbc-mysql/files/do-not-filter-png.diff b/dev-java/jdbc-mysql/files/do-not-filter-png.diff
deleted file mode 100644
index 3aaabe5d3257..000000000000
--- a/dev-java/jdbc-mysql/files/do-not-filter-png.diff
+++ /dev/null
@@ -1,18 +0,0 @@
---- mysql-connector-java-3.1.12/build.xml.orig 2006-04-19 12:37:46.000000000 +0200
-+++ mysql-connector-java-3.1.12/build.xml 2006-04-19 12:57:52.000000000 +0200
-@@ -99,6 +99,7 @@
- <patternset id="classjar" >
- <exclude name="**/*.class*"/>
- <exclude name="**/*.jar"/>
-+ <exclude name="**/*.png"/>
- </patternset>
- </fileset>
-
-@@ -116,6 +117,7 @@
- <fileset dir="${sourceDir}" excludes="**/CVS">
- <patternset id="dojar" >
- <include name="**/*.jar*"/>
-+ <include name="**/*.png"/>
- </patternset>
- </fileset>
- </copy>
diff --git a/dev-java/jdbc-mysql/jdbc-mysql-5.0.8.ebuild b/dev-java/jdbc-mysql/jdbc-mysql-5.0.8.ebuild
deleted file mode 100644
index bbf38643a17b..000000000000
--- a/dev-java/jdbc-mysql/jdbc-mysql-5.0.8.ebuild
+++ /dev/null
@@ -1,74 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/jdbc-mysql/jdbc-mysql-5.0.8.ebuild,v 1.5 2008/03/21 02:23:42 ken69267 Exp $
-
-JAVA_PKG_IUSE="source"
-WANT_ANT_TASKS="ant-contrib"
-
-inherit eutils java-pkg-2 java-ant-2
-
-MY_PN="mysql-connector-java"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="MySQL JDBC driver"
-HOMEPAGE="http://www.mysql.com/products/connector/j/"
-SRC_URI="mirror://mysql/Downloads/Connector-J/${MY_P}.tar.gz"
-LICENSE="GPL-2-with-MySQL-FLOSS-exception"
-SLOT="0"
-KEYWORDS="amd64 ppc ppc64 x86"
-IUSE="c3p0 log4j"
-COMMON_DEP="
- log4j? ( dev-java/log4j )
- c3p0? ( dev-java/c3p0 )
- dev-java/commons-logging"
-RDEPEND=">=virtual/jre-1.4
- ${COMMON_DEP}"
-# FIXME doesn't like Java 1.6's JDBC API
-DEPEND="|| (
- =virtual/jdk-1.5*
- =virtual/jdk-1.4*
- )
- ${COMMON_DEP}"
-
-S="${WORKDIR}/${MY_P}"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- # gcj hangs, but works for others -> why regexp over pictures?!
- epatch "${FILESDIR}/do-not-filter-png.diff"
- epatch "${FILESDIR}/5.0.5-remove-jboss-dependency-from-tests.patch"
- # http://bugs.mysql.com/bug.php?id=28286
- epatch "${FILESDIR}/5.0.5-dist-target-depends.patch"
-
- rm -v *.jar debug/*.jar || die
-
- java-ant_ignore-system-classes
-
- # use test && mkdir src/lib-nodist # needed, or ant will fail
-
- cd src/lib
- rm -v *.jar || die
- java-pkg_jar-from commons-logging
- use log4j && java-pkg_jar-from log4j
- use c3p0 && java-pkg_jar-from c3p0
-}
-
-EANT_BUILD_TARGET="dist"
-
-# Tests need a mysql DB to exist
-RESTRICT="test"
-src_test() {
- cd src/lib
- java-pkg_jar-from junit
- cd "${S}"
- ANT_TASKS="ant-junit" eant test -Dcom.mysql.jdbc.noCleanBetweenCompiles=true
-}
-
-src_install() {
- java-pkg_newjar build/${MY_P}/${MY_P}-bin.jar ${PN}.jar
- dodoc README CHANGES || die
- dohtml docs/*.html || die
- use source && java-pkg_dosrc src/com src/org
-}
diff --git a/dev-java/jdbc-mysql/jdbc-mysql-5.1.10.ebuild b/dev-java/jdbc-mysql/jdbc-mysql-5.1.10.ebuild
deleted file mode 100644
index c92b8f52f62a..000000000000
--- a/dev-java/jdbc-mysql/jdbc-mysql-5.1.10.ebuild
+++ /dev/null
@@ -1,93 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/jdbc-mysql/jdbc-mysql-5.1.10.ebuild,v 1.3 2010/02/12 23:07:40 caster Exp $
-
-JAVA_PKG_IUSE="source"
-WANT_ANT_TASKS="ant-contrib"
-
-inherit eutils java-pkg-2 java-ant-2
-
-MY_PN="mysql-connector-java"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="MySQL JDBC driver"
-HOMEPAGE="http://www.mysql.com/products/connector/j/"
-SRC_URI="mirror://mysql/Downloads/Connector-J/${MY_P}.tar.gz"
-LICENSE="GPL-2-with-MySQL-FLOSS-exception"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
-IUSE="c3p0 log4j"
-COMMON_DEP="
- log4j? ( dev-java/log4j )
- c3p0? ( dev-java/c3p0 )
- dev-java/commons-logging"
-RDEPEND=">=virtual/jre-1.4
- ${COMMON_DEP}"
-
-JAVA_PKG_NV_DEPEND="
- || ( =virtual/jdk-1.5* =virtual/jdk-1.4* )"
-
-DEPEND="${JAVA_PKG_NV_DEPEND}
- >=virtual/jdk-1.6
- ${COMMON_DEP}"
-
-S="${WORKDIR}/${MY_P}"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- epatch "${FILESDIR}/5.0.5-remove-jboss-dependency-from-tests.patch"
- # http://bugs.mysql.com/bug.php?id=28286
- epatch "${FILESDIR}/5.0.5-dist-target-depends.patch"
-
- # checks fail if java6 bootclasspath is not a single jar
- sed -i 's/depends="-compiler-check, /depends="/' build.xml || die
-
- rm -v *.jar || die
-
- # use test && mkdir src/lib-nodist # needed, or ant will fail
-
- cd src/lib
- rm -v *.jar || die
- java-pkg_jar-from commons-logging
- use log4j && java-pkg_jar-from log4j
- use c3p0 && java-pkg_jar-from c3p0
-}
-
-# Needs two different source/targets
-JAVA_PKG_BSFIX="off"
-JAVA_ANT_IGNORE_SYSTEM_CLASSES="true"
-EANT_BUILD_TARGET="dist"
-
-src_compile() {
- local vm=$(depend-java-query -v ">=virtual/jdk-1.6")
- local javac=$(GENTOO_VM="${vm}" java-config --javac)
- local rt=$(GENTOO_VM="${vm}" java-config -g BOOTCLASSPATH)
- einfo "Using ${vm} to compile the JDBC4 driver"
- einfo "javac: ${javac}"
- einfo "bootclasspath: ${rt}"
- java-pkg-2_src_compile \
- -Dcom.mysql.jdbc.java6.javac="${javac}" \
- -Dcom.mysql.jdbc.java6.rtjar="${rt}"
-}
-
-# Tests need a mysql DB to exist
-RESTRICT="test"
-src_test() {
- cd src/lib
- java-pkg_jar-from junit
- cd "${S}"
- ANT_TASKS="ant-junit" eant test -Dcom.mysql.jdbc.noCleanBetweenCompiles=true
-}
-
-src_install() {
- # Skip bytecode check because we want two versions there
- JAVA_PKG_STRICT= java-pkg_newjar build/${MY_P}/${MY_P}-bin.jar ${PN}.jar
- dodoc README CHANGES || die
- dohtml docs/*.html || die
- use source && java-pkg_dosrc src/com src/org
-}
-
-# Silence java-dep-check because it doesn't know how to find 1.6 classes
-pkg_preinst() { :; }
diff --git a/dev-java/jdbc-mysql/jdbc-mysql-5.1.6.ebuild b/dev-java/jdbc-mysql/jdbc-mysql-5.1.6.ebuild
index 2998f8ce8787..9359b280119e 100644
--- a/dev-java/jdbc-mysql/jdbc-mysql-5.1.6.ebuild
+++ b/dev-java/jdbc-mysql/jdbc-mysql-5.1.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/jdbc-mysql/jdbc-mysql-5.1.6.ebuild,v 1.4 2010/02/12 22:55:28 caster Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jdbc-mysql/jdbc-mysql-5.1.6.ebuild,v 1.5 2010/06/30 20:46:26 caster Exp $
JAVA_PKG_IUSE="source"
WANT_ANT_TASKS="ant-contrib"
@@ -15,7 +15,7 @@ HOMEPAGE="http://www.mysql.com/products/connector/j/"
SRC_URI="mirror://mysql/Downloads/Connector-J/${MY_P}.tar.gz"
LICENSE="GPL-2-with-MySQL-FLOSS-exception"
SLOT="0"
-KEYWORDS="amd64 ppc ~ppc64 x86"
+KEYWORDS="ppc"
IUSE="c3p0 log4j"
COMMON_DEP="
log4j? ( dev-java/log4j )