summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohann Schmitz <ercpe@gentoo.org>2014-09-08 04:58:08 +0000
committerJohann Schmitz <ercpe@gentoo.org>2014-09-08 04:58:08 +0000
commitd9b7927eca58a74a4e8f245955a6285a54c5984e (patch)
treee6b6b09f5de8e8a732c404d327d6c9d9788c203d /dev-java
parentfixing systemd stuffs for bug 518622 (diff)
downloadgentoo-2-d9b7927eca58a74a4e8f245955a6285a54c5984e.tar.gz
gentoo-2-d9b7927eca58a74a4e8f245955a6285a54c5984e.tar.bz2
gentoo-2-d9b7927eca58a74a4e8f245955a6285a54c5984e.zip
Restored deleted ebuild due to broken dependencies on x86 (bug #522342)
(Portage version: 2.2.8-r1/cvs/Linux x86_64, RepoMan options: --force, signed Manifest commit with key 77C501ED)
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/jgoodies-binding/ChangeLog7
-rw-r--r--dev-java/jgoodies-binding/jgoodies-binding-1.1.2.ebuild59
2 files changed, 65 insertions, 1 deletions
diff --git a/dev-java/jgoodies-binding/ChangeLog b/dev-java/jgoodies-binding/ChangeLog
index 0a70ebafec01..97c7cf585f8b 100644
--- a/dev-java/jgoodies-binding/ChangeLog
+++ b/dev-java/jgoodies-binding/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-java/jgoodies-binding
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/jgoodies-binding/ChangeLog,v 1.8 2014/09/07 15:53:57 ercpe Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jgoodies-binding/ChangeLog,v 1.9 2014/09/08 04:58:08 ercpe Exp $
+
+*jgoodies-binding-1.1.2 (08 Sep 2014)
+
+ 08 Sep 2014; Johann Schmitz <ercpe@gentoo.org> +jgoodies-binding-1.1.2.ebuild:
+ Restored deleted ebuild due to broken dependencies on x86 (bug #522342)
*jgoodies-binding-1.1.2-r1 (07 Sep 2014)
diff --git a/dev-java/jgoodies-binding/jgoodies-binding-1.1.2.ebuild b/dev-java/jgoodies-binding/jgoodies-binding-1.1.2.ebuild
new file mode 100644
index 000000000000..1ea2f15b4241
--- /dev/null
+++ b/dev-java/jgoodies-binding/jgoodies-binding-1.1.2.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jgoodies-binding/jgoodies-binding-1.1.2.ebuild,v 1.8 2014/09/08 04:58:08 ercpe Exp $
+
+JAVA_PKG_IUSE="doc examples source"
+
+inherit java-pkg-2 java-ant-2
+
+MY_V=${PV//./_}
+DESCRIPTION="A Java library to bind object properties with UI components"
+HOMEPAGE="http://www.jgoodies.com/"
+SRC_URI="http://www.jgoodies.com/download/libraries/binding-${MY_V}.zip"
+
+LICENSE="BSD"
+SLOT="1.0"
+KEYWORDS="~amd64 ~ppc x86"
+IUSE=""
+
+DEPEND=">=virtual/jdk-1.4.2
+ app-arch/unzip"
+RDEPEND=">=virtual/jre-1.4.2
+ examples? ( >=dev-java/jgoodies-looks-1.0.5 )"
+
+S=${WORKDIR}/binding-${PV}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Clean up the directory structure
+ rm -rvf *.jar lib
+
+ # Copy the Gentoo'ized build.xml
+ # cp ${FILESDIR}/build-${PV}.xml ${S}
+ java-ant_xml-rewrite -f build.xml -d -e javac -a bootclasspath
+ # || die "Failed to fix bootclasspath"
+ java-pkg_filter-compiler jikes
+}
+
+src_compile() {
+ eant jar # precompile javadocs
+}
+
+RESTRICT="test"
+# Needs X
+#src_test() {
+# eant test -D\
+# -Djunit.jar=$(java-pkg_getjar junit junit.jar)
+#}
+
+src_install() {
+ java-pkg_dojar build/binding.jar
+
+ dodoc RELEASE-NOTES.txt || die
+ dohtml README.html || die
+ use doc && java-pkg_dohtml -r docs/*
+ use source && java-pkg_dosrc src/core/*
+ use examples && java-pkg_doexamples src/tutorial
+}