summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Wijsman <tomwij@gentoo.org>2013-07-08 14:10:00 +0000
committerTom Wijsman <tomwij@gentoo.org>2013-07-08 14:10:00 +0000
commitcbd91c0a77e8fb12be669b6e80c582ceb8f49142 (patch)
tree8dc08c250dcf999259a93c990cfa06a06681986c /dev-java
parentVersion bump to 4.0.20 (includes build patch for bug #425290 and bug #472672)... (diff)
downloadgentoo-2-cbd91c0a77e8fb12be669b6e80c582ceb8f49142.tar.gz
gentoo-2-cbd91c0a77e8fb12be669b6e80c582ceb8f49142.tar.bz2
gentoo-2-cbd91c0a77e8fb12be669b6e80c582ceb8f49142.zip
Version bump to 1.5. Fixes bug #440994 reported Guillaume Horel, contributed together with Ivan Baidakou (dmol).
(Portage version: 2.1.12.11/cvs/Linux x86_64, signed Manifest commit with key 6D34E57D)
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/xmlgraphics-commons/ChangeLog10
-rw-r--r--dev-java/xmlgraphics-commons/files/xmlgraphics-commons-1.5-disable-iccprofile-test.patch38
-rw-r--r--dev-java/xmlgraphics-commons/xmlgraphics-commons-1.5.ebuild64
3 files changed, 111 insertions, 1 deletions
diff --git a/dev-java/xmlgraphics-commons/ChangeLog b/dev-java/xmlgraphics-commons/ChangeLog
index 187bebbc4ed3..8fc657c75579 100644
--- a/dev-java/xmlgraphics-commons/ChangeLog
+++ b/dev-java/xmlgraphics-commons/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-java/xmlgraphics-commons
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/xmlgraphics-commons/ChangeLog,v 1.24 2013/06/30 19:58:47 tomwij Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/xmlgraphics-commons/ChangeLog,v 1.25 2013/07/08 14:10:00 tomwij Exp $
+
+*xmlgraphics-commons-1.5 (08 Jul 2013)
+
+ 08 Jul 2013; Tom Wijsman <TomWij@gentoo.org>
+ +files/xmlgraphics-commons-1.5-disable-iccprofile-test.patch,
+ +xmlgraphics-commons-1.5.ebuild:
+ Version bump to 1.5. Fixes bug #440994 reported Guillaume Horel, contributed
+ together with Ivan Baidakou (dmol).
*xmlgraphics-commons-1.2-r1 (30 Jun 2013)
diff --git a/dev-java/xmlgraphics-commons/files/xmlgraphics-commons-1.5-disable-iccprofile-test.patch b/dev-java/xmlgraphics-commons/files/xmlgraphics-commons-1.5-disable-iccprofile-test.patch
new file mode 100644
index 000000000000..6d226e6e1f8f
--- /dev/null
+++ b/dev-java/xmlgraphics-commons/files/xmlgraphics-commons-1.5-disable-iccprofile-test.patch
@@ -0,0 +1,38 @@
+Description: This test fails with openjdk-7 (and oracle java 7).
+ Skip for the time being until upstream resolve - see Bug.
+Author: James Page <james.page@ubuntu.com>
+Bug: https://issues.apache.org/bugzilla/show_bug.cgi?id=53328
+
+Index: xmlgraphics-commons/test/java/org/apache/xmlgraphics/image/loader/ImageLoaderTestCase.java
+===================================================================
+--- xmlgraphics-commons.orig/test/java/org/apache/xmlgraphics/image/loader/ImageLoaderTestCase.java 2012-05-30 17:12:37.000324000 +0100
++++ xmlgraphics-commons/test/java/org/apache/xmlgraphics/image/loader/ImageLoaderTestCase.java 2012-05-30 17:13:03.184417043 +0100
+@@ -159,28 +159,6 @@
+ sessionContext.checkAllStreamsClosed();
+ }
+
+- public void testICCProfiles() throws Exception {
+- MyImageSessionContext sessionContext = createImageSessionContext();
+- List/* <ICC_Profile> */profiles = new ArrayList();
+-
+- runReaders(profiles, sessionContext, "iccTest.png", "image/png",
+- ImageFlavor.RAW_PNG);
+- runReaders(profiles, sessionContext, "iccTest.jpg", "image/jpeg",
+- ImageFlavor.RAW_JPEG);
+-
+- ICC_Profile first = (ICC_Profile) profiles.get(0);
+- byte[] firstData = first.getData();
+- for (int i = 1; i < profiles.size(); i++) {
+- ICC_Profile icc = (ICC_Profile) profiles.get(i);
+- byte[] data = icc.getData();
+- assertEquals("Embedded ICC Profiles are not the same size!",
+- firstData.length, data.length);
+- for (int j = 0; j < firstData.length; j++) {
+- assertEquals("Embedded ICC Profiles differ at index " + j,
+- firstData[j], data[j]);
+- }
+- }
+- }
+
+ private void runReaders(List profiles, ImageSessionContext isc, String uri,
+ String mime, ImageFlavor rawFlavor) throws Exception {
diff --git a/dev-java/xmlgraphics-commons/xmlgraphics-commons-1.5.ebuild b/dev-java/xmlgraphics-commons/xmlgraphics-commons-1.5.ebuild
new file mode 100644
index 000000000000..bbdcb0a0f72a
--- /dev/null
+++ b/dev-java/xmlgraphics-commons/xmlgraphics-commons-1.5.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/xmlgraphics-commons/xmlgraphics-commons-1.5.ebuild,v 1.1 2013/07/08 14:10:00 tomwij Exp $
+
+EAPI="5"
+
+JAVA_PKG_IUSE="doc examples source test"
+
+VIRTUALX_REQUIRED="manual"
+VIRTUALX_COMMAND="eant"
+
+inherit java-pkg-2 java-ant-2 virtualx
+
+DESCRIPTION="A library of several reusable components used by Apache Batik and Apache FOP."
+HOMEPAGE="http://xmlgraphics.apache.org/commons/index.html"
+SRC_URI="mirror://apache/xmlgraphics/commons/source/${P}-src.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="1.5"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+
+CDEPEND="dev-java/commons-io:1
+ >=dev-java/commons-logging-1:0"
+
+DEPEND=">=virtual/jdk-1.5
+ test? ( dev-java/ant-junit4 )
+ ${CDEPEND}"
+
+RDEPEND=">=virtual/jre-1.5
+ ${CDEPEND}"
+
+# Strategies for non sun jdk's/jre's
+
+JAVA_ANT_IGNORE_SYSTEM_CLASSES="true"
+JAVA_ANT_REWRITE_CLASSPATH="true"
+
+java_prepare() {
+ # See https://issues.apache.org/bugzilla/show_bug.cgi?id=53328
+ epatch "${FILESDIR}"/${P}-disable-iccprofile-test.patch
+
+ find "${S}" -name '*.jar' -print -delete || die
+
+ rm -v test/java/org/apache/xmlgraphics/java2d/ps/PSGraphics2DTestCase.java || die
+}
+
+EANT_GENTOO_CLASSPATH="commons-io-1,commons-logging"
+EANT_EXTRA_ARGS="-Djdk15.present=true"
+EANT_BUILD_TARGET="jar-main"
+EANT_DOC_TARGET="javadocs"
+
+src_test() {
+ java-pkg_jarfrom --into lib junit-4,commons-io-1
+
+ ANT_TASKS="ant-junit4" virtualmake -Djdk15.present=true junit
+}
+
+src_install(){
+ java-pkg_newjar build/${P}.jar
+
+ use source && java-pkg_dosrc src/java/org
+ use doc && java-pkg_dojavadoc build/javadocs
+}
+
+# TODO: Investigate producing .net libraries.