summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetteri Räty <betelgeuse@gentoo.org>2009-03-07 14:32:47 +0000
committerPetteri Räty <betelgeuse@gentoo.org>2009-03-07 14:32:47 +0000
commitc9cc3912213ccea007885237b6bf2914e43428e4 (patch)
tree102fa9ddd96e0f7b1351b91d924315835f1ed797 /dev-java
parentNew version (diff)
downloadgentoo-2-c9cc3912213ccea007885237b6bf2914e43428e4.tar.gz
gentoo-2-c9cc3912213ccea007885237b6bf2914e43428e4.tar.bz2
gentoo-2-c9cc3912213ccea007885237b6bf2914e43428e4.zip
Remove old version.
(Portage version: 2.2_rc20/cvs/Linux 2.6.29-rc6 i686)
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/qtjambi/ChangeLog6
-rw-r--r--dev-java/qtjambi/qtjambi-4.3.3_p1.ebuild106
2 files changed, 5 insertions, 107 deletions
diff --git a/dev-java/qtjambi/ChangeLog b/dev-java/qtjambi/ChangeLog
index 4742cb940cf4..9b5b04c10071 100644
--- a/dev-java/qtjambi/ChangeLog
+++ b/dev-java/qtjambi/ChangeLog
@@ -1,7 +1,11 @@
# ChangeLog for dev-java/qtjambi
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/qtjambi/ChangeLog,v 1.18 2009/03/04 09:36:28 ali_bush Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/qtjambi/ChangeLog,v 1.19 2009/03/07 14:32:47 betelgeuse Exp $
+ 07 Mar 2009; Petteri Räty <betelgeuse@gentoo.org>
+ -qtjambi-4.3.3_p1.ebuild:
+ Remove old version.
+
04 Mar 2009; Alistair Bush <ali_bush@gentoo.org>
files/configuration-4.4.3.patch:
Update to correct configuration patch. Old patch must have been applied
diff --git a/dev-java/qtjambi/qtjambi-4.3.3_p1.ebuild b/dev-java/qtjambi/qtjambi-4.3.3_p1.ebuild
deleted file mode 100644
index cffc63056167..000000000000
--- a/dev-java/qtjambi/qtjambi-4.3.3_p1.ebuild
+++ /dev/null
@@ -1,106 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/qtjambi/qtjambi-4.3.3_p1.ebuild,v 1.2 2007/12/30 17:24:29 jokey Exp $
-
-inherit eutils java-pkg-2
-
-QTVERSION=4.3.3
-PATCHRELEASE=01
-
-DESCRIPTION="QtJambi is a set of Java bindings and utilities for the Qt C++ toolkit."
-HOMEPAGE="http://www.trolltech.com/"
-
-MY_PV=${QTVERSION}_${PATCHRELEASE}
-
-SRC_URI="ftp://ftp.trolltech.com/pub/qtjambi/source/qtjambi-gpl-src-${MY_PV}.tar.gz"
-S=${WORKDIR}/qtjambi-gpl-src-${MY_PV}
-
-LICENSE="GPL-2"
-SLOT="4"
-KEYWORDS="~amd64 ~x86"
-
-IUSE=""
-
-DEPEND="~x11-libs/qt-${QTVERSION}
- >=virtual/jdk-1.5"
-
-RDEPEND="~x11-libs/qt-${QTVERSION}
- >=virtual/jre-1.5"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/generator-4.3.3.patch
- epatch "${FILESDIR}"/qtjambi_base.pri.diff
- epatch "${FILESDIR}"/jambi.pri.diff
-
- # If Qt wasn't built with accessibility use flag, then we needto remove some files from
- # the list.
- if ! built_with_use =x11-libs/qt-4* accessibility; then
- epatch "${FILESDIR}"/java_files_remove_accessibility.diff
- fi
- if ! built_with_use =x11-libs/qt-4* ssl; then
- epatch "${FILESDIR}"/java_files_remove_ssl.diff
- fi
-}
-
-src_compile() {
-
- # Step 1, build the source generator
- einfo "Building the source generator"
- cd "${S}"/generator
- /usr/bin/qmake && make || die "Error building generator"
-
- # Step 2, run the generator
- einfo "Running the generator. This may take a few minutes."
- QTDIR=/usr/include/qt4 ./generator
-
- # Step 3, build the generated sources
- export JAVADIR=$JDK_HOME
- einfo "Building the generated sources."
- cd "${S}" && /usr/bin/qmake && make || die "Error building generated sources"
-
- # Step 4, generate Ui_.java files
- einfo "Running juic"
- cd "${S}" && ./bin/juic -cp .
-
- # Step 5, compiling java files
- einfo "Compiling java files"
- mkdir -p "${S}"/class
- cd "${S}" && ejavac -d class @java_files
-
- # Step 6, build the jar file
- cd "${S}"/class && jar cf ../qtjambi.jar com/trolltech/qt com/trolltech/tools
- # copy built classes for demos and examples
- cd "${S}/class" && cp -r com/trolltech/demos com/trolltech/examples com/trolltech/launcher ../com/trolltech
- cd "${S}" && jar cf qtjambi-src.jar com
-
- # generate start scripts
- jcp="/usr/share/qtjambi-4/lib"
- cd "${S}" && echo "#!/bin/sh" > bin/jambi-designer
- cd "${S}" && echo "LD_LIBRARY_PATH=/usr/lib/qt4 CLASSPATH=${jcp}/qtjambi.jar:${jcp}/qtjambi-src.jar:$CLASSPATH /usr/bin/designer" >> bin/jambi-designer
-
- cd "${S}" && echo "#!/bin/sh" > bin/jambi
- cd "${S}" && echo "LD_LIBRARY_PATH=/usr/lib/qt4 java -cp ${jcp}/qtjambi.jar:${jcp}/qtjambi-src.jar com.trolltech.launcher.Launcher" >> bin/jambi
-}
-
-src_install() {
- # Install built jar
- java-pkg_dojar qtjambi.jar
- java-pkg_dojar qtjambi-src.jar
-
- # Install designer plugins
- insinto "/usr/$(get_libdir)/qt4/plugins/designer"
- insopts -m0755
- doins plugins/designer/*.so
-
- cp -dpPR "${S}"/lib/* "${D}/usr/$(get_libdir)/qt4"
-
- # Install binaries
- dobin bin/*
-
- einfo "eclipse - Project->Properties->Java Build Path->Libraries:"
- einfo "library: /usr/share/qtjambi-4/lib/qtjambi.jar"
- einfo "source (& demos): /usr/share/qtjambi-4/lib/qtjambi-src.jar"
- einfo "native library location: /usr/$(get_libdir)/qt4/"
-}