summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVlastimil Babka <caster@gentoo.org>2011-11-04 11:19:09 +0000
committerVlastimil Babka <caster@gentoo.org>2011-11-04 11:19:09 +0000
commitc485805c10b8c1e585572f55d3f66adcd8205f45 (patch)
tree836a2c19e47a6704d50651e48ba6d885e9f07e4e /dev-java
parentVersion bump. Address underlinking as pointed out by Diego Elio Pettenò in b... (diff)
downloadgentoo-2-c485805c10b8c1e585572f55d3f66adcd8205f45.tar.gz
gentoo-2-c485805c10b8c1e585572f55d3f66adcd8205f45.tar.bz2
gentoo-2-c485805c10b8c1e585572f55d3f66adcd8205f45.zip
Add icedtea-web:7 slot for icedtea-7.
(Portage version: 2.2.0_alpha68/cvs/Linux x86_64)
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/icedtea-web/ChangeLog8
-rw-r--r--dev-java/icedtea-web/icedtea-web-1.1.3-r7.ebuild149
2 files changed, 156 insertions, 1 deletions
diff --git a/dev-java/icedtea-web/ChangeLog b/dev-java/icedtea-web/ChangeLog
index 169c19237ea9..7e5f894b4efa 100644
--- a/dev-java/icedtea-web/ChangeLog
+++ b/dev-java/icedtea-web/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-java/icedtea-web
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/icedtea-web/ChangeLog,v 1.12 2011/11/04 09:39:42 caster Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/icedtea-web/ChangeLog,v 1.13 2011/11/04 11:19:09 caster Exp $
+
+*icedtea-web-1.1.3-r7 (04 Nov 2011)
+
+ 04 Nov 2011; Vlastimil Babka <caster@gentoo.org>
+ +icedtea-web-1.1.3-r7.ebuild:
+ Add icedtea-web:7 slot for icedtea-7.
04 Nov 2011; Vlastimil Babka <caster@gentoo.org> -icedtea-web-1.1.1.ebuild,
-icedtea-web-1.1.2.ebuild, -icedtea-web-1.1.2-r1.ebuild,
diff --git a/dev-java/icedtea-web/icedtea-web-1.1.3-r7.ebuild b/dev-java/icedtea-web/icedtea-web-1.1.3-r7.ebuild
new file mode 100644
index 000000000000..52ffe6ae8a95
--- /dev/null
+++ b/dev-java/icedtea-web/icedtea-web-1.1.3-r7.ebuild
@@ -0,0 +1,149 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/icedtea-web/icedtea-web-1.1.3-r7.ebuild,v 1.1 2011/11/04 11:19:09 caster Exp $
+# Build written by Andrew John Hughes (ahughes@redhat.com)
+
+EAPI="2"
+
+inherit autotools eutils java-pkg-2 java-vm-2
+
+LICENSE="GPL-2 GPL-2-with-linking-exception LGPL-2"
+SLOT="7"
+KEYWORDS="~amd64"
+
+DESCRIPTION="FOSS Java browser plugin and Web Start implementation"
+SRC_URI="http://icedtea.classpath.org/download/source/${P}.tar.gz"
+HOMEPAGE="http://icedtea.classpath.org"
+
+IUSE="build doc +nsplugin"
+
+RDEPEND="dev-java/icedtea:${SLOT}"
+DEPEND="${RDEPEND}
+ nsplugin? (
+ || ( net-misc/npapi-sdk
+ >=net-libs/xulrunner-1.9.1 ) )"
+
+# a bit of hack so the VM switching is triggered without causing dependency troubles
+JAVA_PKG_NV_DEPEND=">=virtual/jdk-1.6"
+JAVA_PKG_WANT_SOURCE="1.6"
+JAVA_PKG_WANT_TARGET="1.6"
+
+pkg_setup() {
+ # quite a hack since java-config does not provide a way for a package
+ # to limit supported VM's for building and their preferred order
+ if [[ -n "${JAVA_PKG_FORCE_VM}" ]]; then
+ einfo "Honoring user-set JAVA_PKG_FORCE_VM"
+ elif has_version dev-java/icedtea:${SLOT}; then
+ # migration logic
+ if [[ -L /usr/lib/jvm/icedtea${SLOT} ]]; then
+ JAVA_PKG_FORCE_VM="icedtea${SLOT}"
+ else
+ JAVA_PKG_FORCE_VM="icedtea-${SLOT}"
+ fi
+ else
+ JAVA_PKG_FORCE_VM=""
+ # don't die just yet if merging a binpkg - bug #258423
+ DIE_IF_NOT_BINPKG=true
+ fi
+
+ # if the previous failed, don't even run java eclasses pkg_setup
+ # as it might also die when no VM is present
+ if [[ -n "${JAVA_PKG_FORCE_VM}" ]]; then
+ einfo "Forced vm ${JAVA_PKG_FORCE_VM}"
+ java-vm-2_pkg_setup
+ java-pkg-2_pkg_setup
+ fi
+}
+
+unset_vars() {
+ unset JAVA_HOME JDK_HOME CLASSPATH JAVAC JAVACFLAGS
+}
+
+src_unpack() {
+ if [[ -n ${DIE_IF_NOT_BINPKG} ]]; then
+ die "Unable to find a supported VM for building"
+ fi
+
+ default
+}
+
+src_prepare() {
+ # bug #356645
+ epatch "${FILESDIR}"/0002-Respect-LDFLAGS.patch
+ eautoreconf
+}
+
+src_configure() {
+ local vmhome=$(java-config -O)
+
+ if use build; then
+ icedteadir="${ICEDTEA_BIN_DIR}"
+ installdir="/opt/icedtea${SLOT}-web-bin"
+ else
+ icedteadir="/usr/$(get_libdir)/icedtea${SLOT}"
+ installdir="/usr/$(get_libdir)/icedtea${SLOT}-web"
+ fi
+
+ unset_vars
+
+ if use build || [[ ${vmhome} == ${icedteadir} ]] ; then
+ VMHANDLE="icedtea${SLOT}"
+ else
+ die "Unexpected install location of IcedTea${SLOT}"
+ fi
+
+ einfo "Installing IcedTea-Web in ${installdir}"
+ einfo "Installing IcedTea-Web for Icedtea${SLOT} in ${icedteadir}"
+ if [ ! -e ${vmhome} ] ; then
+ eerror "Could not find JDK install directory ${vmhome}."
+ die
+ fi
+
+ # we need to override all *dir variables that econf sets
+ # man page (javaws) is installed directly to icedteadir because it's easier than symlinking, as we don't know
+ # the suffix the man page will end up compressed with, anyway
+ econf \
+ --prefix=${installdir} --mandir=${icedteadir}/man --infodir=${installdir}/share/info --datadir=${installdir}/share \
+ --with-jdk-home=${icedteadir} \
+ $(use_enable doc docs) \
+ $(use_enable nsplugin plugin) \
+ || die "configure failed"
+}
+
+src_compile() {
+ # we need this to override the src_compile from java-pkg-2
+ default
+}
+
+src_install() {
+ # parallel make problem bug #372235
+ emake -j1 DESTDIR="${D}" install || die "Install failed"
+ dodoc AUTHORS README NEWS || die
+
+ if use nsplugin; then
+ local arch=${ARCH};
+ use x86 && arch=i386;
+ install_mozilla_plugin "${installdir}/$(get_libdir)/IcedTeaPlugin.so";
+ fi
+
+ for binary in javaws itweb-settings; do
+ dosym ${installdir}/bin/${binary} ${icedteadir}/bin/${binary}
+ dosym ${installdir}/bin/${binary} ${icedteadir}/jre/bin/${binary}
+ done
+}
+
+pkg_postinst() {
+ java-vm_check-nsplugin
+ java_mozilla_clean_
+
+ if use nsplugin; then
+ elog "The icedtea browser plugin (NPPlugin) can be enabled using eselect java-nsplugin"
+ elog "Note that the plugin works only in browsers based on xulrunner-1.9.1 or later"
+ elog "such as Firefox 3.5+, Chromium and perhaps some others too."
+ fi
+}
+
+pkg_prerm() {
+ # override the java-vm-2 eclass check for removing a system VM, as it doesn't make sense here
+ :;
+}