summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVlastimil Babka <caster@gentoo.org>2013-11-11 07:08:10 +0000
committerVlastimil Babka <caster@gentoo.org>2013-11-11 07:08:10 +0000
commitb6c929ea5284eb7ec941713df8a58e6b4fadbc4d (patch)
tree4ea21b4788356f43231ec719265a0386537d2d3c /dev-java
parentIntroduce icedtea7 USE flag, as it turns out that icedtea-web built with iced... (diff)
downloadgentoo-2-b6c929ea5284eb7ec941713df8a58e6b4fadbc4d.tar.gz
gentoo-2-b6c929ea5284eb7ec941713df8a58e6b4fadbc4d.tar.bz2
gentoo-2-b6c929ea5284eb7ec941713df8a58e6b4fadbc4d.zip
Version bump, security bug #489570. Now depends on icedtea-web for the nsplugin.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 4E61DE84)
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/icedtea-bin/ChangeLog8
-rw-r--r--dev-java/icedtea-bin/icedtea-bin-7.2.4.3.ebuild151
2 files changed, 158 insertions, 1 deletions
diff --git a/dev-java/icedtea-bin/ChangeLog b/dev-java/icedtea-bin/ChangeLog
index df89e3828682..d395e0b3a2da 100644
--- a/dev-java/icedtea-bin/ChangeLog
+++ b/dev-java/icedtea-bin/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-java/icedtea-bin
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/icedtea-bin/ChangeLog,v 1.52 2013/09/10 03:31:48 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/icedtea-bin/ChangeLog,v 1.53 2013/11/11 07:08:10 caster Exp $
+
+*icedtea-bin-7.2.4.3 (11 Nov 2013)
+
+ 11 Nov 2013; Vlastimil Babka <caster@gentoo.org> +icedtea-bin-7.2.4.3.ebuild:
+ Version bump, security bug #489570. Now depends on icedtea-web for the
+ nsplugin.
10 Sep 2013; Patrick Lauer <patrick@gentoo.org> icedtea-bin-7.2.3.9.ebuild,
icedtea-bin-7.2.4.1.ebuild:
diff --git a/dev-java/icedtea-bin/icedtea-bin-7.2.4.3.ebuild b/dev-java/icedtea-bin/icedtea-bin-7.2.4.3.ebuild
new file mode 100644
index 000000000000..c38606c97355
--- /dev/null
+++ b/dev-java/icedtea-bin/icedtea-bin-7.2.4.3.ebuild
@@ -0,0 +1,151 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/icedtea-bin/icedtea-bin-7.2.4.3.ebuild,v 1.1 2013/11/11 07:08:10 caster Exp $
+
+EAPI="5"
+
+inherit java-vm-2 multilib prefix versionator
+
+dist="http://dev.gentoo.org/~caster/distfiles/"
+TARBALL_VERSION="${PV}"
+PLUGIN_VERSION="${PVR}"
+
+DESCRIPTION="A Gentoo-made binary build of the IcedTea JDK"
+HOMEPAGE="http://icedtea.classpath.org"
+SRC_URI="
+ amd64? ( ${dist}/${PN}-core-${TARBALL_VERSION}-amd64.tar.bz2
+ ${dist}/${PN}-libpng15-${TARBALL_VERSION}-amd64.tar.bz2 )
+ x86? ( ${dist}/${PN}-core-${TARBALL_VERSION}-x86.tar.bz2
+ ${dist}/${PN}-libpng15-${TARBALL_VERSION}-x86.tar.bz2 )
+ doc? ( ${dist}/${PN}-doc-${TARBALL_VERSION}.tar.bz2 )
+ examples? (
+ amd64? ( ${dist}/${PN}-examples-${TARBALL_VERSION}-amd64.tar.bz2 )
+ x86? ( ${dist}/${PN}-examples-${TARBALL_VERSION}-x86.tar.bz2 )
+ )
+ source? ( ${dist}/${PN}-src-${TARBALL_VERSION}.tar.bz2 )"
+
+LICENSE="GPL-2-with-linking-exception"
+SLOT="7"
+KEYWORDS="-* ~amd64 ~x86"
+
+IUSE="+X +alsa cjk +cups doc examples nsplugin source"
+REQUIRED_USE="nsplugin? ( X )"
+RESTRICT="strip"
+
+# 423161
+QA_PREBUILT="opt/.*"
+
+ALSA_COMMON_DEP="
+ >=media-libs/alsa-lib-1.0.20"
+CUPS_COMMON_DEP="
+ >=net-print/cups-1.4"
+X_COMMON_DEP="
+ >=dev-libs/atk-1.30.0
+ >=dev-libs/glib-2.20.5:2
+ >=media-libs/fontconfig-2.6.0-r2:1.0
+ >=media-libs/freetype-2.4.9:2
+ >=x11-libs/cairo-1.8.8
+ x11-libs/gdk-pixbuf:2
+ >=x11-libs/gtk+-2.24:2
+ >=x11-libs/libX11-1.4
+ >=x11-libs/libXext-1.3
+ >=x11-libs/libXi-1.6
+ x11-libs/libXrender
+ >=x11-libs/libXtst-1.2
+ >=x11-libs/pango-1.24.5"
+
+COMMON_DEP="
+ >=media-libs/giflib-4.1.6-r1
+ media-libs/lcms:2
+ >=media-libs/libpng-1.5:0=
+ >=sys-devel/gcc-4.5.4
+ >=sys-libs/glibc-2.15
+ >=sys-libs/zlib-1.2.3-r1
+ || ( virtual/jpeg:62 media-libs/jpeg:62 )"
+
+# cups is needed for X. #390945 #390975
+RDEPEND="${COMMON_DEP}
+ X? (
+ ${CUPS_COMMON_DEP}
+ ${X_COMMON_DEP}
+ media-fonts/dejavu
+ cjk? (
+ media-fonts/arphicfonts
+ media-fonts/baekmuk-fonts
+ media-fonts/lklug
+ media-fonts/lohit-fonts
+ media-fonts/sazanami
+ )
+ )
+ alsa? ( ${ALSA_COMMON_DEP} )
+ cups? ( ${CUPS_COMMON_DEP} )"
+
+PDEPEND="nsplugin? ( dev-java/icedtea-web:0[icedtea7,nsplugin] )"
+
+src_unpack() {
+ unpack ${A}
+
+ if has_version '=media-libs/libpng-1.5*:0'; then
+ einfo "Installing libpng-1.5 ABI version"
+ local arch=${ARCH}
+ use x86 && arch=i386
+ mv -v ${PN}-libpng15-${PV}/jre/lib/${arch}/*.so ${P}/jre/lib/${arch} || die
+ else
+ einfo "Installing libpng-1.6 ABI version"
+ fi
+}
+
+src_install() {
+ local dest="/opt/${P}"
+ local ddest="${ED}/${dest}"
+ dodir "${dest}"
+
+ # Ensures HeadlessGraphicsEnvironment is used.
+ if ! use X; then
+ rm -r jre/lib/$(get_system_arch)/xawt || die
+ fi
+
+ # doins can't handle symlinks.
+ cp -pRP bin include jre lib man "${ddest}" || die
+
+ # Remove on next bump as the needed marks are already set by icedtea ebuild.
+ java-vm_set-pax-markings "${ddest}"
+
+ dodoc ../doc/{ASSEMBLY_EXCEPTION,THIRD_PARTY_README}
+
+ if use doc; then
+ dohtml -r ../doc/html/*
+ fi
+
+ if use examples; then
+ cp -pRP share/{demo,sample} "${ddest}" || die
+ fi
+
+ if use source; then
+ cp src.zip "${ddest}" || die
+ fi
+
+ # Remove after next bump, handled by icedtea ebuild. Bug 390663
+ cp "${FILESDIR}"/fontconfig.Gentoo.properties.src "${T}"/fontconfig.Gentoo.properties || die
+ eprefixify "${T}"/fontconfig.Gentoo.properties
+ insinto "${dest}"/jre/lib
+ doins "${T}"/fontconfig.Gentoo.properties
+
+ set_java_env
+ java-vm_revdep-mask "${dest}"
+ java-vm_sandbox-predict /proc/self/coredump_filter
+}
+
+pkg_postinst() {
+ if use nsplugin; then
+ if [[ -n ${REPLACING_VERSIONS} ]] && ! version_is_at_least 7.2.4.3 ${REPLACING_VERSIONS} ]]; then
+ elog "The nsplugin for icedtea-bin is now provided by the icedtea-web package"
+ elog "If you had icedtea-bin-7 nsplugin selected, you may see a related error below"
+ elog "The switch should complete properly during the subsequent installation of icedtea-web"
+ elog "Afterwards you may verify the output of 'eselect java-nsplugin list' and adjust accordingly'"
+ fi
+ fi
+
+ # Set as default VM if none exists
+ java-vm-2_pkg_postinst
+}