summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVlastimil Babka <caster@gentoo.org>2006-10-22 22:48:36 +0000
committerVlastimil Babka <caster@gentoo.org>2006-10-22 22:48:36 +0000
commitb278aac4b0448236f2d0a91adc66e0ab45e4e976 (patch)
tree57913235b9557e7509f7443631077baafd148185 /dev-java
parent0.14.3-r1 have to be ~all for now (diff)
downloadgentoo-2-b278aac4b0448236f2d0a91adc66e0ab45e4e976.tar.gz
gentoo-2-b278aac4b0448236f2d0a91adc66e0ab45e4e976.tar.bz2
gentoo-2-b278aac4b0448236f2d0a91adc66e0ab45e4e976.zip
Version bump, reported by M. Edward Borasky <znmeb@cesmail.net> in bug #152309.
(Portage version: 2.1.2_pre3-r5)
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/jruby/ChangeLog9
-rw-r--r--dev-java/jruby/files/digest-jruby-0.9.13
-rw-r--r--dev-java/jruby/files/jruby-0.9.1-build.xml.patch21
-rw-r--r--dev-java/jruby/jruby-0.9.0.ebuild5
-rw-r--r--dev-java/jruby/jruby-0.9.1.ebuild85
5 files changed, 119 insertions, 4 deletions
diff --git a/dev-java/jruby/ChangeLog b/dev-java/jruby/ChangeLog
index 309479ef6ef3..0d50293e5df1 100644
--- a/dev-java/jruby/ChangeLog
+++ b/dev-java/jruby/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-java/jruby
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/jruby/ChangeLog,v 1.9 2006/10/22 08:17:08 betelgeuse Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jruby/ChangeLog,v 1.10 2006/10/22 22:48:36 caster Exp $
+
+*jruby-0.9.1 (22 Oct 2006)
+
+ 22 Oct 2006; Vlastimil Babka <caster@gentoo.org>
+ +files/jruby-0.9.1-build.xml.patch, jruby-0.9.0.ebuild,
+ +jruby-0.9.1.ebuild:
+ Version bump, reported by M. Edward Borasky <znmeb@cesmail.net> in bug #152309.
22 Oct 2006; Petteri Räty <betelgeuse@gentoo.org> metadata.xml:
Fixed metadata.xml by changing the herd from jruby to java.
diff --git a/dev-java/jruby/files/digest-jruby-0.9.1 b/dev-java/jruby/files/digest-jruby-0.9.1
new file mode 100644
index 000000000000..2055cd62dbe5
--- /dev/null
+++ b/dev-java/jruby/files/digest-jruby-0.9.1
@@ -0,0 +1,3 @@
+MD5 579d2885623d4ec730d829d2b268bb6e jruby-src-0.9.1.tar.gz 2898463
+RMD160 edfebe6c2a539e03aed2863d44d225f1f103f77f jruby-src-0.9.1.tar.gz 2898463
+SHA256 5c5904caf3421063b03498263528e303ab71f49105f90b8358c7a2989191edc9 jruby-src-0.9.1.tar.gz 2898463
diff --git a/dev-java/jruby/files/jruby-0.9.1-build.xml.patch b/dev-java/jruby/files/jruby-0.9.1-build.xml.patch
new file mode 100644
index 000000000000..c95b83f1a186
--- /dev/null
+++ b/dev-java/jruby/files/jruby-0.9.1-build.xml.patch
@@ -0,0 +1,21 @@
+--- build.xml 2006-10-23 00:24:34.000000000 +0200
++++ build.xml 2006-10-23 00:25:19.000000000 +0200
+@@ -188,7 +188,7 @@
+
+ <target name="test" depends="copy-test-files,instrument,run-junit,coverage-report"/>
+ <target name="run-junit" description="runs junit tests">
+- <junit fork="yes" haltonfailure="false" dir="${basedir}" maxmemory="256M">
++ <junit fork="yes" haltonfailure="true" dir="${basedir}" maxmemory="256M">
+ <classpath>
+ <pathelement location="${jruby.instrumented.classes.dir}" />
+ <path refid="build.classpath"/>
+@@ -218,8 +218,7 @@
+ description="Creates the Java API docs">
+ <javadoc destdir="${api.docs.dir}" author="true" version="true" use="true"
+ windowtitle="JRuby API" source="${javac.version}">
+- <fileset dir="${src.dir}"/>
+- <fileset dir="${test.dir}"/>
++ <fileset dir="${src.dir}" includes="**/*.java"/>
+ <doctitle><![CDATA[<h1>JRuby</h1>]]></doctitle>
+ <bottom><![CDATA[<i>Copyright &#169; 2002-2006 JRuby Team. All Rights Reserved.</i>]]></bottom>
+ </javadoc>
diff --git a/dev-java/jruby/jruby-0.9.0.ebuild b/dev-java/jruby/jruby-0.9.0.ebuild
index ce42b7fd12c7..f7339cbaff7e 100644
--- a/dev-java/jruby/jruby-0.9.0.ebuild
+++ b/dev-java/jruby/jruby-0.9.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/jruby/jruby-0.9.0.ebuild,v 1.1 2006/09/30 02:25:15 nichoj Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jruby/jruby-0.9.0.ebuild,v 1.2 2006/10/22 22:48:36 caster Exp $
inherit java-pkg-2 java-ant-2
@@ -47,7 +47,7 @@ src_install() {
if use doc; then
java-pkg_dohtml -r docs/api/*
docinto docs
- dodoc *.*
+ dodoc docs/*
fi
use source && java-pkg_dosrc src/org
java-pkg_dolauncher jruby \
@@ -64,7 +64,6 @@ src_install() {
dobin ${S}/bin/jirb
dodir /usr/share/${PN}/lib
- cp -a ${S}/lib/*.jar
insinto /usr/share/${PN}/lib
doins -r ${S}/lib/ruby
diff --git a/dev-java/jruby/jruby-0.9.1.ebuild b/dev-java/jruby/jruby-0.9.1.ebuild
new file mode 100644
index 000000000000..73d0ba654fef
--- /dev/null
+++ b/dev-java/jruby/jruby-0.9.1.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jruby/jruby-0.9.1.ebuild,v 1.1 2006/10/22 22:48:36 caster Exp $
+
+inherit eutils java-pkg-2 java-ant-2
+
+DESCRIPTION="Java based ruby interpreter implementation"
+HOMEPAGE="http://${PN}.codehaus.org/"
+SRC_URI="http://dist.codehaus.org/${PN}/${PN}-src-${PV}.tar.gz"
+
+LICENSE="|| ( CPL-1.0 GPL-2 LGPL-2.1 )"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc source test"
+
+COMMON_DEPEND="dev-java/jvyaml
+ =dev-java/asm-2.2*
+ =dev-java/bsf-2.3*"
+RDEPEND=">=virtual/jre-1.4
+ ${COMMON_DEPEND}"
+DEPEND=">=virtual/jdk-1.4
+ !test? ( dev-java/ant-core )
+ test? (
+ dev-java/junit
+ dev-java/ant
+ )
+ source? ( app-arch/zip )
+ ${COMMON_DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # fix javadoc, make tests halt on failure
+ epatch "${FILESDIR}/${P}-build.xml.patch"
+
+ cd lib
+ # created by jruby dev, but no source available, so use bundled
+ mv plaincharset.jar "${T}"
+ rm -rf *.jar
+ mv "${T}/plaincharset.jar" .
+
+ java-pkg_jar-from --build-only ant-core ant.jar
+ java-pkg_jar-from asm-2.2 asm.jar
+ java-pkg_jar-from bsf-2.3
+ java-pkg_jar-from jvyaml
+ use test && java-pkg_jar-from --build-only junit
+}
+src_compile() {
+ eant jar $(use_doc create-apidocs)
+}
+
+src_test() {
+ eant test
+}
+
+src_install() {
+ java-pkg_dojar "lib/${PN}.jar"
+ java-pkg_dojar "lib/plaincharset.jar"
+
+ dodoc README COPYING COPYING.CPL COPYING.GPL COPYING.LGPL
+
+ if use doc; then
+ java-pkg_dojavadoc docs/api
+ docinto docs
+ dodoc docs/*
+ fi
+ use source && java-pkg_dosrc src/org
+ java-pkg_dolauncher jruby \
+ --main 'org.jruby.Main' \
+ --java_args '-Djruby.base=/usr/share/jruby -Djruby.home=/usr/share/jruby -Djruby.lib=/usr/share/jruby/lib -Djruby.script=jruby -Djruby.shell=/bin/sh'
+ newbin ${S}/bin/gem jgem
+ newbin ${S}/bin/gem_server jgem_server
+ newbin ${S}/bin/gemlock jgem_lock
+ newbin ${S}/bin/gemri jgemri
+ newbin ${S}/bin/gemwhich jgemwhich
+ newbin ${S}/bin/update_rubygems jupdate_rubygems
+ newbin ${S}/bin/generate_yaml_index.rb jgenerate_yaml_index.rb
+ newbin ${S}/bin/index_gem_repository.rb jindex_gem_repository.rb
+ dobin ${S}/bin/jirb
+
+ dodir "/usr/share/${PN}/lib"
+ insinto "/usr/share/${PN}/lib"
+ doins -r "${S}/lib/ruby"
+}