summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlistair Bush <ali_bush@gentoo.org>2009-12-09 09:48:05 +0000
committerAlistair Bush <ali_bush@gentoo.org>2009-12-09 09:48:05 +0000
commitacf941553e3929bc398b7eb22e039be5bfdaa40c (patch)
tree4adc74cb2ee46543cefe487963179e9d4141de04 /dev-java
parentVersion bump. (diff)
downloadgentoo-2-acf941553e3929bc398b7eb22e039be5bfdaa40c.tar.gz
gentoo-2-acf941553e3929bc398b7eb22e039be5bfdaa40c.tar.bz2
gentoo-2-acf941553e3929bc398b7eb22e039be5bfdaa40c.zip
Move into main tree to await the arrival of eclipse-sdk.
(Portage version: 2.1.7.10/cvs/Linux x86_64)
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/sat4j-core/ChangeLog14
-rw-r--r--dev-java/sat4j-core/metadata.xml6
-rw-r--r--dev-java/sat4j-core/sat4j-core-2.1.ebuild58
3 files changed, 78 insertions, 0 deletions
diff --git a/dev-java/sat4j-core/ChangeLog b/dev-java/sat4j-core/ChangeLog
new file mode 100644
index 000000000000..80be9220d0b5
--- /dev/null
+++ b/dev-java/sat4j-core/ChangeLog
@@ -0,0 +1,14 @@
+# ChangeLog for dev-java/sat4j-core
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/sat4j-core/ChangeLog,v 1.1 2009/12/09 09:48:05 ali_bush Exp $
+
+ 09 Dec 2009; Alistair Bush <ali_bush@gentoo.org> +sat4j-core-2.1.ebuild,
+ +metadata.xml:
+ Move into main tree to await the arrival of eclipse-sdk.
+
+*sat4j-core-2.1 (03 Nov 2009)
+
+ 03 Nov 2009; Alistair Bush <ali_bush@gentoo.org> +sat4j-core-2.1.ebuild,
+ +metadata.xml:
+ New Ebuild based on the work done by Matt Whitlock <matt@whitlock.name>
+
diff --git a/dev-java/sat4j-core/metadata.xml b/dev-java/sat4j-core/metadata.xml
new file mode 100644
index 000000000000..604e0a4238bb
--- /dev/null
+++ b/dev-java/sat4j-core/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>java</herd>
+</pkgmetadata>
+
diff --git a/dev-java/sat4j-core/sat4j-core-2.1.ebuild b/dev-java/sat4j-core/sat4j-core-2.1.ebuild
new file mode 100644
index 000000000000..4dc729c27a2b
--- /dev/null
+++ b/dev-java/sat4j-core/sat4j-core-2.1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/sat4j-core/sat4j-core-2.1.ebuild,v 1.1 2009/12/09 09:48:05 ali_bush Exp $
+
+EAPI="2"
+
+MY_PN="org.${PN//-/.}"
+MY_PV="20090520"
+BUILD_PV="2.4"
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="Lightweight constraint programming with a SAT solver"
+HOMEPAGE="http://www.sat4j.org/"
+SRC_URI="http://download.forge.objectweb.org/sat4j/${PN}-v${MY_PV}.zip
+ http://download.forge.objectweb.org/sat4j/build-${BUILD_PV}.xml -> ${P}-build.xml"
+LICENSE="LGPL-2.1"
+SLOT="2"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=virtual/jre-1.5"
+DEPEND=">=virtual/jdk-1.5"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ unpack ${PN}-v${MY_PV}.zip
+}
+
+java_prepare() {
+ mkdir -p core/{lib,src} || die
+
+ # Don't complain about missing javadoc stylesheet.
+ touch core/lib/stylesheet.css
+
+ # Grab build.xml. Don't fetch from CVS.
+ sed 's/depends="prepare,getsource"/depends="prepare"/g' \
+ "${DISTDIR}/${P}-build.xml" > build.xml || die
+
+ # Unpack manifest.
+ cd core || die
+ jar xf "${WORKDIR}/${MY_PN}.jar" META-INF || die
+
+ # Unpack sources.
+ cd src || die
+ jar xf "${WORKDIR}/${MY_PN}-src.jar" || die
+}
+
+EANT_BUILD_TARGET="core"
+EANT_DOC_TARGET="javadoc -Dmodule=core -Dlib=core/lib"
+
+src_install() {
+ java-pkg_dojar dist/CUSTOM/${MY_PN}.jar
+ use doc && java-pkg_dojavadoc api/core
+ use source && java-pkg_dosrc core/src/org
+}