summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Wijsman <tomwij@gentoo.org>2013-05-09 12:57:14 +0000
committerTom Wijsman <tomwij@gentoo.org>2013-05-09 12:57:14 +0000
commita8be9177b834c7e20d92ab11f04c80609950c8f4 (patch)
treecba778daf0e6275abb546051f40a29e63ad6c3cd /dev-java
parentmigrate -> distutils-r1, change license to correct version of Apache, fixes B... (diff)
downloadgentoo-2-a8be9177b834c7e20d92ab11f04c80609950c8f4.tar.gz
gentoo-2-a8be9177b834c7e20d92ab11f04c80609950c8f4.tar.bz2
gentoo-2-a8be9177b834c7e20d92ab11f04c80609950c8f4.zip
EAPI 5. Version bump to 3.7, depend on at least Java 1.5. Fixes bug #458264.
(Portage version: 2.1.11.63/cvs/Linux x86_64, signed Manifest commit with key 6D34E57D)
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/sablecc/ChangeLog10
-rw-r--r--dev-java/sablecc/sablecc-3.7.ebuild40
2 files changed, 47 insertions, 3 deletions
diff --git a/dev-java/sablecc/ChangeLog b/dev-java/sablecc/ChangeLog
index 45a744bb1e13..f4e501caddd4 100644
--- a/dev-java/sablecc/ChangeLog
+++ b/dev-java/sablecc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-java/sablecc
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/sablecc/ChangeLog,v 1.22 2010/05/24 15:03:12 caster Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/sablecc/ChangeLog,v 1.23 2013/05/09 12:57:14 tomwij Exp $
+
+*sablecc-3.7 (09 May 2013)
+
+ 09 May 2013; Tom Wijsman <TomWij@gentoo.org> +sablecc-3.7.ebuild:
+ EAPI 5. Version bump to 3.7, depend on at least Java 1.5. Fixes bug #458264.
24 May 2010; Vlastimil Babka <caster@gentoo.org> -sablecc-3.1-r1.ebuild:
Remove old.
@@ -77,4 +82,3 @@
17 Feb 2004; Chris Aniszczyk <zx@gentoo.org> sablecc-2.18.2.ebuild:
Initial Import. Thanks to Kaleb Pederson <kibab@icehouse.net> for the initial
ebuild. Bug #40321
-
diff --git a/dev-java/sablecc/sablecc-3.7.ebuild b/dev-java/sablecc/sablecc-3.7.ebuild
new file mode 100644
index 000000000000..1fa9671b9a15
--- /dev/null
+++ b/dev-java/sablecc/sablecc-3.7.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/sablecc/sablecc-3.7.ebuild,v 1.1 2013/05/09 12:57:14 tomwij Exp $
+
+EAPI="5"
+
+JAVA_PKG_IUSE="source"
+JAVA_PKG_FILTER_COMPILER="jikes"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="Java based compiler / parser generator"
+HOMEPAGE="http://www.sablecc.org/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND=">=virtual/jre-1.5"
+DEPEND=">=virtual/jdk-1.5"
+
+src_unpack() {
+ unpack ${A}
+}
+
+src_prepare() {
+ rm -v "${S}"/lib/*.jar || die
+}
+
+src_install() {
+ java-pkg_dojar lib/*
+
+ dobin "${FILESDIR}"/${PN}
+
+ dodoc AUTHORS THANKS
+ dohtml README.html
+
+ use source && java-pkg_dosrc src/*
+}