summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Brinkmann <luckyduck@gentoo.org>2005-04-28 19:18:51 +0000
committerJan Brinkmann <luckyduck@gentoo.org>2005-04-28 19:18:51 +0000
commit8c76247f05cb2014c88bb9578e72eac6bb83d009 (patch)
tree1a3b9bfb4ddbcd3373c10c0705366529c6f86ac7 /dev-java
parentcleaning up (diff)
downloadgentoo-2-8c76247f05cb2014c88bb9578e72eac6bb83d009.tar.gz
gentoo-2-8c76247f05cb2014c88bb9578e72eac6bb83d009.tar.bz2
gentoo-2-8c76247f05cb2014c88bb9578e72eac6bb83d009.zip
stable on amd64, ppc and x86. introduced support for the jikes and the source useflag
(Portage version: 2.0.51.19)
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/icu4j/ChangeLog8
-rw-r--r--dev-java/icu4j/Manifest4
-rw-r--r--dev-java/icu4j/icu4j-3.0.ebuild14
3 files changed, 17 insertions, 9 deletions
diff --git a/dev-java/icu4j/ChangeLog b/dev-java/icu4j/ChangeLog
index aed6c7acf57e..48466be19a95 100644
--- a/dev-java/icu4j/ChangeLog
+++ b/dev-java/icu4j/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-java/icu4j
-# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/icu4j/ChangeLog,v 1.4 2004/10/20 08:24:17 absinthe Exp $
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/icu4j/ChangeLog,v 1.5 2005/04/28 19:18:51 luckyduck Exp $
+
+ 28 Apr 2005; Jan Brinkmann <luckyduck@gentoo.org> icu4j-3.0.ebuild:
+ stable on amd64, ppc and x86. introduced support for the jikes and the source
+ useflag
20 Oct 2004; Dylan Carlson <absinthe@gentoo.org> icu4j-3.0.ebuild:
Keywords ~amd64.
diff --git a/dev-java/icu4j/Manifest b/dev-java/icu4j/Manifest
index f1ba400104b0..fcb2fb04557d 100644
--- a/dev-java/icu4j/Manifest
+++ b/dev-java/icu4j/Manifest
@@ -1,4 +1,4 @@
-MD5 ee48b15853cd567b2332af8714f6e1e2 ChangeLog 704
-MD5 1e3a9108264cf50c30e425297c4b2baf icu4j-3.0.ebuild 971
+MD5 18a5dde721072bb908f637a4f7501349 icu4j-3.0.ebuild 1134
+MD5 a6bff4e8aa7f9de13a4b230655121032 ChangeLog 865
MD5 4dad079a28768d183022cff420f01281 metadata.xml 220
MD5 998429fb6f6a9beb6ff4899735f0e32b files/digest-icu4j-3.0 125
diff --git a/dev-java/icu4j/icu4j-3.0.ebuild b/dev-java/icu4j/icu4j-3.0.ebuild
index e5230e41f0f8..9466ee99c55d 100644
--- a/dev-java/icu4j/icu4j-3.0.ebuild
+++ b/dev-java/icu4j/icu4j-3.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/icu4j/icu4j-3.0.ebuild,v 1.4 2004/10/20 08:24:17 absinthe Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/icu4j/icu4j-3.0.ebuild,v 1.5 2005/04/28 19:18:51 luckyduck Exp $
inherit java-pkg
@@ -12,10 +12,12 @@ SRC_URI="ftp://www-126.ibm.com/pub/icu4j/${PV}/${PN}src_${MY_PV}.jar
doc? ( ftp://www-126.ibm.com/pub/icu4j/${PV}/${PN}docs_${MY_PV}.jar )"
LICENSE="icu"
SLOT="0"
-KEYWORDS="~x86 ~ppc ~amd64"
-IUSE="doc"
+KEYWORDS="x86 ppc amd64"
+IUSE="doc jikes source"
DEPEND=">=virtual/jdk-1.4
- dev-java/ant"
+ dev-java/ant-core
+ jikes? ( dev-java/jikes )
+ source? ( app-arch/zip )"
RDEPEND=">=virtual/jre-1.4"
S=${WORKDIR}
@@ -30,6 +32,7 @@ src_unpack() {
src_compile() {
local antflags="jar"
+ use jikes && antflags="${antflags} -Dbuild.compiler=jikes"
ant ${antflags} || die "compile failed"
}
@@ -37,4 +40,5 @@ src_install() {
java-pkg_dojar ${PN}.jar
use doc && java-pkg_dohtml -r readme.html docs/*
+ use source && java-pkg_dosrc src/*
}