summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRalph Sennhauser <sera@gentoo.org>2011-11-21 11:07:41 +0000
committerRalph Sennhauser <sera@gentoo.org>2011-11-21 11:07:41 +0000
commit7abc209db176d01704523c42d27d6ea493a25675 (patch)
treef51f795c1ec07988d2c7619c99d61a6c66bc7672 /dev-java
parentRemove vulnarable (diff)
downloadgentoo-2-7abc209db176d01704523c42d27d6ea493a25675.tar.gz
gentoo-2-7abc209db176d01704523c42d27d6ea493a25675.tar.bz2
gentoo-2-7abc209db176d01704523c42d27d6ea493a25675.zip
Use java-vm-2.eclass to set PaX markings
(Portage version: 2.1.10.35/cvs/Linux x86_64)
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/icedtea-bin/ChangeLog6
-rw-r--r--dev-java/icedtea-bin/icedtea-bin-6.1.10.4.ebuild10
-rw-r--r--dev-java/icedtea-bin/icedtea-bin-7.2.0-r1.ebuild10
3 files changed, 11 insertions, 15 deletions
diff --git a/dev-java/icedtea-bin/ChangeLog b/dev-java/icedtea-bin/ChangeLog
index f3d55162957d..26eb8bdb945e 100644
--- a/dev-java/icedtea-bin/ChangeLog
+++ b/dev-java/icedtea-bin/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-java/icedtea-bin
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/icedtea-bin/ChangeLog,v 1.7 2011/11/18 21:32:23 sera Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/icedtea-bin/ChangeLog,v 1.8 2011/11/21 11:07:41 sera Exp $
+
+ 21 Nov 2011; Ralph Sennhauser <sera@gentoo.org> icedtea-bin-6.1.10.4.ebuild,
+ icedtea-bin-7.2.0-r1.ebuild:
+ Use java-vm-2.eclass to set PaX markings
18 Nov 2011; Ralph Sennhauser <sera@gentoo.org> icedtea-bin-6.1.10.4.ebuild,
icedtea-bin-7.2.0-r1.ebuild:
diff --git a/dev-java/icedtea-bin/icedtea-bin-6.1.10.4.ebuild b/dev-java/icedtea-bin/icedtea-bin-6.1.10.4.ebuild
index aa8f86dcecc0..a464d98fad9e 100644
--- a/dev-java/icedtea-bin/icedtea-bin-6.1.10.4.ebuild
+++ b/dev-java/icedtea-bin/icedtea-bin-6.1.10.4.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/icedtea-bin/icedtea-bin-6.1.10.4.ebuild,v 1.3 2011/11/18 21:32:23 sera Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/icedtea-bin/icedtea-bin-6.1.10.4.ebuild,v 1.4 2011/11/21 11:07:41 sera Exp $
EAPI="4"
-inherit java-vm-2 pax-utils
+inherit java-vm-2
dist="http://dev.gentoo.org/~caster/distfiles/"
DESCRIPTION="A Gentoo-made binary build of the Icedtea6 JDK"
@@ -69,11 +69,7 @@ src_install() {
cp -pRP bin include jre lib man "${ddest}" || die "failed to copy"
# Remove on next bump as the needed marks are already set by icedtea ebuild.
- # Set PaX markings on all JDK/JRE executables to allow code-generation on
- # the heap by the JIT compiler.
- local marks="m"
- use x86 && marks="msp"
- pax-mark ${marks} $(list-paxables "${ddest}"{,/jre}/bin/*)
+ java-vm_set-pax-markings "${ddest}"
dodoc ../doc/{ASSEMBLY_EXCEPTION,THIRD_PARTY_README}
if use doc ; then
diff --git a/dev-java/icedtea-bin/icedtea-bin-7.2.0-r1.ebuild b/dev-java/icedtea-bin/icedtea-bin-7.2.0-r1.ebuild
index 7b0cd900ea77..dae69a39c8d5 100644
--- a/dev-java/icedtea-bin/icedtea-bin-7.2.0-r1.ebuild
+++ b/dev-java/icedtea-bin/icedtea-bin-7.2.0-r1.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/icedtea-bin/icedtea-bin-7.2.0-r1.ebuild,v 1.3 2011/11/18 21:32:23 sera Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/icedtea-bin/icedtea-bin-7.2.0-r1.ebuild,v 1.4 2011/11/21 11:07:41 sera Exp $
EAPI="4"
-inherit java-vm-2 pax-utils
+inherit java-vm-2
dist="http://dev.gentoo.org/~caster/distfiles/"
DESCRIPTION="A Gentoo-made binary build of the Icedtea6 JDK"
@@ -69,11 +69,7 @@ src_install() {
cp -pRP bin include jre lib man "${ddest}" || die "failed to copy"
# Remove on next bump as the needed marks are already set by icedtea ebuild.
- # Set PaX markings on all JDK/JRE executables to allow code-generation on
- # the heap by the JIT compiler.
- local marks="m"
- use x86 && marks="msp"
- pax-mark ${marks} $(list-paxables "${ddest}"{,/jre}/bin/*)
+ java-vm_set-pax-markings "${ddest}"
dodoc ../doc/{ASSEMBLY_EXCEPTION,THIRD_PARTY_README}
if use doc ; then