summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVlastimil Babka <caster@gentoo.org>2007-05-27 00:07:08 +0000
committerVlastimil Babka <caster@gentoo.org>2007-05-27 00:07:08 +0000
commit67a4d4104841a51f4a3a8fdfde37c8404c4318d0 (patch)
tree5feaedddecb7e75708d2d9df367782be882eb673 /dev-java
parentNext stop: Java junkyard. (diff)
downloadgentoo-2-67a4d4104841a51f4a3a8fdfde37c8404c4318d0.tar.gz
gentoo-2-67a4d4104841a51f4a3a8fdfde37c8404c4318d0.tar.bz2
gentoo-2-67a4d4104841a51f4a3a8fdfde37c8404c4318d0.zip
Migrate to split-ant.
(Portage version: 2.1.2.8)
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/jgoodies-animation/ChangeLog6
-rw-r--r--dev-java/jgoodies-animation/jgoodies-animation-1.2.0.ebuild15
2 files changed, 12 insertions, 9 deletions
diff --git a/dev-java/jgoodies-animation/ChangeLog b/dev-java/jgoodies-animation/ChangeLog
index 13a2e582d2f6..4977a4d6454a 100644
--- a/dev-java/jgoodies-animation/ChangeLog
+++ b/dev-java/jgoodies-animation/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-java/jgoodies-animation
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/jgoodies-animation/ChangeLog,v 1.5 2007/01/10 22:01:17 betelgeuse Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jgoodies-animation/ChangeLog,v 1.6 2007/05/27 00:07:08 caster Exp $
+
+ 27 May 2007; Vlastimil Babka <caster@gentoo.org>
+ jgoodies-animation-1.2.0.ebuild:
+ Migrate to split-ant.
*jgoodies-animation-1.2.0 (10 Jan 2007)
diff --git a/dev-java/jgoodies-animation/jgoodies-animation-1.2.0.ebuild b/dev-java/jgoodies-animation/jgoodies-animation-1.2.0.ebuild
index 36c6ca3af8c7..dd2d7f2f57fd 100644
--- a/dev-java/jgoodies-animation/jgoodies-animation-1.2.0.ebuild
+++ b/dev-java/jgoodies-animation/jgoodies-animation-1.2.0.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/jgoodies-animation/jgoodies-animation-1.2.0.ebuild,v 1.1 2007/01/10 22:01:17 betelgeuse Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jgoodies-animation/jgoodies-animation-1.2.0.ebuild,v 1.2 2007/05/27 00:07:08 caster Exp $
+
+JAVA_PKG_IUSE="doc examples source test"
inherit java-pkg-2 java-ant-2
@@ -12,13 +14,11 @@ SRC_URI="http://www.jgoodies.com/download/libraries/animation-${MY_V}.zip"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~x86 ~amd64 ~ppc"
-IUSE="doc examples source test"
+IUSE=""
DEPEND=">=virtual/jdk-1.4
- >=dev-java/ant-core-1.4
app-arch/unzip
- source? ( app-arch/zip )
- test? ( dev-java/junit dev-java/ant-tasks )"
+ test? ( =dev-java/junit-3* dev-java/ant-junit )"
RDEPEND=">=virtual/jre-1.4"
S="${WORKDIR}/animation-${PV}"
@@ -28,11 +28,10 @@ src_unpack() {
cd ${S}
# Remove the packaged jar
- rm -v lib/*.jar *.jar
+ rm -v lib/*.jar *.jar || die
- # Copy the Gentoo'ized build.xml
# cp ${FILESDIR}/build-${PV}.xml ${S}
- xml-rewrite.py -f build.xml -d -e javac -a bootclasspath \
+ java-ant_xml-rewrite -f build.xml -d -e javac -a bootclasspath \
|| die "Failed to fix bootclasspath"
}
src_compile() {