summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVlastimil Babka <caster@gentoo.org>2007-05-22 06:58:24 +0000
committerVlastimil Babka <caster@gentoo.org>2007-05-22 06:58:24 +0000
commit653b3cf3fff7c73806962118c092f8638aba9eea (patch)
treebbd76185b35e8cfcab23faa213172fa887fc16ee /dev-java
parentInitial import. (diff)
downloadgentoo-2-653b3cf3fff7c73806962118c092f8638aba9eea.tar.gz
gentoo-2-653b3cf3fff7c73806962118c092f8638aba9eea.tar.bz2
gentoo-2-653b3cf3fff7c73806962118c092f8638aba9eea.zip
Replace fetch restricted sun-jmx dep with mx4j-core, upstream uses it too according to maven xmls.
(Portage version: 2.1.2.7)
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/groovy/ChangeLog8
-rw-r--r--dev-java/groovy/files/digest-groovy-1.0-r13
-rw-r--r--dev-java/groovy/groovy-1.0-r1.ebuild105
3 files changed, 115 insertions, 1 deletions
diff --git a/dev-java/groovy/ChangeLog b/dev-java/groovy/ChangeLog
index f5c1c4be6c28..007780f75145 100644
--- a/dev-java/groovy/ChangeLog
+++ b/dev-java/groovy/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-java/groovy
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/groovy/ChangeLog,v 1.21 2007/02/10 19:45:35 nichoj Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/groovy/ChangeLog,v 1.22 2007/05/22 06:58:24 caster Exp $
+
+*groovy-1.0-r1 (22 May 2007)
+
+ 22 May 2007; Vlastimil Babka <caster@gentoo.org> +groovy-1.0-r1.ebuild:
+ Replace fetch restricted sun-jmx dep with mx4j-core, upstream uses it too
+ according to maven xmls.
10 Feb 2007; Joshua Nichols <nichoj@gentoo.org> -groovy-1.0_rc01.ebuild:
Pruned old version with same keywords.
diff --git a/dev-java/groovy/files/digest-groovy-1.0-r1 b/dev-java/groovy/files/digest-groovy-1.0-r1
new file mode 100644
index 000000000000..36011df7d086
--- /dev/null
+++ b/dev-java/groovy/files/digest-groovy-1.0-r1
@@ -0,0 +1,3 @@
+MD5 14d39578832e3c7a02a4d5972e5d573f groovy-1.0-src.tar.gz 966931
+RMD160 dad940d5bbe10a16686dc619a094c2cbdc0d52f1 groovy-1.0-src.tar.gz 966931
+SHA256 63d1e47d80a31567792b65dfe19653ab98ce74a6876fb05b9423b83ecc960599 groovy-1.0-src.tar.gz 966931
diff --git a/dev-java/groovy/groovy-1.0-r1.ebuild b/dev-java/groovy/groovy-1.0-r1.ebuild
new file mode 100644
index 000000000000..0d86ca8e3222
--- /dev/null
+++ b/dev-java/groovy/groovy-1.0-r1.ebuild
@@ -0,0 +1,105 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/groovy/groovy-1.0-r1.ebuild,v 1.1 2007/05/22 06:58:24 caster Exp $
+
+inherit versionator java-pkg-2 java-ant-2
+
+MY_PV=${PV/_rc/-RC-}
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="Groovy is a high-level dynamic language for the JVM"
+HOMEPAGE="http://groovy.codehaus.org/"
+SRC_URI="http://dist.codehaus.org/groovy/distributions/${MY_P/JSR/jsr}-src.tar.gz"
+LICENSE="codehaus-groovy"
+SLOT="1"
+KEYWORDS="~amd64 ~x86"
+IUSE="source"
+
+COMMON_DEPS="
+ =dev-java/asm-2.2*
+ >=dev-java/antlr-2.7.5
+ >=dev-java/xerces-2.7
+ >=dev-java/ant-core-1.6.5
+ >=dev-java/xstream-1.1.1
+ =dev-java/junit-3*
+ dev-java/qdox
+ >=dev-java/commons-cli-1.0
+ >=dev-java/bsf-2.3.0_rc1
+ >=dev-java/mockobjects-0.09
+ ~dev-java/servletapi-2.4
+ =dev-java/mx4j-core-3.0*"
+RDEPEND=">=virtual/jre-1.4
+ ${COMMON_DEPS}"
+# FIXME doesn't compile with 1.6 due to JDBC api change
+DEPEND="|| ( =virtual/jdk-1.4* =virtual/jdk-1.5* )
+ ${COMMON_DEPS}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+# epatch ${FILESDIR}/${P}-compiler-exit-code.patch
+
+ mkdir -p ${S}/target/lib
+
+ cd ${S}/target/lib
+ java-pkg_jar-from commons-cli-1
+ java-pkg_jar-from xerces-2
+ java-pkg_jar-from ant-core ant.jar
+ java-pkg_jar-from antlr
+ java-pkg_jar-from asm-2.2
+ java-pkg_jar-from xstream
+ java-pkg_jar-from mockobjects
+ java-pkg_jar-from junit
+ java-pkg_jar-from servletapi-2.4
+ java-pkg_jar-from bsf-2.3
+ java-pkg_jar-from mx4j-core-3.0
+
+ cd ${S}
+
+ # We use ant NOT maven. This build.xml is generated using 'maven ant', and
+ # then the following tweaks:
+ # - change libdir from /root/.ant/maven to target/lib
+ # NOTE this could be also simplified using -Dlibdir=target/lib
+ # - change build.classpath to use <fileset dir="${libdir}" includes="**/*.jar"/>
+ # instead of using each individual jar
+ # - remove get-deps from the depends of all targets. you should be able to
+ # define -Dnoget=true, but that doesn't really work
+ # - remove all the get-* targets (otherwise, the file is a bit oversized to
+ # be in files/
+ # - remove all the junit-present stuff
+ # - remove test dependency from jar target
+ cp ${FILESDIR}/build.xml-${PV} ${S}/build.xml || die "Failed to update build.xml"
+
+ cd src/main
+ # This won't compile without an incestuous relationship with radeox.
+ rm -rf org/codehaus/groovy/wiki
+}
+
+src_compile() {
+ eant jar
+
+ # need to compile .groovy files to .class files
+ cd src/main
+ java -classpath ../../target/${MY_P}.jar:$(java-pkg_getjars commons-cli-1,asm-2.2,antlr,junit,qdox-1.6) \
+ org.codehaus.groovy.tools.FileSystemCompiler \
+ $(find -name *.groovy) || die "Failed to invoke groovyc"
+
+ # add the now compiled .class files to our jar
+ jar uf ../../target/${MY_P}.jar $(find -name *.class) || die "Failed to backpatch Console*.class"
+}
+
+src_install() {
+ java-pkg_newjar target/${MY_P}.jar
+ java-pkg_dolauncher "grok" --main org.codehaus.groovy.tools.Grok
+ java-pkg_dolauncher "groovyc" --main org.codehaus.groovy.tools.FileSystemCompiler
+ java-pkg_dolauncher "groovy" --main groovy.ui.GroovyMain
+ java-pkg_dolauncher "groovysh" --main groovy.ui.InteractiveShell
+ java-pkg_dolauncher "groovyConsole" --main groovy.ui.Console
+}
+
+src_test() {
+ eant test
+}