summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetteri Räty <betelgeuse@gentoo.org>2010-01-16 20:28:43 +0000
committerPetteri Räty <betelgeuse@gentoo.org>2010-01-16 20:28:43 +0000
commit628654d76cb28e02126a162abce51a0a3c23b48c (patch)
tree62877d84ee16e0f2113abceca716b7f94e9143ce /dev-java
parentUpdated handling of mycmakeargs from cmake-utils.eclass. (diff)
downloadgentoo-2-628654d76cb28e02126a162abce51a0a3c23b48c.tar.gz
gentoo-2-628654d76cb28e02126a162abce51a0a3c23b48c.tar.bz2
gentoo-2-628654d76cb28e02126a162abce51a0a3c23b48c.zip
Add dep on x11-libs/libXt for the X use flag as the installed jni headers need a file from it.
(Portage version: 2.2_rc61/cvs/Linux i686)
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/icedtea6-bin/ChangeLog11
-rw-r--r--dev-java/icedtea6-bin/icedtea6-bin-1.6.2-r1.ebuild107
2 files changed, 116 insertions, 2 deletions
diff --git a/dev-java/icedtea6-bin/ChangeLog b/dev-java/icedtea6-bin/ChangeLog
index 896c026bcbdd..aac725914a31 100644
--- a/dev-java/icedtea6-bin/ChangeLog
+++ b/dev-java/icedtea6-bin/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-java/icedtea6-bin
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/icedtea6-bin/ChangeLog,v 1.9 2009/12/28 20:48:10 maekke Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/icedtea6-bin/ChangeLog,v 1.10 2010/01/16 20:28:43 betelgeuse Exp $
+
+*icedtea6-bin-1.6.2-r1 (16 Jan 2010)
+
+ 16 Jan 2010; Petteri Räty <betelgeuse@gentoo.org>
+ +icedtea6-bin-1.6.2-r1.ebuild:
+ Add dep on x11-libs/libXt for the X use flag as the installed jni headers
+ need a file from it.
28 Dec 2009; Markus Meier <maekke@gentoo.org> icedtea6-bin-1.6.2.ebuild:
amd64 stable, bug #292003
diff --git a/dev-java/icedtea6-bin/icedtea6-bin-1.6.2-r1.ebuild b/dev-java/icedtea6-bin/icedtea6-bin-1.6.2-r1.ebuild
new file mode 100644
index 000000000000..5f490ddb8787
--- /dev/null
+++ b/dev-java/icedtea6-bin/icedtea6-bin-1.6.2-r1.ebuild
@@ -0,0 +1,107 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/icedtea6-bin/icedtea6-bin-1.6.2-r1.ebuild,v 1.1 2010/01/16 20:28:43 betelgeuse Exp $
+
+EAPI="1"
+
+inherit java-vm-2
+
+dist="mirror://gentoo/"
+DESCRIPTION="A Gentoo-made binary build of the icedtea6 JDK"
+TARBALL_VERSION="${PV}"
+SRC_URI="amd64? ( ${dist}/${PN}-core-${TARBALL_VERSION}-amd64.tar.bz2 )
+ x86? ( ${dist}/${PN}-core-${TARBALL_VERSION}-x86.tar.bz2 )
+ doc? ( ${dist}/${PN}-doc-${TARBALL_VERSION}.tar.bz2 )
+ examples? (
+ amd64? ( ${dist}/${PN}-examples-${TARBALL_VERSION}-amd64.tar.bz2 )
+ x86? ( ${dist}/${PN}-examples-${TARBALL_VERSION}-x86.tar.bz2 )
+ )
+ nsplugin? (
+ amd64? ( ${dist}/${PN}-nsplugin-${TARBALL_VERSION}-amd64.tar.bz2 )
+ x86? ( ${dist}/${PN}-nsplugin-${TARBALL_VERSION}-x86.tar.bz2 )
+ )
+ source? ( ${dist}/${PN}-src-${TARBALL_VERSION}.tar.bz2 )"
+HOMEPAGE="http://icedtea.classpath.org"
+
+IUSE="X alsa doc examples nsplugin source"
+RESTRICT="strip"
+
+LICENSE="GPL-2-with-linking-exception"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+S="${WORKDIR}/${PN}-${TARBALL_VERSION}"
+
+RDEPEND=">=sys-devel/gcc-4.3
+ >=sys-libs/glibc-2.9
+ >=media-libs/giflib-4.1.6-r1
+ >=media-libs/jpeg-7
+ >=media-libs/libpng-1.2.38
+ >=sys-libs/zlib-1.2.3-r1
+ alsa? ( >=media-libs/alsa-lib-1.0.20 )
+ X? (
+ >=media-libs/freetype-2.3.9:2
+ >=media-libs/fontconfig-2.6.0-r2:1.0
+ >=x11-libs/libXext-1.0.5
+ >=x11-libs/libXi-1.2.1
+ >=x11-libs/libXtst-1.0.3
+ >=x11-libs/libX11-1.2.2
+ x11-libs/libXt
+ )
+ nsplugin? (
+ >=dev-libs/atk-1.26.0
+ >=dev-libs/glib-2.20.5:2
+ >=dev-libs/nspr-4.8
+ >=x11-libs/cairo-1.8.8
+ >=x11-libs/gtk+-2.16.6:2
+ >=x11-libs/pango-1.24.5
+ )"
+DEPEND=""
+
+QA_EXECSTACK_amd64="opt/${P}/jre/lib/amd64/server/libjvm.so"
+QA_EXECSTACK_x86="opt/${P}/jre/lib/i386/server/libjvm.so
+ opt/${P}/jre/lib/i386/client/libjvm.so"
+
+src_install() {
+ local dest="/opt/${P}"
+ local ddest="${D}/${dest}"
+ dodir "${dest}" || die
+
+ local arch=${ARCH}
+
+ # doins can't handle symlinks.
+ cp -pRP bin include jre lib man "${ddest}" || die "failed to copy"
+
+ dodoc ../doc/{ASSEMBLY_EXCEPTION,THIRD_PARTY_README} || die
+ if use doc ; then
+ dohtml -r ../doc/html/* || die "Failed to install documentation"
+ fi
+
+ if use examples; then
+ cp -pRP share/{demo,sample} "${ddest}" || die
+ fi
+
+ if use source ; then
+ cp src.zip "${ddest}" || die
+ fi
+
+ if use nsplugin ; then
+ use x86 && arch=i386
+ install_mozilla_plugin "${dest}/jre/lib/${arch}/IcedTeaPlugin.so"
+ fi
+
+ set_java_env
+ java-vm_revdep-mask
+}
+
+pkg_postinst() {
+ # Set as default VM if none exists
+ java-vm-2_pkg_postinst
+
+ if use nsplugin; then
+ elog "The icedtea6-bin browser plugin can be enabled using eselect java-nsplugin"
+ elog "Note that the plugin works only in browsers based on xulrunner-1.9.1"
+ elog "such as Firefox 3.5, and not in older versions! The version for xulrunner-1.9.0"
+ elog "is not included anymore, as 1.9.1 is stable. If you still need it, fill a bug."
+ fi
+}