summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetteri Räty <betelgeuse@gentoo.org>2007-01-31 18:42:40 +0000
committerPetteri Räty <betelgeuse@gentoo.org>2007-01-31 18:42:40 +0000
commit6215f8e3bf9d4f206b502b2e2df1bf7fcff3dede (patch)
tree63c25330d95ac22316692561593798310925e4ed /dev-java
parentAdded ~ppc64; bug #160285 (diff)
downloadgentoo-2-6215f8e3bf9d4f206b502b2e2df1bf7fcff3dede.tar.gz
gentoo-2-6215f8e3bf9d4f206b502b2e2df1bf7fcff3dede.tar.bz2
gentoo-2-6215f8e3bf9d4f206b502b2e2df1bf7fcff3dede.zip
Version bump. Fixes bug #164607 and hopefully bug #164056. Dropped amd64 keywords because I could not test if the changes work there.
(Portage version: 2.1.2-r5)
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/jss/ChangeLog11
-rw-r--r--dev-java/jss/files/digest-jss-4.23
-rw-r--r--dev-java/jss/files/jss-4.2-pkg-config.patch22
-rw-r--r--dev-java/jss/jss-4.2.ebuild71
-rw-r--r--dev-java/jss/metadata.xml4
5 files changed, 107 insertions, 4 deletions
diff --git a/dev-java/jss/ChangeLog b/dev-java/jss/ChangeLog
index f350da6d98db..34e5e5054d76 100644
--- a/dev-java/jss/ChangeLog
+++ b/dev-java/jss/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-java/jss
-# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/jss/ChangeLog,v 1.10 2006/10/05 18:21:17 gustavoz Exp $
+# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jss/ChangeLog,v 1.11 2007/01/31 18:42:40 betelgeuse Exp $
+
+*jss-4.2 (31 Jan 2007)
+
+ 31 Jan 2007; Petteri Räty <betelgeuse@gentoo.org>
+ +files/jss-4.2-pkg-config.patch, metadata.xml, +jss-4.2.ebuild:
+ Version bump. Fixes bug #164607 and hopefully bug #164056. Dropped amd64
+ keywords because I could not test if the changes work there.
05 Oct 2006; Gustavo Zacarias <gustavoz@gentoo.org> jss-3.4.ebuild:
Dropping sparc keywords, see #96229
diff --git a/dev-java/jss/files/digest-jss-4.2 b/dev-java/jss/files/digest-jss-4.2
new file mode 100644
index 000000000000..fd7a14192e30
--- /dev/null
+++ b/dev-java/jss/files/digest-jss-4.2
@@ -0,0 +1,3 @@
+MD5 cc42b5cf802c8aa782c1aea3df7598fc jss-4.2.tar.bz2 376845
+RMD160 1bc9180a43d062dbf46818427f96df86bb0ce4e5 jss-4.2.tar.bz2 376845
+SHA256 1c7240312193620607d4b823adb69ad63b3f8bd5de8e0c284f3df2d19aab8621 jss-4.2.tar.bz2 376845
diff --git a/dev-java/jss/files/jss-4.2-pkg-config.patch b/dev-java/jss/files/jss-4.2-pkg-config.patch
new file mode 100644
index 000000000000..befd3fbe68ae
--- /dev/null
+++ b/dev-java/jss/files/jss-4.2-pkg-config.patch
@@ -0,0 +1,22 @@
+Index: security/jss/lib/config.mk
+===================================================================
+RCS file: /cvsroot/mozilla/security/jss/lib/config.mk,v
+retrieving revision 1.19
+diff -u -r1.19 config.mk
+--- mozilla/security/jss/lib/config.mk 25 Apr 2004 15:02:19 -0000 1.19
++++ mozilla/security/jss/lib/config.mk 30 Jan 2007 21:08:06 -0000
+@@ -72,13 +72,7 @@
+ else
+
+ EXTRA_SHARED_LIBS += \
+- -L$(DIST)/lib \
+- -lnss3 \
+- -lsmime3 \
+- -lssl3 \
+- -lplc4 \
+- -lplds4 \
+- -lnspr4 \
++ `pkg-config --libs nss` \
+ $(JAVA_LIBS) \
+ $(NULL)
+
diff --git a/dev-java/jss/jss-4.2.ebuild b/dev-java/jss/jss-4.2.ebuild
new file mode 100644
index 000000000000..6cbbd7529e3f
--- /dev/null
+++ b/dev-java/jss/jss-4.2.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jss/jss-4.2.ebuild,v 1.1 2007/01/31 18:42:40 betelgeuse Exp $
+
+inherit eutils java-pkg-2 versionator
+
+RTM_NAME="JSS_${PV//./_}_RTM"
+DESCRIPTION="Network Security Services for Java (JSS)"
+HOMEPAGE="http://www.mozilla.org/projects/security/pki/jss/"
+# To prepare this tarball
+# cvs -d :pserver:anonymous@cvs-mirror.mozilla.org:/cvsroot export \
+# -r JSS_4_2_RTM mozilla/security/corefonf
+# cvs -d :pserver:anonymous@cvs-mirror.mozilla.org:/cvsroot export \
+# -r JSS_4_2_RTM mozilla/security/jss
+# tar cvjf jss-4.2.tar.bz2 mozilla
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="MPL-1.1"
+SLOT="3.4"
+KEYWORDS="~x86"
+IUSE="doc examples source"
+
+RDEPEND=">=virtual/jre-1.4
+ >=dev-libs/nspr-4.3
+ >=dev-libs/nss-3.9.2"
+DEPEND=">=virtual/jdk-1.4
+ ${RDEPEND}
+ app-arch/zip
+ dev-util/pkgconfig
+ >=sys-apps/sed-4"
+
+S=${WORKDIR}/mozilla
+
+src_unpack() {
+ unpack ${A}
+ epatch "${FILESDIR}/${PN}-3.4-target_source.patch"
+ epatch "${FILESDIR}/${PN}-4.2-pkg-config.patch"
+
+ echo "INCLUDES += -I${ROOT}usr/include/nss -I${ROOT}usr/include/nspr" \
+ >> "${S}"/security/coreconf/headers.mk || die
+}
+
+src_compile() {
+ export JAVA_GENTOO_OPTS="-target $(java-pkg_get-target) -source $(java-pkg_get-source)"
+ cd "${S}/security/coreconf" || die
+ emake -j1 BUILD_OPT=1 || die "coreconf make failed"
+
+ cd "${S}/security/jss" || die
+ emake -j1 BUILD_OPT=1 || die "jss make failed"
+ if use doc; then
+ emake -j1 BUILD_OPT=1 javadoc || die "failed to create javadocs"
+ fi
+}
+
+src_test() {
+ BUILD_OPT=1 perl security/jss/org/mozilla/jss/tests/all.pl dist \
+ "${S}"/dist/Linux*.OBJ/
+}
+
+src_install() {
+ java-pkg_dojar dist/*.jar
+ # Use this instead of the one in dist because it is a symlink
+ # and doso handles symlinks by just symlinking to the original
+ java-pkg_doso ./security/${PN}/lib/*/*.so
+ use doc && java-pkg_dojavadoc dist/jssdoc
+ use source && java-pkg_dosrc ./security/jss/org
+ if use examples; then
+ docinto examples
+ dodoc ./security/jss/samples/*
+ fi
+}
diff --git a/dev-java/jss/metadata.xml b/dev-java/jss/metadata.xml
index 8cbf83f2d1a1..6b82ef4099b3 100644
--- a/dev-java/jss/metadata.xml
+++ b/dev-java/jss/metadata.xml
@@ -6,8 +6,8 @@
<longdescription>
-Network Security Services for Java (JSS) is a Java interface to NSS. It supports
-most of the security standards and encryption technologies supported by NSS. JSS
+Network Security Services for Java (JSS) is a Java interface to NSS. It supports
+most of the security standards and encryption technologies supported by NSS. JSS
also provides a pure Java interface for ASN.1 types and BER/DER encoding.
</longdescription>