summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVlastimil Babka <caster@gentoo.org>2006-09-10 14:28:33 +0000
committerVlastimil Babka <caster@gentoo.org>2006-09-10 14:28:33 +0000
commit5efef810a6ce139de3dcdfcdc9915d1c8d48cab9 (patch)
tree3c2c3291571024fce8f37735222c0e55458f03fc /dev-java
parentVersion bump (diff)
downloadgentoo-2-5efef810a6ce139de3dcdfcdc9915d1c8d48cab9.tar.gz
gentoo-2-5efef810a6ce139de3dcdfcdc9915d1c8d48cab9.tar.bz2
gentoo-2-5efef810a6ce139de3dcdfcdc9915d1c8d48cab9.zip
Remove automagical detection of jai and jimi support that fails with JAVA_PKG_STRICT wrt bug #145568.
(Portage version: 2.1.1)
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/fop/ChangeLog9
-rw-r--r--dev-java/fop/files/0.20.5-no-autodetection.patch43
-rw-r--r--dev-java/fop/files/digest-fop-0.20.5-r73
-rw-r--r--dev-java/fop/fop-0.20.5-r7.ebuild77
4 files changed, 131 insertions, 1 deletions
diff --git a/dev-java/fop/ChangeLog b/dev-java/fop/ChangeLog
index f6671707de5e..a244b573aa76 100644
--- a/dev-java/fop/ChangeLog
+++ b/dev-java/fop/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-java/fop
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/fop/ChangeLog,v 1.29 2006/08/06 03:33:16 nichoj Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/fop/ChangeLog,v 1.30 2006/09/10 14:28:33 caster Exp $
+
+*fop-0.20.5-r7 (10 Sep 2006)
+
+ 10 Sep 2006; Vlastimil Babka <caster@gentoo.org>
+ +files/0.20.5-no-autodetection.patch, +fop-0.20.5-r7.ebuild:
+ Remove automagical detection of jai and jimi support that fails with
+ JAVA_PKG_STRICT wrt bug #145568.
06 Aug 2006; Joshua Nichols <nichoj@gentoo.org> fop-0.20.5-r6.ebuild:
Added missing dependency jar that was brought in by /usr/bin/ant, in order
diff --git a/dev-java/fop/files/0.20.5-no-autodetection.patch b/dev-java/fop/files/0.20.5-no-autodetection.patch
new file mode 100644
index 000000000000..bb52378281ed
--- /dev/null
+++ b/dev-java/fop/files/0.20.5-no-autodetection.patch
@@ -0,0 +1,43 @@
+--- build.xml 2003-07-15 04:03:22.000000000 +0200
++++ build.xml 2006-08-30 11:30:22.000000000 +0200
+@@ -172,16 +172,7 @@
+ </fileset>
+
+ <path id="libs-build-classpath">
+- <fileset dir="lib">
+- <include name="xalan*.jar"/>
+- <include name="xerces*.jar"/>
+- <include name="xml-apis.jar"/>
+- <include name="avalon-framework*.jar"/>
+- <include name="batik*.jar"/>
+- <include name="jimi*.jar"/>
+- <include name="jai*.jar"/>
+- <include name="jce*.jar"/>
+- </fileset>
++ <fileset dir="lib" includes="**/*.jar"/>
+ </path>
+
+ <!-- =================================================================== -->
+@@ -293,11 +284,9 @@
+ </target>
+
+ <target name="init-avail">
+- <available property="jimi.present" classname="com.sun.jimi.core.Jimi" classpathref="libs-build-classpath"/>
+- <available property="jai.present" classname="javax.media.jai.JAI" classpathref="libs-build-classpath"/>
+- <available property="trax.present" classname="javax.xml.transform.Transformer" classpathref="libs-build-classpath"/>
+- <available property="jdk14.present" classname="java.lang.CharSequence"/>
+- <available property="jce.present" classname="javax.crypto.Cipher" classpathref="libs-build-classpath"/>
++ <property name="trax.present" value="true"/>
++ <property name="jdk14.present" value="true"/>
++ <property name="jce.present" value="true"/>
+ </target>
+
+ <target name="init-filters-jdk13" depends="init-avail" unless="jdk14.present">
+@@ -588,7 +577,6 @@
+ includes="org/**,conf/**,hyph/**">
+ <manifest>
+ <attribute name="Main-Class" value="${main.class}"/>
+- <attribute name="Class-Path" value="${runtime.classpath}"/>
+ <attribute name="Implementation-Title" value="${Name}"/>
+ <attribute name="Implementation-Version" value="${version}"/>
+ <attribute name="Implementation-Vendor" value="Apache Software Foundation (http://xml.apache.org/fop/)"/>
diff --git a/dev-java/fop/files/digest-fop-0.20.5-r7 b/dev-java/fop/files/digest-fop-0.20.5-r7
new file mode 100644
index 000000000000..f4b8ca285900
--- /dev/null
+++ b/dev-java/fop/files/digest-fop-0.20.5-r7
@@ -0,0 +1,3 @@
+MD5 1a31eb1357e5d4b8d32d4cb3edae2da2 fop-0.20.5-src.tar.gz 7885256
+RMD160 c4b776b2b406710548bb343ca2f3dcf03af1a68b fop-0.20.5-src.tar.gz 7885256
+SHA256 0c3db9596520ae91747f55984f13d5474e195182c2c274a7556e509864a9ac88 fop-0.20.5-src.tar.gz 7885256
diff --git a/dev-java/fop/fop-0.20.5-r7.ebuild b/dev-java/fop/fop-0.20.5-r7.ebuild
new file mode 100644
index 000000000000..d99b802fd321
--- /dev/null
+++ b/dev-java/fop/fop-0.20.5-r7.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/fop/fop-0.20.5-r7.ebuild,v 1.1 2006/09/10 14:28:33 caster Exp $
+
+inherit eutils java-pkg-2 java-ant-2
+
+MY_V=${PV/_/}
+DESCRIPTION="Formatting Objects Processor is a print formatter driven by XSL"
+SRC_URI="mirror://apache/xml/fop/fop-${MY_V}-src.tar.gz"
+HOMEPAGE="http://xml.apache.org/fop/"
+LICENSE="Apache-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples jai jimi"
+
+# Doesn't like Java 1.5
+COMMON_DEP="
+ jai? ( dev-java/sun-jai-bin )
+ jimi? ( dev-java/sun-jimi )
+ =dev-java/avalon-framework-4.1*
+ ~dev-java/batik-1.5
+ dev-java/xalan
+ >=dev-java/xerces-2.6.2
+ !dev-java/fop-bin"
+RDEPEND="=virtual/jre-1.4*
+ ${COMMON_DEP}"
+DEPEND="=virtual/jdk-1.4*
+ ${COMMON_DEP}
+ >=dev-java/ant-1.5.4"
+
+S=${WORKDIR}/${P/_/}
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ epatch ${FILESDIR}/${PV}-no-autodetection.patch
+
+ cd ${S}/lib
+ rm -f *.jar
+ java-pkg_jar-from ant-core ant.jar
+ java-pkg_jar-from avalon-framework-4.1
+ java-pkg_jar-from batik-1.5 batik-all.jar batik.jar
+ java-pkg_jar-from xalan
+ java-pkg_jar-from xerces-2
+ use jai && java-pkg_jar-from sun-jai-bin
+ use jimi && java-pkg_jar-from sun-jimi
+}
+
+src_compile() {
+ java-pkg_filter-compiler jikes
+
+ local jaip jimip
+
+ use jai && jaip="-Djai.present=true"
+ use jimi && jimip="-Djimi.present=true"
+
+ eant ${jaip} ${jimip} package $(use_doc javadocs)
+}
+
+src_install() {
+ java-pkg_dojar build/fop.jar
+
+ dodir /etc/env.d/java/
+ echo 'FOP_HOME=/usr/share/fop/' > ${D}/etc/env.d/java/22fop
+ java-pkg_dolauncher ${PN} --main org.apache.fop.apps.Fop
+
+ if use doc; then
+ dodoc CHANGES STATUS README
+ java-pkg_dohtml -r ReleaseNotes.html build/javadocs/*
+ fi
+
+ if use examples; then
+ dodir /usr/share/doc/${PF}/examples
+ cp -pPR examples ${D}/usr/share/doc/${PF}/examples
+ fi
+}