summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetteri Räty <betelgeuse@gentoo.org>2010-03-20 18:00:27 +0000
committerPetteri Räty <betelgeuse@gentoo.org>2010-03-20 18:00:27 +0000
commit5d151caa0df4d3eb46dca31d4a9d78715eb057ef (patch)
treee4b9ab8c31668478688512282b644c49ce8d02c2 /dev-java
parentVersion bump, bug #310415. (diff)
downloadgentoo-2-5d151caa0df4d3eb46dca31d4a9d78715eb057ef.tar.gz
gentoo-2-5d151caa0df4d3eb46dca31d4a9d78715eb057ef.tar.bz2
gentoo-2-5d151caa0df4d3eb46dca31d4a9d78715eb057ef.zip
Version bump. Fixes bug #309587, bug #115704 and hopefully bug #218118.
(Portage version: 2.2_rc65/cvs/Linux i686)
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/jdbc-jaybird/ChangeLog8
-rw-r--r--dev-java/jdbc-jaybird/files/2.1.6-remove-unused-ant-import.patch12
-rw-r--r--dev-java/jdbc-jaybird/jdbc-jaybird-2.1.6.ebuild108
3 files changed, 127 insertions, 1 deletions
diff --git a/dev-java/jdbc-jaybird/ChangeLog b/dev-java/jdbc-jaybird/ChangeLog
index 87684531c429..03569f857142 100644
--- a/dev-java/jdbc-jaybird/ChangeLog
+++ b/dev-java/jdbc-jaybird/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-java/jdbc-jaybird
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/jdbc-jaybird/ChangeLog,v 1.31 2010/01/10 10:12:42 betelgeuse Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jdbc-jaybird/ChangeLog,v 1.32 2010/03/20 18:00:26 betelgeuse Exp $
+
+*jdbc-jaybird-2.1.6 (20 Mar 2010)
+
+ 20 Mar 2010; Petteri Räty <betelgeuse@gentoo.org>
+ +files/2.1.6-remove-unused-ant-import.patch, +jdbc-jaybird-2.1.6.ebuild:
+ Version bump. Fixes bug #309587, bug #115704 and hopefully bug #218118.
10 Jan 2010; Petteri Räty <betelgeuse@gentoo.org>
jdbc-jaybird-2.1.5-r2.ebuild:
diff --git a/dev-java/jdbc-jaybird/files/2.1.6-remove-unused-ant-import.patch b/dev-java/jdbc-jaybird/files/2.1.6-remove-unused-ant-import.patch
new file mode 100644
index 000000000000..2a32c5a4126f
--- /dev/null
+++ b/dev-java/jdbc-jaybird/files/2.1.6-remove-unused-ant-import.patch
@@ -0,0 +1,12 @@
+diff --git a/src/main/org/firebirdsql/jdbc/AbstractDatabaseMetaData.java b/src/main/org/firebirdsql/jdbc/AbstractDatabaseMetaData.java
+index 179f58b..fec2ac7 100644
+--- a/src/main/org/firebirdsql/jdbc/AbstractDatabaseMetaData.java
++++ b/src/main/org/firebirdsql/jdbc/AbstractDatabaseMetaData.java
+@@ -23,7 +23,6 @@ package org.firebirdsql.jdbc;
+ import java.sql.*;
+ import java.util.*;
+
+-import org.apache.tools.ant.taskdefs.Get.DownloadProgress;
+ import org.firebirdsql.gds.*;
+ import org.firebirdsql.gds.impl.AbstractGDS;
+ import org.firebirdsql.gds.impl.AbstractIscDbHandle;
diff --git a/dev-java/jdbc-jaybird/jdbc-jaybird-2.1.6.ebuild b/dev-java/jdbc-jaybird/jdbc-jaybird-2.1.6.ebuild
new file mode 100644
index 000000000000..0de1d2cfbebb
--- /dev/null
+++ b/dev-java/jdbc-jaybird/jdbc-jaybird-2.1.6.ebuild
@@ -0,0 +1,108 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jdbc-jaybird/jdbc-jaybird-2.1.6.ebuild,v 1.1 2010/03/20 18:00:26 betelgeuse Exp $
+
+EAPI="2"
+JAVA_PKG_IUSE="doc source examples test"
+
+inherit eutils java-pkg-2 java-ant-2
+
+At="Jaybird-${PV/_/}-src"
+DESCRIPTION="JDBC Type 2 and 4 drivers for Firebird SQL server"
+HOMEPAGE="http://jaybirdwiki.firebirdsql.org/"
+SRC_URI="mirror://sourceforge/firebird/${At}.zip"
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="jni"
+
+RDEPEND=">=virtual/jre-1.6
+ dev-java/log4j:0
+ dev-java/glassfish-connector-api:0"
+DEPEND=">=virtual/jdk-1.6
+ ${RDEPEND}
+ app-arch/unzip
+ jni? ( dev-java/cpptasks )
+ test? (
+ dev-java/ant-junit
+ )"
+
+S="${WORKDIR}/client-java.sources"
+
+MY_PN="jaybird"
+
+java_prepare() {
+
+ epatch "${FILESDIR}/archive-xml-2.1.0.patch"
+ epatch "${FILESDIR}/compile_xml-2.1.2.patch"
+ epatch "${FILESDIR}/2.1.6-remove-unused-ant-import.patch"
+
+ # JAVA_ANT_ENCODING doesn't work because it doesn't like entities
+ java-ant_xml-rewrite -f build.xml -c -e javac -a encoding -v ISO-8859-1
+
+ cd "${S}/lib/"
+ rm -v *.jar
+ use test && java-pkg_jar-from --build-only junit junit.jar
+
+ cd "${S}/src/lib/"
+ rm -v *.jar *.zip
+ # the build.xml unpacks this and uses stuff
+ touch empty
+ jar cf mini-j2ee.jar empty
+}
+
+JAVA_ANT_REWRITE_CLASSPATH="true"
+EANT_GENTOO_CLASSPATH="glassfish-connector-api,log4j"
+EANT_BUILD_TARGET="jars"
+EANT_DOC_TARGET="javadocs"
+
+src_compile() {
+ java-pkg_filter-compiler jikes
+ use jni && ANT_TASKS="cpptasks"
+ java-pkg-2_src_compile $(use test && echo "-Dtests=true") \
+ $(use jni && echo "compile-native")
+}
+
+src_install() {
+ cd "${S}/output/lib/"
+ java-pkg_newjar ${MY_PN}-${PV}.jar ${PN}.jar
+
+ for jar in full pool; do
+ java-pkg_newjar ${MY_PN}-${jar}-${PV}.jar ${MY_PN}-${jar}.jar || die "java-pkg_newjar ${MY_PN}-${jar}.jar failed"
+ done
+ if use test; then
+ java-pkg_newjar ${MY_PN}-test-${PV}.jar ${MY_PN}-${jar}.jar || die "java-pkg_newjar ${MY_PN}-${jar}.jar failed"
+ fi
+
+ if use jni; then
+ cd "${S}/output/native"
+ sodest="/usr/lib/"
+ java-pkg_doso libjaybird21.so || die \
+ "java-pkg_doso ${sodest}libjaybird21.so failed"
+ fi
+
+ cd "${S}"
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/
+ doins -r examples || die "installing examples failed"
+ fi
+
+ use source && java-pkg_dosrc "${S}"/src/*/org
+
+ cd "${S}/output"
+ use doc && java-pkg_dohtml -r docs/
+ dodoc etc/{*.txt,default.mf}
+ dohtml etc/*.html
+}
+
+src_test() {
+ #
+ # Warning about timeouts without Firebird installed and running Locally
+ #
+ ewarn "You will experience long timeouts when running junit tests"
+ ewarn "without Firebird installed and running locally. The tests will"
+ ewarn "complete without Firebird, but network timeouts prolong the"
+ ewarn "testing phase considerably."
+ ANT_TASKS="ant-junit" eant all-tests-pure-java
+}