summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Wijsman <tomwij@gentoo.org>2013-05-29 11:34:30 +0000
committerTom Wijsman <tomwij@gentoo.org>2013-05-29 11:34:30 +0000
commit3793e5b1e9a69945cb401b66bc667bee3d88f6a5 (patch)
treeb4b150e81ede61f0ac774aae901b8e9970c6ca92 /dev-java
parentStable for amd64 wrt bug #471680 (diff)
downloadgentoo-2-3793e5b1e9a69945cb401b66bc667bee3d88f6a5.tar.gz
gentoo-2-3793e5b1e9a69945cb401b66bc667bee3d88f6a5.tar.bz2
gentoo-2-3793e5b1e9a69945cb401b66bc667bee3d88f6a5.zip
Revision bump to use generated build.xml instead of bailing out due to QA violation.
(Portage version: 2.1.12.2/cvs/Linux x86_64, signed Manifest commit with key 6D34E57D)
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/javax-inject/ChangeLog10
-rw-r--r--dev-java/javax-inject/files/javax-inject-1-build.xml154
-rw-r--r--dev-java/javax-inject/javax-inject-1-r1.ebuild46
3 files changed, 208 insertions, 2 deletions
diff --git a/dev-java/javax-inject/ChangeLog b/dev-java/javax-inject/ChangeLog
index 70ee8860c628..d7ecbc0ee527 100644
--- a/dev-java/javax-inject/ChangeLog
+++ b/dev-java/javax-inject/ChangeLog
@@ -1,10 +1,16 @@
# ChangeLog for dev-java/javax-inject
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/javax-inject/ChangeLog,v 1.1 2013/03/26 04:17:41 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/javax-inject/ChangeLog,v 1.2 2013/05/29 11:34:30 tomwij Exp $
+
+*javax-inject-1-r1 (29 May 2013)
+
+ 29 May 2013; Tom Wijsman <TomWij@gentoo.org> +files/javax-inject-1-build.xml,
+ +javax-inject-1-r1.ebuild:
+ Revision bump to use generated build.xml instead of bailing out due to QA
+ violation.
*javax-inject-1 (26 Mar 2013)
26 Mar 2013; Tim Harder <radhermit@gentoo.org> +javax-inject-1.ebuild,
+metadata.xml:
Initial import.
-
diff --git a/dev-java/javax-inject/files/javax-inject-1-build.xml b/dev-java/javax-inject/files/javax-inject-1-build.xml
new file mode 100644
index 000000000000..2b7e7cdd3051
--- /dev/null
+++ b/dev-java/javax-inject/files/javax-inject-1-build.xml
@@ -0,0 +1,154 @@
+<?xml version="1.0" encoding="UTF-8"?>
+
+<!-- ====================================================================== -->
+<!-- Ant build file (http://ant.apache.org/) for Ant 1.6.2 or above. -->
+<!-- ====================================================================== -->
+
+<!-- ====================================================================== -->
+<!-- ===================== - DO NOT EDIT THIS FILE! - ===================== -->
+<!-- ====================================================================== -->
+<!-- -->
+<!-- Any modifications will be overwritten. -->
+<!-- -->
+<!-- Generated by Maven Ant Plugin on 5/29/13 1:21 PM -->
+<!-- See: http://maven.apache.org/plugins/maven-ant-plugin/ -->
+<!-- -->
+<!-- ====================================================================== -->
+
+<project name="javax.inject-from-maven" default="package" basedir=".">
+
+ <!-- ====================================================================== -->
+ <!-- Build environment properties -->
+ <!-- ====================================================================== -->
+
+ <property file="${user.home}/.m2/maven.properties"/>
+ <property file="maven-build.properties"/>
+
+ <property name="maven.build.finalName" value="javax.inject-1"/>
+ <property name="maven.build.dir" value="target"/>
+ <property name="maven.build.outputDir" value="${maven.build.dir}/classes"/>
+ <property name="maven.build.srcDir.0" value="src/main/java"/>
+ <property name="maven.build.resourceDir.0" value="src/main/resources"/>
+ <property name="maven.build.testOutputDir" value="${maven.build.dir}/test-classes"/>
+ <property name="maven.build.testDir.0" value="src/test/java"/>
+ <property name="maven.build.testResourceDir.0" value="src/test/resources"/>
+ <property name="maven.test.reports" value="${maven.build.dir}/test-reports"/>
+ <property name="maven.reporting.outputDirectory" value="${maven.build.dir}/site"/>
+
+ <property name="maven.repo.local" value="${user.home}/.m2/repository"/>
+ <property name="maven.settings.offline" value="false"/>
+ <property name="maven.settings.interactiveMode" value="true"/>
+
+ <!-- ====================================================================== -->
+ <!-- Defining classpaths -->
+ <!-- ====================================================================== -->
+
+ <path id="build.classpath"/>
+ <path id="build.test.classpath"/>
+
+ <!-- ====================================================================== -->
+ <!-- Cleaning up target -->
+ <!-- ====================================================================== -->
+
+ <target name="clean" description="Clean the output directory">
+ <delete dir="${maven.build.dir}"/>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Compilation target -->
+ <!-- ====================================================================== -->
+
+ <target name="compile" depends="get-deps" description="Compile the code">
+ <mkdir dir="${maven.build.outputDir}"/>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Test-compilation target -->
+ <!-- ====================================================================== -->
+
+ <target name="compile-tests"
+ depends="compile"
+ description="Compile the test code"
+ unless="maven.test.skip">
+ <mkdir dir="${maven.build.testOutputDir}"/>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Run all tests -->
+ <!-- ====================================================================== -->
+
+ <target name="test"
+ depends="compile-tests, junit-missing"
+ unless="junit.skipped"
+ description="Run the test cases"/>
+
+ <target name="test-junit-present">
+ <available classname="junit.framework.Test" property="junit.present"/>
+ </target>
+
+ <target name="test-junit-status"
+ depends="test-junit-present">
+ <condition property="junit.missing">
+ <and>
+ <isfalse value="${junit.present}"/>
+ <isfalse value="${maven.test.skip}"/>
+ </and>
+ </condition>
+ <condition property="junit.skipped">
+ <or>
+ <isfalse value="${junit.present}"/>
+ <istrue value="${maven.test.skip}"/>
+ </or>
+ </condition>
+ </target>
+
+ <target name="junit-missing"
+ depends="test-junit-status"
+ if="junit.missing">
+ <echo>=================================== WARNING ===================================</echo>
+ <echo> JUnit is not present in your $ANT_HOME/lib directory. Tests not executed.</echo>
+ <echo>===============================================================================</echo>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Javadoc target -->
+ <!-- ====================================================================== -->
+
+ <target name="javadoc" description="Generates the Javadoc of the application"/>
+
+ <!-- ====================================================================== -->
+ <!-- Package target -->
+ <!-- ====================================================================== -->
+
+ <target name="package" depends="compile,test" description="Package the application">
+ <jar jarfile="${maven.build.dir}/${maven.build.finalName}.jar"
+ compress="true"
+ index="false"
+ basedir="${maven.build.outputDir}"
+ excludes="**/package.html"/>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- A dummy target for the package named after the type it creates -->
+ <!-- ====================================================================== -->
+
+ <target name="jar" depends="package" description="Builds the jar for the application"/>
+
+ <!-- ====================================================================== -->
+ <!-- Download dependencies target -->
+ <!-- ====================================================================== -->
+
+ <target name="test-offline">
+ <condition property="maven.mode.offline">
+ <equals arg1="${maven.settings.offline}" arg2="true"/>
+ </condition>
+ </target>
+
+ <target name="get-deps"
+ depends="test-offline"
+ description="Download all dependencies"
+ unless="maven.mode.offline">
+ <mkdir dir="${maven.repo.local}"/>
+ </target>
+
+</project>
diff --git a/dev-java/javax-inject/javax-inject-1-r1.ebuild b/dev-java/javax-inject/javax-inject-1-r1.ebuild
new file mode 100644
index 000000000000..4efa5d89288c
--- /dev/null
+++ b/dev-java/javax-inject/javax-inject-1-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/javax-inject/javax-inject-1-r1.ebuild,v 1.1 2013/05/29 11:34:30 tomwij Exp $
+
+EAPI="5"
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-ant-2
+
+MY_P=${PN/-/.}-${PV}
+
+DESCRIPTION="Dependency injection for Java (JSR-330)"
+HOMEPAGE="http://code.google.com/p/atinject/"
+SRC_URI="http://atinject.googlecode.com/files/${MY_P}-bundle.jar"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND=">=virtual/jdk-1.5
+ app-arch/unzip"
+
+RDEPEND=">=virtual/jre-1.5"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ unpack ${A}
+
+ cd "${S}"
+ unzip -q ${MY_P}-sources.jar || die
+}
+
+java_prepare() {
+ cp "${FILESDIR}"/${P}-build.xml build.xml || die
+
+ sed -i 's/\(<mkdir dir="${maven.build.outputDir}"\/>\)/\1<javac srcdir="." destdir="${maven.build.outputDir}" \/>/g' build.xml || die
+}
+
+src_install() {
+ java-pkg_newjar target/javax.inject-${PV}.jar
+
+ use doc && java-pkg_dojavadoc target/api
+ use source && java-pkg_dosrc javax
+}