summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2011-12-15 18:08:11 +0000
committerMiroslav Šulc <fordfrog@gentoo.org>2011-12-15 18:08:11 +0000
commit2fc177ad8f26dcccc69599d878d5c79145f773bc (patch)
tree1ea2c074c178973717ca92340ca40638655bff50 /dev-java
parentStable for AMD64, wrt bug #376397 (diff)
downloadgentoo-2-2fc177ad8f26dcccc69599d878d5c79145f773bc.tar.gz
gentoo-2-2fc177ad8f26dcccc69599d878d5c79145f773bc.tar.bz2
gentoo-2-2fc177ad8f26dcccc69599d878d5c79145f773bc.zip
dev-java/tomcat-native: version bump
(Portage version: 2.1.10.41/cvs/Linux x86_64)
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/tomcat-native/ChangeLog10
-rw-r--r--dev-java/tomcat-native/tomcat-native-1.1.22.ebuild47
2 files changed, 55 insertions, 2 deletions
diff --git a/dev-java/tomcat-native/ChangeLog b/dev-java/tomcat-native/ChangeLog
index 5fd98a4bed9f..38dad65efc1a 100644
--- a/dev-java/tomcat-native/ChangeLog
+++ b/dev-java/tomcat-native/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-java/tomcat-native
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/tomcat-native/ChangeLog,v 1.29 2010/05/26 19:09:42 pacho Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/tomcat-native/ChangeLog,v 1.30 2011/12/15 18:08:11 fordfrog Exp $
+
+*tomcat-native-1.1.22 (15 Dec 2011)
+
+ 15 Dec 2011; Miroslav Šulc <fordfrog@gentoo.org>
+ +tomcat-native-1.1.22.ebuild:
+ Version bump
26 May 2010; Pacho Ramos <pacho@gentoo.org> tomcat-native-1.1.20.ebuild:
stable amd64, bug 316551
diff --git a/dev-java/tomcat-native/tomcat-native-1.1.22.ebuild b/dev-java/tomcat-native/tomcat-native-1.1.22.ebuild
new file mode 100644
index 000000000000..6321d76b54cb
--- /dev/null
+++ b/dev-java/tomcat-native/tomcat-native-1.1.22.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/tomcat-native/tomcat-native-1.1.22.ebuild,v 1.1 2011/12/15 18:08:11 fordfrog Exp $
+
+EAPI="2"
+
+inherit base eutils java-pkg-2
+
+DESCRIPTION="Native APR library for Tomcat"
+
+SLOT="0"
+SRC_URI="mirror://apache/tomcat/tomcat-connectors/native/${PV}/source/${P}-src.tar.gz"
+HOMEPAGE="http://tomcat.apache.org/"
+KEYWORDS="~amd64 ~x86"
+LICENSE="Apache-2.0"
+IUSE=""
+
+RDEPEND="=dev-libs/apr-1*
+ dev-libs/openssl
+ >=virtual/jre-1.5"
+
+DEPEND=">=virtual/jdk-1.5
+ ${RDEPEND}"
+
+S=${WORKDIR}/${P}-src/jni/native
+
+src_configure(){
+ econf --with-apr=/usr/bin/apr-1-config \
+ --with-ssl=/usr || die "Could not configure native sources"
+}
+
+src_compile() {
+ base_src_compile
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Could not install libtcnative-1.so"
+}
+
+pkg_postinst() {
+ elog
+ elog " APR should be available with Tomcat, for more information"
+ elog " please see http://tomcat.apache.org/tomcat-6.0-doc/apr.html"
+ elog
+ elog " Please report any bugs to http://bugs.gentoo.org/"
+ elog
+}