summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2010-01-31 17:19:10 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2010-01-31 17:19:10 +0000
commit14c08b1e423533fcec2203af00fb19f8e78303c4 (patch)
treed0c7f7d7139610918f6bc20f1a04065cc6dd5cd9 /dev-java
parentold (diff)
downloadgentoo-2-14c08b1e423533fcec2203af00fb19f8e78303c4.tar.gz
gentoo-2-14c08b1e423533fcec2203af00fb19f8e78303c4.tar.bz2
gentoo-2-14c08b1e423533fcec2203af00fb19f8e78303c4.zip
Require a new version of jffi so that the jruby wrapper has one less java-config call. Also drop RubyGems and leave it to dev-ruby/rubygems to install it.
(Portage version: 2.2_rc62/cvs/Linux x86_64)
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/jruby/ChangeLog10
-rw-r--r--dev-java/jruby/files/jruby-1.4.0-system-jars-r2.patch276
-rw-r--r--dev-java/jruby/jruby-1.4.0-r5.ebuild181
3 files changed, 466 insertions, 1 deletions
diff --git a/dev-java/jruby/ChangeLog b/dev-java/jruby/ChangeLog
index 8b2e34ff8ab7..dde6f593db7c 100644
--- a/dev-java/jruby/ChangeLog
+++ b/dev-java/jruby/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-java/jruby
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/jruby/ChangeLog,v 1.53 2010/01/24 00:54:52 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jruby/ChangeLog,v 1.54 2010/01/31 17:19:09 flameeyes Exp $
+
+*jruby-1.4.0-r5 (31 Jan 2010)
+
+ 31 Jan 2010; Diego E. Pettenò <flameeyes@gentoo.org>
+ +jruby-1.4.0-r5.ebuild, +files/jruby-1.4.0-system-jars-r2.patch:
+ Require a new version of jffi so that the jruby wrapper has one less
+ java-config call. Also drop RubyGems and leave it to dev-ruby/rubygems to
+ install it.
24 Jan 2010; Diego E. Pettenò <flameeyes@gentoo.org>
jruby-1.4.0-r4.ebuild, +files/jruby-1.4.0-bindir.patch:
diff --git a/dev-java/jruby/files/jruby-1.4.0-system-jars-r2.patch b/dev-java/jruby/files/jruby-1.4.0-system-jars-r2.patch
new file mode 100644
index 000000000000..8b96db90c9fc
--- /dev/null
+++ b/dev-java/jruby/files/jruby-1.4.0-system-jars-r2.patch
@@ -0,0 +1,276 @@
+Index: jruby-1.4.0/bin/jruby
+===================================================================
+--- jruby-1.4.0.orig/bin/jruby
++++ jruby-1.4.0/bin/jruby
+@@ -11,26 +11,17 @@
+ #
+ # -----------------------------------------------------------------------------
+
+-cygwin=false
+-
+ # ----- Identify OS we are running under --------------------------------------
+ case "`uname`" in
+- CYGWIN*) cygwin=true;;
+ Darwin) darwin=true;;
+ esac
+
+-#
+-# Figure out the OS and cpu the same as JNA would, so the library path can be set
+-#
+-case "`uname -m`" in
+- i[34567]86) JNA_CPU=i386; JNA_ALT_CPU=amd64;;
+- i86pc) JNA_CPU="x86"; JNA_ALT_CPU=amd64;;
+- amd64|x86_64) JNA_CPU=amd64; JNA_ALT_CPU=i386;;
+- sparc*) JNA_CPU=sparc; JNA_ALT_CPU=sparcv9;;
+-esac
+-
+ # ----- Verify and Set Required Environment Variables -------------------------
+
++# This will be filled in by the ebuild after install
++JRUBY_HOME=
++
++# ++ebuild-cut-here++
+ ## resolve links - $0 may be a link to home
+ PRG=$0
+ progname=`basename "$0"`
+@@ -49,13 +40,16 @@ while [ -h "$PRG" ] ; do
+ fi
+ done
+
+-JRUBY_HOME_1=`dirname "$PRG"` # the ./bin dir
+-if [ "$JRUBY_HOME_1" = '.' ] ; then
+- cwd=`pwd`
+- JRUBY_HOME=`dirname $cwd` # JRUBY-2699
+-else
+- JRUBY_HOME=`dirname "$JRUBY_HOME_1"` # the . dir
++if [ -z "$JRUBY_HOME" ]; then
++ JRUBY_HOME_1=`dirname "$PRG"` # the ./bin dir
++ if [ "$JRUBY_HOME_1" = '.' ] ; then
++ cwd=`pwd`
++ JRUBY_HOME=`dirname $cwd` # JRUBY-2699
++ else
++ JRUBY_HOME=`dirname "$JRUBY_HOME_1"` # the . dir
++ fi
+ fi
++# --ebuild-cut-here--
+
+ if [ -z "$JRUBY_OPTS" ] ; then
+ JRUBY_OPTS=""
+@@ -84,72 +78,17 @@ for opt in ${JRUBY_OPTS[@]}; do
+ done
+ JRUBY_OPTS=${JRUBY_OPTS_TEMP}
+
+-if [ -z "$JAVA_HOME" ] ; then
+- JAVA_CMD='java'
+-else
+- if $cygwin; then
+- JAVA_HOME=`cygpath -u "$JAVA_HOME"`
+- fi
+- JAVA_CMD="$JAVA_HOME/bin/java"
+-fi
+-
+-# If you're seeing odd exceptions, you may have a bad JVM install.
+-# Uncomment this and report the version to the JRuby team along with error.
+-#$JAVA_CMD -version
+-
+ JRUBY_SHELL=/bin/sh
+
+ # ----- Set Up The Boot Classpath -------------------------------------------
+
+-CP_DELIMITER=":"
+-
+-# add jruby jars for command-line execution
+-for j in "$JRUBY_HOME"/lib/{jruby*,bsf}.jar; do
+- if [ "$JRUBY_CP" ]; then
+- JRUBY_CP="$JRUBY_CP$CP_DELIMITER$j"
+- else
+- JRUBY_CP="$j"
+- fi
+-done
+-
+-if $cygwin; then
+- JRUBY_CP=`cygpath -p -w "$JRUBY_CP"`
+-fi
+-
+-# ----- Set Up The System Classpath -------------------------------------------
+-
+-if [ "$JRUBY_PARENT_CLASSPATH" != "" ]; then
+- # Use same classpath propagated from parent jruby
+- CP=$JRUBY_PARENT_CLASSPATH
+-else
+- # add other jars in lib to CP for command-line execution
+- for j in "$JRUBY_HOME"/lib/*.jar; do
+- if [ "$CP" ]; then
+- CP="$CP$CP_DELIMITER$j"
+- else
+- CP="$j"
+- fi
+- done
+-
+- if $cygwin; then
+- CP=`cygpath -p -w "$CP"`
+- fi
+-fi
+-
+-if $cygwin; then
+- # switch delimiter only after building Unix style classpaths
+- CP_DELIMITER=";"
+-fi
++JRUBY_CP=$(java-config -d -p jruby)
++CP=${JRUBY_PARENT_CLASSPATH}
+
+ # ----- Execute The Requested Command -----------------------------------------
+
+-if [ -z "$JAVA_MEM" ] ; then
+- JAVA_MEM=-Xmx500m
+-fi
+-
+-if [ -z "$JAVA_STACK" ] ; then
+- JAVA_STACK=-Xss1024k
+-fi
++JAVA_MEM=${JAVA_MEM:--Xmx500m}
++JAVA_STACK=${JAVA_STACK:--Xss1024k}
+
+ JAVA_VM=-client
+ JAVA_ENCODING=""
+@@ -172,18 +111,18 @@ do
+ elif [ "${val:0:4}" = "-Xss" ]; then
+ JAVA_STACK=$val
+ elif [ "${val}" = "" ]; then
+- $JAVA_CMD -help
++ java -help
+ echo "(Prepend -J in front of these options when using 'jruby' command)"
+ exit
+ elif [ "${val}" = "-X" ]; then
+- $JAVA_CMD -X
++ java -X
+ echo "(Prepend -J in front of these options when using 'jruby' command)"
+ exit
+ elif [ "${val}" = "-classpath" ]; then
+- CP="$CP$CP_DELIMITER$2"
++ CP="$CP:$2"
+ shift
+ elif [ "${val}" = "-cp" ]; then
+- CP="$CP$CP_DELIMITER$2"
++ CP="$CP:$2"
+ shift
+ else
+ if [ "${val:0:3}" = "-ea" ]; then
+@@ -221,14 +160,7 @@ do
+ java_args=("${java_args[@]}" "-Djava.awt.headless=true") ;;
+ # Run under JDB
+ --jdb)
+- if [ -z "$JAVA_HOME" ] ; then
+- JAVA_CMD='jdb'
+- else
+- if $cygwin; then
+- JAVA_HOME=`cygpath -u "$JAVA_HOME"`
+- fi
+- JAVA_CMD="$JAVA_HOME/bin/jdb"
+- fi
++ JAVA_CMD='jdb'
+ java_args=("${java_args[@]}" "-sourcepath" "$JRUBY_HOME/lib/ruby/1.8:.")
+ JRUBY_OPTS=("${JRUBY_OPTS[@]}" "-X+C") ;;
+ --client)
+@@ -270,57 +202,17 @@ ruby_args=("${ruby_args[@]}" "$@")
+ set -- "${ruby_args[@]}"
+
+ JAVA_OPTS="$JAVA_OPTS $JAVA_MEM $JAVA_STACK"
+-JNA_OS="`uname -s | tr '[:upper:]' '[:lower:]'`"
+-case "$JNA_OS" in
+-darwin) JNA_PATH="$JRUBY_HOME/lib/native/darwin";;
+- *) JNA_PATH="$JRUBY_HOME/lib/native/${JNA_OS}-${JNA_CPU}:$JRUBY_HOME/lib/native/${JNA_OS}-${JNA_ALT_CPU}";;
+-esac
+-#JAVA_OPTS="$JAVA_OPTS -Djna.boot.library.path=$JNA_PATH"
+-JAVA_JNA="-Djna.boot.library.path=$JNA_PATH"
+
+-JFFI_BOOT=""
+-for d in $JRUBY_HOME/lib/native/*`uname -s`; do
+- if [ -z "$JFFI_BOOT" ]; then
+- JFFI_BOOT="$d"
+- else
+- JFFI_BOOT="$JFFI_BOOT:$d"
+- fi
+-done
+-JFFI_OPTS="-Djffi.boot.library.path=$JFFI_BOOT"
+-
+-if $cygwin; then
+- JRUBY_HOME=`cygpath --mixed "$JRUBY_HOME"`
+- JRUBY_SHELL=`cygpath --mixed "$JRUBY_SHELL"`
+-
+- if [[ ( "${1:0:1}" = "/" ) && ( ( -f "$1" ) || ( -d "$1" )) ]]; then
+- win_arg=`cygpath -w "$1"`
+- shift
+- win_args=("$win_arg" "$@")
+- set -- "${win_args[@]}"
+- fi
+-
+- # fix JLine to use UnixTerminal
+- stty -icanon min 1 -echo > /dev/null 2>&1
+- if [ $? = 0 ]; then
+- JAVA_OPTS="$JAVA_OPTS -Djline.terminal=jline.UnixTerminal"
+- fi
+-
+-fi
++JAVA_JNA="-Djna.boot.library.path=$(java-config -i jna)"
+
+ if [ "$nailgun_client" != "" ]; then
+- if [ -f $JRUBY_HOME/tool/nailgun/ng ]; then
+- exec $JRUBY_HOME/tool/nailgun/ng org.jruby.util.NailMain $JRUBY_OPTS "$@"
+- else
+- echo "error: ng executable not found; run 'make' in ${JRUBY_HOME}/tool/nailgun"
+- exit 1
+- fi
+-else
+-if [ "$VERIFY_JRUBY" != "" ]; then
++ exec /usr/bin/ng org.jruby.util.NailMain $JRUBY_OPTS "$@"
++elif [ "$VERIFY_JRUBY" != "" ]; then
+ if [ "$PROFILE_ARGS" != "" ]; then
+ echo "Running with instrumented profiler"
+ fi
+
+- "$JAVA_CMD" $PROFILE_ARGS $JAVA_OPTS "$JAVA_JNA" "$JFFI_OPTS" "${java_args[@]}" -classpath "$JRUBY_CP$CP_DELIMITER$CP$CP_DELIMITER$CLASSPATH" \
++ "${JAVA_CMD:-java}" $PROFILE_ARGS $JAVA_OPTS "$JAVA_JNA" "${java_args[@]}" -classpath "$JRUBY_CP:$CP:$CLASSPATH" \
+ "-Djruby.home=$JRUBY_HOME" \
+ "-Djruby.lib=$JRUBY_HOME/lib" -Djruby.script=jruby \
+ "-Djruby.shell=$JRUBY_SHELL" \
+@@ -335,34 +228,13 @@ if [ "$VERIFY_JRUBY" != "" ]; then
+ rm profile.txt
+ fi
+
+- if $cygwin; then
+- stty icanon echo > /dev/null 2>&1
+- fi
+-
+ exit $JRUBY_STATUS
+ else
+- if $cygwin; then
+- # exec doed not work correctly with cygwin bash
+- "$JAVA_CMD" $JAVA_OPTS "$JAVA_JNA" "$JFFI_OPTS" "${java_args[@]}" -Xbootclasspath/a:"$JRUBY_CP" -classpath "$CP$CP_DELIMITER$CLASSPATH" \
+- "-Djruby.home=$JRUBY_HOME" \
+- "-Djruby.lib=$JRUBY_HOME/lib" -Djruby.script=jruby \
+- "-Djruby.shell=$JRUBY_SHELL" \
+- $java_class $JRUBY_OPTS "$@"
+-
+- # Record the exit status immediately, or it will be overridden.
+- JRUBY_STATUS=$?
+-
+- stty icanon echo > /dev/null 2>&1
+-
+- exit $JRUBY_STATUS
+- else
+- exec "$JAVA_CMD" $JAVA_OPTS "$JAVA_JNA" "$JFFI_OPTS" "${java_args[@]}" -Xbootclasspath/a:"$JRUBY_CP" -classpath "$CP$CP_DELIMITER$CLASSPATH" \
+- "-Djruby.home=$JRUBY_HOME" \
+- "-Djruby.lib=$JRUBY_HOME/lib" -Djruby.script=jruby \
+- "-Djruby.shell=$JRUBY_SHELL" \
+- $java_class $JRUBY_OPTS "$@"
+- fi
+-fi
++ exec "${JAVA_CMD:-java}" $JAVA_OPTS "$JAVA_JNA" "${java_args[@]}" -Xbootclasspath/a:"$JRUBY_CP" -classpath "$CP:$CLASSPATH" \
++ "-Djruby.home=$JRUBY_HOME" \
++ "-Djruby.lib=$JRUBY_HOME/lib" -Djruby.script=jruby \
++ "-Djruby.shell=$JRUBY_SHELL" \
++ $java_class $JRUBY_OPTS "$@"
+ fi
+
+ # Be careful adding code down here, you might override the exit
diff --git a/dev-java/jruby/jruby-1.4.0-r5.ebuild b/dev-java/jruby/jruby-1.4.0-r5.ebuild
new file mode 100644
index 000000000000..5a86c7d8f45d
--- /dev/null
+++ b/dev-java/jruby/jruby-1.4.0-r5.ebuild
@@ -0,0 +1,181 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jruby/jruby-1.4.0-r5.ebuild,v 1.1 2010/01/31 17:19:09 flameeyes Exp $
+
+EAPI="2"
+JAVA_PKG_IUSE="doc source test"
+inherit eutils java-pkg-2 java-ant-2
+
+MY_PV="${PV/_rc1/RC1}"
+
+DESCRIPTION="Java-based Ruby interpreter implementation"
+HOMEPAGE="http://jruby.codehaus.org/"
+SRC_URI="http://jruby.kenai.com/downloads/${PV}/${PN}-src-${MY_PV}.tar.gz"
+LICENSE="|| ( CPL-1.0 GPL-2 LGPL-2.1 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="bsf java6 ssl"
+
+CDEPEND=">=dev-java/bytelist-1.0.2:0
+ >=dev-java/constantine-0.6:0
+ >=dev-java/jline-0.9.94:0
+ >=dev-java/joni-1.1.3:0
+ >=dev-java/jna-posix-1.0.1:0
+ >=dev-java/jvyamlb-0.2.5:0
+ >=dev-java/asm-3.2:3
+ dev-java/jcodings:0
+ >=dev-java/jffi-0.7_pre:0.4
+ dev-java/jna:0
+ dev-java/joda-time:0
+ dev-util/jay:0[java]
+ !java6? ( dev-java/backport-util-concurrent:0 )
+ dev-java/nailgun:0
+ dev-java/jaffl:0
+ dev-java/jgrapht:0"
+
+RDEPEND="${CDEPEND}
+ !java6? ( =virtual/jre-1.5* )
+ java6? ( >=virtual/jre-1.6 )"
+
+# using 1.6 produces 1.6 bytecode, not sure why
+DEPEND="${CDEPEND}
+ !java6? ( =virtual/jdk-1.5* )
+ java6? ( >=virtual/jdk-1.6 )
+ bsf? ( dev-java/bsf:2.3 )
+ test? (
+ dev-java/ant-junit
+ dev-java/ant-trax
+ )
+ !!<dev-ruby/jruby-1.3.1-r1"
+
+PDEPEND="ssl? ( dev-ruby/jruby-openssl )"
+
+# Tests work for ali_bush. But fail for flameeyes see #282439.
+# Tests work for ali_bush inside the ebuild env
+# but fail when using vanilla src tarball.
+# Restrict tests so we can stablise this package.
+#RESTRICT="test"
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+RUBY_HOME=/usr/share/${PN}/lib/ruby
+SITE_RUBY=${RUBY_HOME}/site_ruby
+GEMS=${RUBY_HOME}/gems
+
+JAVA_ANT_REWRITE_CLASSPATH="true"
+JAVA_ANT_IGNORE_SYSTEM_CLASSES="true"
+EANT_GENTOO_CLASSPATH="asm-3 bytelist constantine jay jcodings jffi-0.4 jline \
+joda-time joni jna jna-posix jvyamlb nailgun jaffl jgrapht"
+EANT_NEEDS_TOOLS="true"
+
+pkg_setup() {
+ java-pkg-2_pkg_setup
+ use java6 || EANT_GENTOO_CLASSPATH="${EANT_GENTOO_CLASSPATH} backport-util-concurrent"
+
+ local fail
+
+ for directory in "${GEMS}" "${SITE_RUBY}"; do
+ if [[ -L ${directory} ]]; then
+ eerror "${directory} is a symlink. Please remove this symlink."
+ fail="true"
+ fi
+ done
+
+ if [[ -n ${fail} ]]; then
+ die "Please address the above errors, then run emerge --resume"
+ fi
+}
+
+java_prepare() {
+ epatch "${FILESDIR}/ftype-test-fixes.patch"
+ epatch "${FILESDIR}/user-test-fixes.patch"
+ epatch "${FILESDIR}"/${P}-system-jars-r2.patch
+ epatch "${FILESDIR}"/${P}-bindir.patch
+
+ # We don't need to use Retroweaver. There is a jarjar and a regular jar
+ # target but even with jarjarclean, both are a pain. The latter target
+ # is slightly easier so go with this one.
+ sed -r -i \
+ -e 's/maxmemory="128m"/maxmemory="192m"/' \
+ -e "/RetroWeaverTask/d" \
+ -e "/<zipfileset .+\/>/d" \
+ build.xml || die
+
+ sed -i -e '/Arndt/d' src/org/jruby/RubyBigDecimal.java
+
+ # Delete the bundled JARs but keep invokedynamic.jar.
+ # No source is available and it's only a dummy anyway.
+ find build_lib -name "*.jar" ! -name "jsr292-mock.jar" -delete || die
+ rm lib/profile.jar || die
+
+ if ! use bsf; then
+ # Remove BSF test cases.
+ cd "${S}/test/org/jruby"
+ rm -f test/TestAdoptedThreading.java || die
+ rm -f javasupport/test/TestBSF.java || die
+ sed -i '/TestBSF.class/d' javasupport/test/JavaSupportTestSuite.java || die
+ sed -i '/TestAdoptedThreading.class/d' test/MainTestSuite.java || die
+ fi
+}
+
+src_compile() {
+ eant jar $(use_doc apidocs) -Djdk1.5+=true
+}
+
+src_test() {
+ if [ ${UID} == 0 ] ; then
+ ewarn 'The tests will fail if run as root so skipping them.'
+ ewarn 'Enable FEATURES="userpriv" if you want to run them.'
+ return
+ fi
+
+ # ali_bush was getting crashes while attempting to run a test.
+ # No info about why it crashed seemed to be produced.
+ # remove it as temp fix.
+ #sed -i -e '/MRI/d' build.xml || die "Failed to sed build.xml"
+
+ # BSF is a compile-time only dependency because it's just the adapter
+ # classes and they won't be used unless invoked from BSF itself.
+ use bsf && java-pkg_jar-from --into build_lib --with-dependencies bsf-2.3
+
+ # Our jruby.jar is unbundled so we need to add the classpath to this test.
+ sed -i "s:java -jar:java -Xbootclasspath/a\:#{ENV['JRUBY_CP']} -jar:g" test/test_load_compiled_ruby_class_from_classpath.rb || die
+
+ ANT_TASKS="ant-junit ant-trax" JRUBY_CP=`java-pkg_getjars ${EANT_GENTOO_CLASSPATH// /,}` JRUBY_OPTS="" eant test -Djdk1.5+=true
+}
+
+src_install() {
+ local bin
+
+ java-pkg_dojar lib/${PN}.jar
+ dodoc README docs/{*.txt,README.*} || die
+
+ use doc && java-pkg_dojavadoc docs/api
+ use source && java-pkg_dosrc src/org
+
+ # We run the sed here in install so that we don't get the wrong
+ # data during the test phase!
+ sed \
+ -e '/++ebuild-cut-here++/, /--ebuild-cut-here--/ d' \
+ -e '/^JRUBY_HOME=/s:=:=/usr/share/jruby:' \
+ bin/jruby > "${T}"/jruby
+
+ dobin "${T}"/jruby "${S}"/bin/j{irb{,_swing},rubyc} || die
+
+ insinto "${RUBY_HOME}"
+ doins -r "${S}"/lib/ruby/{1.8,1.9,site_ruby} || die
+
+ # Remove all the references to RubyGems as we're just going to
+ # install it through dev-ruby/rubygems.
+ find "${D}${RUBY_HOME}" -type f \
+ '(' '(' -path '*rubygems*' -not -name 'jruby.rb' ')' -or -name 'ubygems.rb' -or -name 'datadir.rb' ')' \
+ -delete || die
+}
+
+pkg_postinst() {
+ ewarn "If you're updating from <=jruby-1.4.0, you're going to get errors related"
+ ewarn "to gentoo.rb load failure."
+ ewarn "This is due to a stray definition of JRUBY_OPTS variable from the previous ebuilds."
+ ewarn "To solve the problem, either login in a new shell, use 'env -i ${SHELL} --login'"
+ ewarn "or explicitly unset the variable before running jruby."
+}