summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Thomson <wltjr@gentoo.org>2008-03-03 00:55:03 +0000
committerWilliam Thomson <wltjr@gentoo.org>2008-03-03 00:55:03 +0000
commit0b9b534c02f658310849736030497e15f5b67f80 (patch)
tree4fd6e722a9246b8addfa6453b43d61bdf75a9101 /dev-java
parentStable on x86 wrt #212077 (diff)
downloadgentoo-2-0b9b534c02f658310849736030497e15f5b67f80.tar.gz
gentoo-2-0b9b534c02f658310849736030497e15f5b67f80.tar.bz2
gentoo-2-0b9b534c02f658310849736030497e15f5b67f80.zip
amd64 stable, bug #177362.Removed past versions in same slot.
(Portage version: 2.1.4.1)
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/ant-tasks/ChangeLog7
-rw-r--r--dev-java/ant-tasks/ant-tasks-1.7.0-r2.ebuild118
-rw-r--r--dev-java/ant-tasks/ant-tasks-1.7.0-r3.ebuild100
-rw-r--r--dev-java/ant-tasks/ant-tasks-1.7.0-r4.ebuild4
4 files changed, 8 insertions, 221 deletions
diff --git a/dev-java/ant-tasks/ChangeLog b/dev-java/ant-tasks/ChangeLog
index b7cffad00e20..0857e9a977cb 100644
--- a/dev-java/ant-tasks/ChangeLog
+++ b/dev-java/ant-tasks/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-java/ant-tasks
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/ant-tasks/ChangeLog,v 1.78 2008/01/22 02:14:27 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/ant-tasks/ChangeLog,v 1.79 2008/03/03 00:55:03 wltjr Exp $
+
+ 03 Mar 2008; William L. Thomson Jr. <wltjr@gentoo.org>
+ -ant-tasks-1.7.0-r2.ebuild, -ant-tasks-1.7.0-r3.ebuild,
+ ant-tasks-1.7.0-r4.ebuild:
+ amd64 stable, bug #177362.Removed past versions in same slot.
22 Jan 2008; Brent Baude <ranger@gentoo.org> ant-tasks-1.7.0-r4.ebuild:
Marking ant-tasks-1.7.0-r4 ppc64 for bug 177362
diff --git a/dev-java/ant-tasks/ant-tasks-1.7.0-r2.ebuild b/dev-java/ant-tasks/ant-tasks-1.7.0-r2.ebuild
deleted file mode 100644
index 95e148b0f029..000000000000
--- a/dev-java/ant-tasks/ant-tasks-1.7.0-r2.ebuild
+++ /dev/null
@@ -1,118 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/ant-tasks/ant-tasks-1.7.0-r2.ebuild,v 1.7 2007/10/30 01:20:18 betelgeuse Exp $
-
-inherit java-pkg-2 eutils
-
-DESCRIPTION="Meta-package for Apache Ant's optional tasks."
-HOMEPAGE="http://ant.apache.org/"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~ia64 ppc ppc64 x86 ~x86-fbsd"
-IUSE="jai javamail noantlr nobcel nobsf nocommonsnet nocommonslogging nojdepend
- nojmf nojsch nolog4j nooro noregexp noresolver noswing noxalan"
-# nobeanutils nobsh nojython norhino noxerces
-
-RDEPEND=">=virtual/jre-1.4
- ~dev-java/ant-core-${PV}
- ~dev-java/ant-nodeps-${PV}
- ~dev-java/ant-junit-${PV}
- !dev-java/ant-optional
- !noantlr? ( ~dev-java/ant-antlr-${PV} )
- !nobcel? ( ~dev-java/ant-apache-bcel-${PV} )
- !nobsf? ( ~dev-java/ant-apache-bsf-${PV} )
- !nolog4j? ( ~dev-java/ant-apache-log4j-${PV} )
- !nooro? ( ~dev-java/ant-apache-oro-${PV} )
- !noregexp? ( ~dev-java/ant-apache-regexp-${PV} )
- !noresolver? ( ~dev-java/ant-apache-resolver-${PV} )
- !nocommonslogging? ( ~dev-java/ant-commons-logging-${PV} )
- !nocommonsnet? ( ~dev-java/ant-commons-net-${PV} )
- jai? ( ~dev-java/ant-jai-${PV} )
- javamail? ( ~dev-java/ant-javamail-${PV} )
- !nojdepend? ( ~dev-java/ant-jdepend-${PV} )
- !nojmf? ( ~dev-java/ant-jmf-${PV} )
- !nojsch? ( ~dev-java/ant-jsch-${PV} )
- !noswing? ( ~dev-java/ant-swing-${PV} )
- !noxalan? ( ~dev-java/ant-trax-${PV} )"
-
-# TODO: consider those
-# !noxerces? ( >=dev-java/xerces-2.6.2-r1 )
-# !nobsh? ( >=dev-java/bsh-1.2-r7 )
-# !nobeanutils? ( =dev-java/commons-beanutils-1.6* )
-# !norhino? ( =dev-java/rhino-1.5* )
-# !nojython? ( >=dev-java/jython-2.1-r5 )
-
-DEPEND=">=virtual/jdk-1.4
- ${RDEPEND}"
-
-S="${WORKDIR}"
-
-src_compile() { :; }
-
-my_reg_jars() {
- # Recording jars to get the same behaviour as before
- local jars="$(java-pkg_getjars ${1})"
- for jar in ${jars//:/ }; do
- # these two are only for tasks, not core
- if [[ "${1}" != ant-core ]]; then
- # this one for package.env, thus java-config -p etc
- java-pkg_regjar "${jar}"
- # this one for broken stuff with hardcoded paths
- dosym ${jar} /usr/share/${PN}/lib/
- fi
- # this one for the non-split $ANT_HOME/lib expected by stuff that
- # doesn't use the launcher
- dosym ${jar} /usr/share/ant/lib/
- done
-}
-
-src_install() {
- # create the fake ANT_HOME with symlinks to all ant jars
- # starting with ant-core
- dodir /usr/share/ant/lib
- my_reg_jars ant-core
- # just in case
- dosym /usr/share/ant-core/bin /usr/share/ant/bin
-
- # now process the tasks
- my_reg_jars ant-nodeps
- use !noantlr && my_reg_jars ant-antlr
- use !nobcel && my_reg_jars ant-apache-bcel
- use !nobsf && my_reg_jars ant-apache-bsf
- use !nolog4j && my_reg_jars ant-apache-log4j
- use !nooro && my_reg_jars ant-apache-oro
- use !noregexp && my_reg_jars ant-apache-regexp
- use !noresolver && my_reg_jars ant-apache-resolver
- use !nocommonslogging && my_reg_jars ant-commons-logging
- use !nocommonsnet && my_reg_jars ant-commons-net
- use jai && my_reg_jars ant-jai
- use javamail && my_reg_jars ant-javamail
- use !nojdepend && my_reg_jars ant-jdepend
- use !nojmf && my_reg_jars ant-jmf
- use !nojsch && my_reg_jars ant-jsch
- my_reg_jars ant-junit
- use !noswing && my_reg_jars ant-swing
- use !noxalan && my_reg_jars ant-trax
-
- # point ANT_HOME to the one with all symlinked jars
- # ant-core startup script will ignore this one anyway
- echo "ANT_HOME=\"/usr/share/ant\"" > "${T}/21ant-tasks"
- doenvd "${T}/21ant-tasks" || die "failed to install env.d file"
-}
-
-pkg_postinst() {
- local noset=false
- for x in ${IUSE} ; do
- if [ "${x:0:2}" == "no" ] ; then
- use ${x} && noset=true
- fi
- done
- if [ ${noset} == "true" ]; then
- ewarn "You have disabled some of the ant tasks. Be advised that this may"
- ewarn "break building some of the Java packages!!"
- ewarn ""
- ewarn "We can only offer very limited support in cases where dev-java/ant-tasks"
- ewarn "has been build with essential features disabled."
- fi
-}
diff --git a/dev-java/ant-tasks/ant-tasks-1.7.0-r3.ebuild b/dev-java/ant-tasks/ant-tasks-1.7.0-r3.ebuild
deleted file mode 100644
index 938dce71e5b8..000000000000
--- a/dev-java/ant-tasks/ant-tasks-1.7.0-r3.ebuild
+++ /dev/null
@@ -1,100 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/ant-tasks/ant-tasks-1.7.0-r3.ebuild,v 1.1 2008/01/04 19:18:31 caster Exp $
-
-inherit java-pkg-2 eutils
-
-DESCRIPTION="Meta-package for Apache Ant's optional tasks."
-HOMEPAGE="http://ant.apache.org/"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
-IUSE="X antlr bcel bsf commonslogging commonsnet jai javamail jdepend jmf jsch
- log4j oro regexp resolver"
-
-RDEPEND=">=virtual/jre-1.4
- ~dev-java/ant-core-${PV}
- ~dev-java/ant-nodeps-${PV}
- ~dev-java/ant-junit-${PV}
- !dev-java/ant-optional
- ~dev-java/ant-trax-${PV}
- antlr? ( ~dev-java/ant-antlr-${PV} )
- bcel? ( ~dev-java/ant-apache-bcel-${PV} )
- bsf? ( ~dev-java/ant-apache-bsf-${PV} )
- log4j? ( ~dev-java/ant-apache-log4j-${PV} )
- oro? ( ~dev-java/ant-apache-oro-${PV} )
- regexp? ( ~dev-java/ant-apache-regexp-${PV} )
- resolver? ( ~dev-java/ant-apache-resolver-${PV} )
- commonslogging? ( ~dev-java/ant-commons-logging-${PV} )
- commonsnet? ( ~dev-java/ant-commons-net-${PV} )
- jai? ( ~dev-java/ant-jai-${PV} )
- javamail? ( ~dev-java/ant-javamail-${PV} )
- jdepend? ( ~dev-java/ant-jdepend-${PV} )
- jmf? ( ~dev-java/ant-jmf-${PV} )
- jsch? ( ~dev-java/ant-jsch-${PV} )
- X? ( ~dev-java/ant-swing-${PV} )"
-
-DEPEND=">=virtual/jdk-1.4
- ${RDEPEND}"
-
-S="${WORKDIR}"
-
-src_compile() { :; }
-
-my_reg_jars() {
- # Recording jars to get the same behaviour as before
- local jars="$(java-pkg_getjars ${1})"
- for jar in ${jars//:/ }; do
- # these two are only for tasks, not core
- if [[ "${1}" != ant-core ]]; then
- # this one for package.env, thus java-config -p etc
- java-pkg_regjar "${jar}"
- # this one for broken stuff with hardcoded paths
- dosym ${jar} /usr/share/${PN}/lib/
- fi
- # this one for the non-split $ANT_HOME/lib expected by stuff that
- # doesn't use the launcher
- dosym ${jar} /usr/share/ant/lib/
- done
-}
-
-src_install() {
- # create the fake ANT_HOME with symlinks to all ant jars
- # starting with ant-core
- dodir /usr/share/ant/lib
- my_reg_jars ant-core
- # just in case
- dosym /usr/share/ant-core/bin /usr/share/ant/bin
-
- # now process the tasks
- my_reg_jars ant-nodeps
- my_reg_jars ant-junit
- my_reg_jars ant-trax
- use antlr && my_reg_jars ant-antlr
- use bcel && my_reg_jars ant-apache-bcel
- use bsf && my_reg_jars ant-apache-bsf
- use log4j && my_reg_jars ant-apache-log4j
- use oro && my_reg_jars ant-apache-oro
- use regexp && my_reg_jars ant-apache-regexp
- use resolver && my_reg_jars ant-apache-resolver
- use commonslogging && my_reg_jars ant-commons-logging
- use commonsnet && my_reg_jars ant-commons-net
- use jai && my_reg_jars ant-jai
- use javamail && my_reg_jars ant-javamail
- use jdepend && my_reg_jars ant-jdepend
- use jmf && my_reg_jars ant-jmf
- use jsch && my_reg_jars ant-jsch
-
- use X && my_reg_jars ant-swing
-
- # point ANT_HOME to the one with all symlinked jars
- # ant-core startup script will ignore this one anyway
- echo "ANT_HOME=\"/usr/share/ant\"" > "${T}/21ant-tasks"
- doenvd "${T}/21ant-tasks" || die "failed to install env.d file"
-}
-
-pkg_postinst() {
- elog "You may now freely set the USE flags of this package without breaking"
- elog "building of Java packages, which DEPEND on the exact tasks they need."
-}
diff --git a/dev-java/ant-tasks/ant-tasks-1.7.0-r4.ebuild b/dev-java/ant-tasks/ant-tasks-1.7.0-r4.ebuild
index 1d9acc3c763c..fb6e2becea6c 100644
--- a/dev-java/ant-tasks/ant-tasks-1.7.0-r4.ebuild
+++ b/dev-java/ant-tasks/ant-tasks-1.7.0-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/ant-tasks/ant-tasks-1.7.0-r4.ebuild,v 1.4 2008/01/22 02:14:27 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/ant-tasks/ant-tasks-1.7.0-r4.ebuild,v 1.5 2008/03/03 00:55:03 wltjr Exp $
EAPI="1"
@@ -11,7 +11,7 @@ HOMEPAGE="http://ant.apache.org/"
LICENSE="Apache-2.0"
SLOT="0"
-KEYWORDS="~amd64 ~ia64 ppc ppc64 x86 ~x86-fbsd"
+KEYWORDS="amd64 ~ia64 ppc ppc64 x86 ~x86-fbsd"
IUSE="X +antlr +bcel +bsf +commonslogging +commonsnet jai +javamail +jdepend jmf +jsch
+log4j +oro +regexp +resolver"