summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Aniszczyk <zx@gentoo.org>2004-05-14 02:54:19 +0000
committerChris Aniszczyk <zx@gentoo.org>2004-05-14 02:54:19 +0000
commit0831ec2f35f5fbf52c1fb71737553e3d5cded61e (patch)
tree0ba48d9b688268be247da3794f62f8bf2e88b9aa /dev-java
parent~amd64 (Manifest recommit) (diff)
downloadgentoo-2-0831ec2f35f5fbf52c1fb71737553e3d5cded61e.tar.gz
gentoo-2-0831ec2f35f5fbf52c1fb71737553e3d5cded61e.tar.bz2
gentoo-2-0831ec2f35f5fbf52c1fb71737553e3d5cded61e.zip
Closes #50304
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/commons-cli/ChangeLog8
-rw-r--r--dev-java/commons-cli/Manifest10
-rw-r--r--dev-java/commons-cli/commons-cli-1.0-r4.ebuild44
-rw-r--r--dev-java/commons-cli/files/commons-cli-1.0-gentoo.diff112
-rw-r--r--dev-java/commons-cli/files/digest-commons-cli-1.0-r41
5 files changed, 166 insertions, 9 deletions
diff --git a/dev-java/commons-cli/ChangeLog b/dev-java/commons-cli/ChangeLog
index 885ac26286c3..c8fec53de5bc 100644
--- a/dev-java/commons-cli/ChangeLog
+++ b/dev-java/commons-cli/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-java/commons-cli
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-cli/ChangeLog,v 1.9 2004/05/13 18:28:21 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-cli/ChangeLog,v 1.10 2004/05/14 02:54:19 zx Exp $
+
+*commons-cli-1.0-r4 (13 May 2004)
+
+ 13 May 2004; Chris Aniszczyk <zx@gentoo.org>
+ files/commons-cli-1.0-gentoo.diff, +commons-cli-1.0-r4.ebuild:
+ Fixed ebuild so that we don't use jakarta-commons.eclass, Closes #50304
13 May 2004; Daniel Ahlberg <aliz@gentoo.org> commons-cli-1.0-r3.ebuild:
Added amd64 keyword.
diff --git a/dev-java/commons-cli/Manifest b/dev-java/commons-cli/Manifest
index c633d9910e08..db70f7001011 100644
--- a/dev-java/commons-cli/Manifest
+++ b/dev-java/commons-cli/Manifest
@@ -1,7 +1,9 @@
-MD5 df15e4590265543a168d1c33e3c66cd7 commons-cli-1.0-r3.ebuild 885
-MD5 29cf8f6204c3bc524fdd7c128aa5590b commons-cli-1.0-r2.ebuild 880
-MD5 21aa67fd22215bf40a246130a1abb264 ChangeLog 1798
+MD5 0b0e65bed440f5ccc12240830c35f5d3 ChangeLog 1797
+MD5 e095d0203df8e55e684f0a1c4d51498e commons-cli-1.0-r2.ebuild 879
+MD5 b924608fd3c4dd34cd4b92163106d141 commons-cli-1.0-r3.ebuild 884
MD5 a6ec7d7724fbd068ffb39b5be56134ed metadata.xml 157
-MD5 ff275165684fda9ed2a9d819df2399e1 files/commons-cli-1.0-gentoo.diff 538
+MD5 1078090bb0d961610841c47eaa909c9c commons-cli-1.0-r4.ebuild 1376
+MD5 9af836edb3657dd5241a10f36f961521 files/commons-cli-1.0-gentoo.diff 4039
MD5 8e1e3125e998bf49313b7e5ac3a5b1a0 files/digest-commons-cli-1.0-r2 62
MD5 8e1e3125e998bf49313b7e5ac3a5b1a0 files/digest-commons-cli-1.0-r3 62
+MD5 8e1e3125e998bf49313b7e5ac3a5b1a0 files/digest-commons-cli-1.0-r4 62
diff --git a/dev-java/commons-cli/commons-cli-1.0-r4.ebuild b/dev-java/commons-cli/commons-cli-1.0-r4.ebuild
new file mode 100644
index 000000000000..16eaa03ad6f8
--- /dev/null
+++ b/dev-java/commons-cli/commons-cli-1.0-r4.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-cli/commons-cli-1.0-r4.ebuild,v 1.1 2004/05/14 02:54:19 zx Exp $
+
+inherit java-pkg eutils
+
+DESCRIPTION="The CLI library provides a simple and easy to use API for working with the command line arguments and options."
+HOMEPAGE="http://jakarta.apache.org/commons/cli/"
+SRC_URI="mirror://apache/jakarta/commons/cli/source/cli-${PV}-src.tar.gz"
+DEPEND=">=virtual/jdk-1.3
+ >=dev-java/ant-1.4
+ >=dev-java/commons-logging-1.0
+ >=dev-java/junit-3.7
+ >=dev-java/commons-lang-1.0"
+RDEPEND=">=virtual/jdk-1.3"
+LICENSE="Apache-1.1"
+SLOT="1"
+KEYWORDS="x86 sparc ppc ~amd64"
+IUSE="doc jikes junit"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${PN}-${PV}-gentoo.diff || die "patch failed"
+ echo "commons-logging.jar=`java-config -p commons-logging`" >> build.properties
+ echo "commons-lang.jar=`java-config -p commons-lang`" >> build.properties
+ use junit && echo "junit.jar=`java-config -p junit`" >> build.properties
+}
+
+src_compile() {
+ local antflags="jar"
+ use jikes && antflags="${antflags} -Dbuild.compiler=jikes"
+ use doc && antflags="${antflags} javadoc"
+ use junit && antflags="${antflags} test"
+ ant ${antflags} || die "compilation failed"
+}
+
+src_install() {
+ mv ${S}/target/${P}.jar ${S}/target/${PN}.jar
+ java-pkg_dojar target/${PN}.jar
+ use doc && dohtml -r target/docs/
+ dodoc README.txt
+}
+
diff --git a/dev-java/commons-cli/files/commons-cli-1.0-gentoo.diff b/dev-java/commons-cli/files/commons-cli-1.0-gentoo.diff
index 88b6a8461f1d..9a916e774f8f 100644
--- a/dev-java/commons-cli/files/commons-cli-1.0-gentoo.diff
+++ b/dev-java/commons-cli/files/commons-cli-1.0-gentoo.diff
@@ -1,11 +1,115 @@
---- build.xml.orig 2003-03-10 16:54:25.000000000 -0600
-+++ build.xml 2003-03-10 16:54:13.000000000 -0600
-@@ -8,7 +8,7 @@
+--- build.xml 2002-11-06 00:10:24.000000000 -0500
++++ build.xml.patched 2004-05-13 22:46:32.819126973 -0400
+@@ -1,15 +1,23 @@
+ <?xml version="1.0" encoding="UTF-8"?>
+
+ <project default="jar" name="commons-cli" basedir=".">
+-
++
++ <property file="${basedir}/build.properties"/>
++
++ <path id="compile.classpath">
++ <pathelement location="${commons-logging.jar}"/>
++ <pathelement location="${commons-lang.jar}"/>
++ <pathelement location="${junit.jar}"/>
++ </path>
++
+ <property name="defaulttargetdir" value="target"></property>
+ <property name="classesdir" value="target/classes"></property>
+ <property name="testclassesdir" value="target/test-classes"></property>
<property name="testreportdir" value="target/test-reports"></property>
<property name="distdir" value="dist"></property>
<property name="javadocdir" value="target/docs/apidocs"></property>
- <property name="final.name" value="commons-cli-1.0-beta-2-dev"></property>
+-
+ <property name="final.name" value="commons-cli-1.0"></property>
-
++
<target name="init" description="o Initializes some properties">
+ <condition property="noget">
+@@ -17,21 +25,13 @@
+ </condition>
+ </target>
+
+- <target name="jar" description="o Create the jar" depends="get-deps">
++ <target name="jar" description="o Create the jar">
+
+ <mkdir dir="${classesdir}"></mkdir>
+
+- <javac destdir="${classesdir}" deprecation="true" debug="true" optimize="false" excludes="**/package.html">
+- <src>
+- <pathelement location="src/java"></pathelement>
+- </src>
+- <classpath>
+- <fileset dir="lib">
+- <include name="*.jar"></include>
+- </fileset>
+- </classpath>
++ <javac srcdir="src/java" destdir="${classesdir}" deprecation="true" debug="true" optimize="false" excludes="**/package.html">
++ <classpath refid="compile.classpath"/>
+ </javac>
+-
+
+ <jar jarfile="target/${final.name}.jar" excludes="**/package.html" basedir="${classesdir}"></jar>
+
+@@ -55,10 +55,8 @@
+ <sysproperty key="basedir" value="src/test"></sysproperty>
+ <formatter type="xml"></formatter>
+ <formatter usefile="true" type="plain"></formatter>
++ <classpath refid="compile.classpath"/>
+ <classpath>
+- <fileset dir="lib">
+- <include name="*.jar"></include>
+- </fileset>
+ <pathelement location="target/${final.name}.jar"></pathelement>
+ <pathelement path="${testclassesdir}"></pathelement>
+ </classpath>
+@@ -115,39 +113,17 @@
+ <property name="title" value="CLI 1.0-beta-2-dev API"></property>
+
+ <javadoc use="true" private="true" destdir="${javadocdir}" author="true" version="true" sourcepath="src/java" packagenames="org.apache.commons.cli.*">
++
++ <classpath refid="compile.classpath"/>
+ <classpath>
+- <fileset dir="lib">
+- <include name="*.jar"></include>
+- </fileset>
+ <pathelement location="target/${final.name}.jar"></pathelement>
+ </classpath>
+ </javadoc>
+
+ </target>
+
+- <target name="get-deps" unless="noget" depends="init">
+-
+- <mkdir dir="lib"></mkdir>
+-
+- <get dest="lib/commons-logging-1.0.jar" usetimestamp="true" ignoreerrors="true" src="http://www.ibiblio.org/maven/commons-logging/jars/commons-logging-1.0.jar"></get>
+- <get dest="lib/commons-lang-SNAPSHOT.jar" usetimestamp="true" ignoreerrors="true" src="http://www.ibiblio.org/maven/commons-lang/jars/commons-lang-SNAPSHOT.jar"></get>
+- <get dest="lib/junit-3.7.jar" usetimestamp="true" ignoreerrors="true" src="http://www.ibiblio.org/maven/junit/jars/junit-3.7.jar"></get>
+-
+- </target>
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+ <target name="install-maven">
+
+-
+-
+ <get dest="${user.home}/maven-install-latest.jar" usetimestamp="true" src="${maven.repo.remote}/maven/maven-install-latest.jar"></get>
+
+ <unjar dest="${maven.home}" src="${user.home}/maven-install-latest.jar"></unjar>
+@@ -155,4 +131,4 @@
+ </target>
+
+ </project>
+-
+\ No newline at end of file
++
diff --git a/dev-java/commons-cli/files/digest-commons-cli-1.0-r4 b/dev-java/commons-cli/files/digest-commons-cli-1.0-r4
new file mode 100644
index 000000000000..9fa950d9ac6b
--- /dev/null
+++ b/dev-java/commons-cli/files/digest-commons-cli-1.0-r4
@@ -0,0 +1 @@
+MD5 ba34d585046b1f17dacbb13b377f4255 cli-1.0-src.tar.gz 37046