summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdrian Almenar <strider@gentoo.org>2002-11-06 17:14:41 +0000
committerAdrian Almenar <strider@gentoo.org>2002-11-06 17:14:41 +0000
commit0244984cecbf7260091c1799ce7bd50c7f0ccfdf (patch)
treeef2fe2ec8f81fa38049f086335c13404cf9366ad /dev-java
parentinitial ebuild addition to portage tree (diff)
downloadgentoo-2-0244984cecbf7260091c1799ce7bd50c7f0ccfdf.tar.gz
gentoo-2-0244984cecbf7260091c1799ce7bd50c7f0ccfdf.tar.bz2
gentoo-2-0244984cecbf7260091c1799ce7bd50c7f0ccfdf.zip
New DEPEND, New DESCRIPTION
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/commons-logging/ChangeLog10
-rw-r--r--dev-java/commons-logging/commons-logging-1.0.2-r1.ebuild52
-rw-r--r--dev-java/commons-logging/files/digest-commons-logging-1.0.2-r11
3 files changed, 61 insertions, 2 deletions
diff --git a/dev-java/commons-logging/ChangeLog b/dev-java/commons-logging/ChangeLog
index 4711830c9734..01897ee40f8b 100644
--- a/dev-java/commons-logging/ChangeLog
+++ b/dev-java/commons-logging/ChangeLog
@@ -1,9 +1,15 @@
# ChangeLog for dev-java/commons-logging
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-logging/ChangeLog,v 1.1 2002/11/06 05:24:12 strider Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-logging/ChangeLog,v 1.2 2002/11/06 17:14:41 strider Exp $
+
+*commons-logging-1.0.2-r1 (06 Nov 2002)
+
+ 06 Nov 2002; Adrian Almenar <strider@gentoo.org> commons-logging-1.0.2-r1.ebuild files/digest-commons-logging-1.0.2-r1:
+ Changed DEPEND, this ebuild now depends on log4j and jdk-1.4, cause it
+ abstract all logging api located on both products. Changed DESCRIPTION for a
+ better understanding of what this is.
*commons-logging-1.0.2 (06 Nov 2002)
06 Nov 2002; Adrian Almenar <strider@gentoo.org> ChangeLog commons-logging-1.0.2.ebuild files/digest-commons-logging-1.0.2 :
Initial import.
-
diff --git a/dev-java/commons-logging/commons-logging-1.0.2-r1.ebuild b/dev-java/commons-logging/commons-logging-1.0.2-r1.ebuild
new file mode 100644
index 000000000000..e4c4317af73d
--- /dev/null
+++ b/dev-java/commons-logging/commons-logging-1.0.2-r1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-logging/commons-logging-1.0.2-r1.ebuild,v 1.1 2002/11/06 17:14:41 strider Exp $
+
+S="${WORKDIR}/${P}-src"
+DESCRIPTION="The Jakarta-Commons Logging package is an ultra-thin bridge between different logging libraries."
+HOMEPAGE="http://jakarta.apache.org/commons/logging.html"
+SRC_URI="http://jakarta.apache.org/builds/jakarta-commons/release/${PN}/v${PV}/${P}-src.tar.gz"
+DEPEND=">=virtual/jdk-1.4
+ >=dev-java/log4j-1.2.5
+ >=dev-java/ant-1.4"
+RDEPEND=">=virtual/jre-1.4"
+LICENSE="Apache-1.1"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="jikes junit"
+
+src_compile() {
+ local myc
+
+ cd logging
+ cp LICENSE.txt ../LICENSE
+
+ if [ -n "`use jikes`" ] ; then
+ myc="${myc} -Dbuild.compiler=jikes"
+ fi
+
+ if [ -n "`use junit`" ] ; then
+ echo "junit.jar=`java-config --classpath=junit`" | sed s/:.*// > build.properties
+ ANT_OPTS=${myc} ant test || die "Testing Classes Failed"
+ fi
+
+ echo "log4j.jar=`java-config --classpath=log4j`" >> build.properties
+
+ ANT_OPTS=${myc} ant dist || die "Compilation failed"
+}
+
+src_install () {
+ cd logging
+ dojar dist/commons-logging-api.jar || die "Unable to install"
+ dojar dist/commons-logging.jar || die "Unable to install"
+ dodoc RELEASE-NOTES.txt
+ dohtml PROPOSAL.html STATUS.html usersguide.html
+ dohtml -r dist/docs/*
+}
+
+pkg_postinst() {
+ einfo "**************** Documentation can be found at ******************\n
+ WEB: ${HOMEPAGE}\n
+ LOCAL: /usr/share/doc/${PF}\n
+ *****************************************************************"
+}
diff --git a/dev-java/commons-logging/files/digest-commons-logging-1.0.2-r1 b/dev-java/commons-logging/files/digest-commons-logging-1.0.2-r1
new file mode 100644
index 000000000000..608ab555e60d
--- /dev/null
+++ b/dev-java/commons-logging/files/digest-commons-logging-1.0.2-r1
@@ -0,0 +1 @@
+MD5 78bfaac25906a54b925bcc285872c9c9 commons-logging-1.0.2-src.tar.gz 33550