summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Matthijs <axxo@gentoo.org>2005-07-15 10:39:11 +0000
committerThomas Matthijs <axxo@gentoo.org>2005-07-15 10:39:11 +0000
commitab7d704e5d4290a006608a088b9db785b21d7292 (patch)
tree162da7742a67dfaa903c61082b33f999ead2b45f /dev-java/xmlc
parentrestricted maketest (#91515) and moved to net-dns from net-misc (#80805) (diff)
downloadgentoo-2-ab7d704e5d4290a006608a088b9db785b21d7292.tar.gz
gentoo-2-ab7d704e5d4290a006608a088b9db785b21d7292.tar.bz2
gentoo-2-ab7d704e5d4290a006608a088b9db785b21d7292.zip
Dep fixes
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'dev-java/xmlc')
-rw-r--r--dev-java/xmlc/xmlc-2.2.5.ebuild12
1 files changed, 4 insertions, 8 deletions
diff --git a/dev-java/xmlc/xmlc-2.2.5.ebuild b/dev-java/xmlc/xmlc-2.2.5.ebuild
index cc403ffc3b83..99b582ac69ce 100644
--- a/dev-java/xmlc/xmlc-2.2.5.ebuild
+++ b/dev-java/xmlc/xmlc-2.2.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/xmlc/xmlc-2.2.5.ebuild,v 1.1 2005/04/16 18:44:19 zx Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/xmlc/xmlc-2.2.5.ebuild,v 1.2 2005/07/15 10:39:11 axxo Exp $
inherit java-pkg
@@ -8,9 +8,10 @@ DESCRIPTION="Enhydra XMLC is the presentation technology that supports the needs
HOMEPAGE="http://xmlc.objectweb.org/"
SRC_URI="http://download.forge.objectweb.org/${PN}/${PN}-src-${PV}.zip
http://download.us.forge.objectweb.org/${PN}/${PN}-src-${PV}.zip"
-DEPEND=">=dev-java/ant-core-1.4
+DEPEND=">=virtual/jdk-1.3
+ >=dev-java/ant-core-1.4
jikes? ( >=dev-java/jikes-1.21 )"
-RDEPEND=">=virtual/jdk-1.3"
+RDEPEND=">=virtual/jre-1.3"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="x86 ppc sparc amd64"
@@ -18,11 +19,6 @@ IUSE="doc jikes"
S="${WORKDIR}/${PN}-src-${PV}/"
-src_unpack() {
- unpack ${A}
- cd ${S}
-}
-
src_compile() {
local antflags="all-libs"
use jikes && antflags="${antflags} -Dbuild.compiler=jikes"