summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVlastimil Babka <caster@gentoo.org>2007-02-12 00:53:52 +0000
committerVlastimil Babka <caster@gentoo.org>2007-02-12 00:53:52 +0000
commiteba8cccb188b2f5a5ded7fa7f4b4f00a92d0eee3 (patch)
treedd5815345b6bd8446d17c417d2e6f9360d18710a /dev-java/xjavac
parentMigrate to split-ant wrt xjavac, and cleanup. (diff)
downloadgentoo-2-eba8cccb188b2f5a5ded7fa7f4b4f00a92d0eee3.tar.gz
gentoo-2-eba8cccb188b2f5a5ded7fa7f4b4f00a92d0eee3.tar.bz2
gentoo-2-eba8cccb188b2f5a5ded7fa7f4b4f00a92d0eee3.zip
Revbump that stops symlinking the jar into ant-core/lib, for split-ant aware revisions of xerces.
(Portage version: 2.1.2-r9)
Diffstat (limited to 'dev-java/xjavac')
-rw-r--r--dev-java/xjavac/ChangeLog9
-rw-r--r--dev-java/xjavac/files/digest-xjavac-20041208-r53
-rw-r--r--dev-java/xjavac/xjavac-20041208-r4.ebuild4
-rw-r--r--dev-java/xjavac/xjavac-20041208-r5.ebuild32
4 files changed, 45 insertions, 3 deletions
diff --git a/dev-java/xjavac/ChangeLog b/dev-java/xjavac/ChangeLog
index c8df78bb9d9a..2ddcde95993b 100644
--- a/dev-java/xjavac/ChangeLog
+++ b/dev-java/xjavac/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-java/xjavac
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/xjavac/ChangeLog,v 1.19 2007/01/27 22:25:02 betelgeuse Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/xjavac/ChangeLog,v 1.20 2007/02/12 00:53:52 caster Exp $
+
+*xjavac-20041208-r5 (12 Feb 2007)
+
+ 12 Feb 2007; Vlastimil Babka <caster@gentoo.org>
+ xjavac-20041208-r4.ebuild, +xjavac-20041208-r5.ebuild:
+ Revbump that stops symlinking the jar into ant-core/lib, for split-ant aware
+ revisions of xerces.
27 Jan 2007; Petteri Räty <betelgeuse@gentoo.org>
-xjavac-20041208-r1.ebuild, -xjavac-20041208-r2.ebuild,
diff --git a/dev-java/xjavac/files/digest-xjavac-20041208-r5 b/dev-java/xjavac/files/digest-xjavac-20041208-r5
new file mode 100644
index 000000000000..b7075055b4c2
--- /dev/null
+++ b/dev-java/xjavac/files/digest-xjavac-20041208-r5
@@ -0,0 +1,3 @@
+MD5 47e450883782e191e0e91c31a6dc2caf xjavac-20041208.tar.gz 1971
+RMD160 bdee4c165275dedcfaf42fd38962a85b668d259e xjavac-20041208.tar.gz 1971
+SHA256 ae54e392bfe3ff5d33bc58a7e122bdae863531e235c2a553dee024e045694781 xjavac-20041208.tar.gz 1971
diff --git a/dev-java/xjavac/xjavac-20041208-r4.ebuild b/dev-java/xjavac/xjavac-20041208-r4.ebuild
index c870873ae089..77b813c8bcda 100644
--- a/dev-java/xjavac/xjavac-20041208-r4.ebuild
+++ b/dev-java/xjavac/xjavac-20041208-r4.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/xjavac/xjavac-20041208-r4.ebuild,v 1.6 2007/01/05 21:46:37 beandog Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/xjavac/xjavac-20041208-r4.ebuild,v 1.7 2007/02/12 00:53:52 caster Exp $
-inherit java-pkg-2
+inherit java-pkg-2 java-ant-2
DESCRIPTION="The implementation of the javac compiler for IBM JDK 1.4 (needed for xerces-2)"
SRC_URI="mirror://gentoo/${P}.tar.gz"
diff --git a/dev-java/xjavac/xjavac-20041208-r5.ebuild b/dev-java/xjavac/xjavac-20041208-r5.ebuild
new file mode 100644
index 000000000000..794a6004d6ac
--- /dev/null
+++ b/dev-java/xjavac/xjavac-20041208-r5.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/xjavac/xjavac-20041208-r5.ebuild,v 1.1 2007/02/12 00:53:52 caster Exp $
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="The implementation of the javac compiler for IBM JDK 1.4 (needed for xerces-2)"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+HOMEPAGE="http://cvs.apache.org/viewcvs.cgi/xml-xerces/java/tools/src/XJavac.java"
+LICENSE="Apache-2.0"
+SLOT="1"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
+DEPEND=">=virtual/jdk-1.4
+ >=dev-java/ant-core-1.4"
+RDEPEND=">=virtual/jdk-1.4"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ cp ${FILESDIR}/${P}-build.xml ./build.xml || die" failed to cp build.xml"
+ epatch "${FILESDIR}/${PN}-ibm-1_5.patch"
+ epatch "${FILESDIR}/${PN}-more-vendors.patch"
+}
+
+src_compile() {
+ eant jar -Dclasspath=$(java-pkg_getjars ant-core)
+}
+
+src_install() {
+ java-pkg_dojar dist/${PN}.jar
+}