summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Matthijs <axxo@gentoo.org>2005-05-18 12:11:59 +0000
committerThomas Matthijs <axxo@gentoo.org>2005-05-18 12:11:59 +0000
commitebfef20ea5c95b76e1245dc6cb96fdce34e53968 (patch)
treed73fc17330df882ea490cd797fb9497b1fe655f9 /dev-java/velocity
parentCleaning up (diff)
downloadgentoo-2-ebfef20ea5c95b76e1245dc6cb96fdce34e53968.tar.gz
gentoo-2-ebfef20ea5c95b76e1245dc6cb96fdce34e53968.tar.bz2
gentoo-2-ebfef20ea5c95b76e1245dc6cb96fdce34e53968.zip
fixes 92884, versioned jar, thanks too Josh Nichols <nichoj@alum.rpi.edu>
Diffstat (limited to 'dev-java/velocity')
-rw-r--r--dev-java/velocity/ChangeLog7
-rw-r--r--dev-java/velocity/Manifest12
-rw-r--r--dev-java/velocity/files/digest-velocity-1.4-r21
-rw-r--r--dev-java/velocity/velocity-1.4-r2.ebuild48
4 files changed, 57 insertions, 11 deletions
diff --git a/dev-java/velocity/ChangeLog b/dev-java/velocity/ChangeLog
index 7a4480539f92..5209fa8e19c1 100644
--- a/dev-java/velocity/ChangeLog
+++ b/dev-java/velocity/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-java/velocity
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/velocity/ChangeLog,v 1.16 2005/04/02 21:51:56 luckyduck Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/velocity/ChangeLog,v 1.17 2005/05/18 12:11:59 axxo Exp $
+
+*velocity-1.4-r2 (18 May 2005)
+
+ 18 May 2005; Thomas Matthijs <axxo@gentoo.org> +velocity-1.4-r2.ebuild:
+ fixes 92884, versioned jar, thanks too Josh Nichols <nichoj@alum.rpi.edu>
02 Apr 2005; Jan Brinkmann <luckyduck@gentoo.org> velocity-1.4-r1.ebuild,
-velocity-1.4.ebuild:
diff --git a/dev-java/velocity/Manifest b/dev-java/velocity/Manifest
index f1bbeeb4e01e..e5743528f277 100644
--- a/dev-java/velocity/Manifest
+++ b/dev-java/velocity/Manifest
@@ -1,14 +1,6 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
+MD5 dabf70a15d379b9a9b2197db930c33ae velocity-1.4-r2.ebuild 1389
MD5 dabf70a15d379b9a9b2197db930c33ae velocity-1.4-r1.ebuild 1389
MD5 8bc8e79286f62f477a8099691aa8fcc3 ChangeLog 2272
MD5 a6ec7d7724fbd068ffb39b5be56134ed metadata.xml 157
MD5 ebc2b845ee1e201a404b4eceb168952a files/digest-velocity-1.4-r1 65
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.0 (GNU/Linux)
-
-iD8DBQFCTxQD06ebR+OMO78RArjCAKCMDyE28xZLjpuCQ3RTEswcJjjvWACfUiM1
-Pq0sdhp1wq7QNNzYDupkCWA=
-=yUDq
------END PGP SIGNATURE-----
+MD5 ebc2b845ee1e201a404b4eceb168952a files/digest-velocity-1.4-r2 65
diff --git a/dev-java/velocity/files/digest-velocity-1.4-r2 b/dev-java/velocity/files/digest-velocity-1.4-r2
new file mode 100644
index 000000000000..ccc2e9c9c5dd
--- /dev/null
+++ b/dev-java/velocity/files/digest-velocity-1.4-r2
@@ -0,0 +1 @@
+MD5 f280fee7ddb5eac5b354f6dea39a2f51 velocity-1.4.tar.gz 4566056
diff --git a/dev-java/velocity/velocity-1.4-r2.ebuild b/dev-java/velocity/velocity-1.4-r2.ebuild
new file mode 100644
index 000000000000..4e0e405f02cc
--- /dev/null
+++ b/dev-java/velocity/velocity-1.4-r2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/velocity/velocity-1.4-r2.ebuild,v 1.1 2005/05/18 12:11:59 axxo Exp $
+
+inherit java-pkg
+
+DESCRIPTION="A Java-based template engine that allows easy creation/rendering of documents that format and present data."
+HOMEPAGE="http://jakarta.apache.org/velocity/"
+SRC_URI="mirror://apache/jakarta/velocity/binaries/velocity-${PV}/velocity-${PV}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="doc j2ee jikes junit"
+
+DEPEND=">=virtual/jdk-1.3.1"
+RDEPEND=">=virtual/jdk-1.3.1
+ >=dev-java/ant-1.5.1
+ >=dev-java/avalon-logkit-bin-1.2
+ =dev-java/jakarta-oro-2.0*
+ j2ee? ( =dev-java/sun-j2ee-1.3.1* )
+ jikes? ( >=dev-java/jikes-1.17 )"
+
+src_compile () {
+ cd ${S}/build
+ local antflags
+ use jikes && antflags="${antflags} -Dbuild.compiler=jikes"
+ use junit && antflags="${antflags} test"
+ use doc && antflags="${antflags} javadocs"
+ if use j2ee ; then
+ cp /opt/sun-j2ee-1.3.1/lib/j2ee.jar ${S}/build/lib
+ ant ${antflags} jar-J2EE || die "Java compile failed."
+ else
+ ant ${antflags} jar || die "Java compile failed"
+ fi
+}
+
+
+src_install () {
+ cd ${S}
+ if use j2ee ; then
+ java-pkg_newjar bin/${PN}-J2EE-${PV}.jar ${PN}-J2EE.jar
+ else
+ java-pkg_newjar bin/${PN}-${PV}.jar ${PN}.jar
+ fi
+ dodoc LICENSE NOTICE README.txt
+ use doc && java-pkg_dohtml -r docs/*
+}