summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2012-06-14 16:13:38 +0000
committerMiroslav Šulc <fordfrog@gentoo.org>2012-06-14 16:13:38 +0000
commitc939022342ee481ceaa94d34de4e71cbb534e1ad (patch)
treea7073b92fa36823ae777e7280848a46be08e9172 /dev-java/tomcat-native
parentdev-java/tomcat-native: removed old ebuilds (diff)
downloadgentoo-2-c939022342ee481ceaa94d34de4e71cbb534e1ad.tar.gz
gentoo-2-c939022342ee481ceaa94d34de4e71cbb534e1ad.tar.bz2
gentoo-2-c939022342ee481ceaa94d34de4e71cbb534e1ad.zip
dev-java/tomcat-native: version bump
(Portage version: 2.1.10.65/cvs/Linux x86_64)
Diffstat (limited to 'dev-java/tomcat-native')
-rw-r--r--dev-java/tomcat-native/ChangeLog8
-rw-r--r--dev-java/tomcat-native/tomcat-native-1.1.24.ebuild47
2 files changed, 54 insertions, 1 deletions
diff --git a/dev-java/tomcat-native/ChangeLog b/dev-java/tomcat-native/ChangeLog
index 8fbfcd6c4c60..a6e481c1fe1b 100644
--- a/dev-java/tomcat-native/ChangeLog
+++ b/dev-java/tomcat-native/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-java/tomcat-native
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/tomcat-native/ChangeLog,v 1.36 2012/06/14 16:01:29 fordfrog Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/tomcat-native/ChangeLog,v 1.37 2012/06/14 16:13:38 fordfrog Exp $
+
+*tomcat-native-1.1.24 (14 Jun 2012)
+
+ 14 Jun 2012; Miroslav Šulc <fordfrog@gentoo.org>
+ +tomcat-native-1.1.24.ebuild:
+ Version bump
14 Jun 2012; Miroslav Šulc <fordfrog@gentoo.org>
-tomcat-native-1.1.15.ebuild, -tomcat-native-1.1.16.ebuild,
diff --git a/dev-java/tomcat-native/tomcat-native-1.1.24.ebuild b/dev-java/tomcat-native/tomcat-native-1.1.24.ebuild
new file mode 100644
index 000000000000..e46bef4346bf
--- /dev/null
+++ b/dev-java/tomcat-native/tomcat-native-1.1.24.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/tomcat-native/tomcat-native-1.1.24.ebuild,v 1.1 2012/06/14 16:13:38 fordfrog Exp $
+
+EAPI="2"
+
+inherit base eutils java-pkg-2
+
+DESCRIPTION="Native APR library for Tomcat"
+
+SLOT="0"
+SRC_URI="mirror://apache/tomcat/tomcat-connectors/native/${PV}/source/${P}-src.tar.gz"
+HOMEPAGE="http://tomcat.apache.org/"
+KEYWORDS="~amd64 ~x86"
+LICENSE="Apache-2.0"
+IUSE=""
+
+RDEPEND="=dev-libs/apr-1*
+ dev-libs/openssl
+ >=virtual/jre-1.5"
+
+DEPEND=">=virtual/jdk-1.5
+ ${RDEPEND}"
+
+S=${WORKDIR}/${P}-src/jni/native
+
+src_configure(){
+ econf --with-apr=/usr/bin/apr-1-config \
+ --with-ssl=/usr || die "Could not configure native sources"
+}
+
+src_compile() {
+ base_src_compile
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Could not install libtcnative-1.so"
+}
+
+pkg_postinst() {
+ elog
+ elog " APR should be available with Tomcat, for more information"
+ elog " please see http://tomcat.apache.org/tomcat-6.0-doc/apr.html"
+ elog
+ elog " Please report any bugs to http://bugs.gentoo.org/"
+ elog
+}