summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2013-10-15 14:31:45 +0000
committerMiroslav Šulc <fordfrog@gentoo.org>2013-10-15 14:31:45 +0000
commit681dcee8f62c65c3b3780563145e1bcc6e557ed5 (patch)
tree1bd300a609197f592db03323e365b4b3b11db434 /dev-java/tomcat-native
parentMake the build process verbose (diff)
downloadgentoo-2-681dcee8f62c65c3b3780563145e1bcc6e557ed5.tar.gz
gentoo-2-681dcee8f62c65c3b3780563145e1bcc6e557ed5.tar.bz2
gentoo-2-681dcee8f62c65c3b3780563145e1bcc6e557ed5.zip
dev-java/tomcat-native: version bump
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key CFE47E2F)
Diffstat (limited to 'dev-java/tomcat-native')
-rw-r--r--dev-java/tomcat-native/ChangeLog8
-rw-r--r--dev-java/tomcat-native/tomcat-native-1.1.29.ebuild47
2 files changed, 54 insertions, 1 deletions
diff --git a/dev-java/tomcat-native/ChangeLog b/dev-java/tomcat-native/ChangeLog
index ba3811c7a9f1..173799182cb5 100644
--- a/dev-java/tomcat-native/ChangeLog
+++ b/dev-java/tomcat-native/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-java/tomcat-native
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/tomcat-native/ChangeLog,v 1.43 2013/09/17 17:28:23 fordfrog Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/tomcat-native/ChangeLog,v 1.44 2013/10/15 14:31:45 fordfrog Exp $
+
+*tomcat-native-1.1.29 (15 Oct 2013)
+
+ 15 Oct 2013; Miroslav Šulc <fordfrog@gentoo.org>
+ +tomcat-native-1.1.29.ebuild:
+ version bump
*tomcat-native-1.1.28 (17 Sep 2013)
diff --git a/dev-java/tomcat-native/tomcat-native-1.1.29.ebuild b/dev-java/tomcat-native/tomcat-native-1.1.29.ebuild
new file mode 100644
index 000000000000..648db408f271
--- /dev/null
+++ b/dev-java/tomcat-native/tomcat-native-1.1.29.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/tomcat-native/tomcat-native-1.1.29.ebuild,v 1.1 2013/10/15 14:31:45 fordfrog Exp $
+
+EAPI="5"
+
+inherit base eutils java-pkg-2
+
+DESCRIPTION="Native APR library for Tomcat"
+
+SLOT="0"
+SRC_URI="mirror://apache/tomcat/tomcat-connectors/native/${PV}/source/${P}-src.tar.gz"
+HOMEPAGE="http://tomcat.apache.org/"
+KEYWORDS="~amd64 ~x86"
+LICENSE="Apache-2.0"
+IUSE=""
+
+RDEPEND="=dev-libs/apr-1*
+ dev-libs/openssl
+ >=virtual/jre-1.5"
+
+DEPEND=">=virtual/jdk-1.5
+ ${RDEPEND}"
+
+S=${WORKDIR}/${P}-src/jni/native
+
+src_configure(){
+ econf --with-apr=/usr/bin/apr-1-config \
+ --with-ssl=/usr || die "Could not configure native sources"
+}
+
+src_compile() {
+ base_src_compile
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Could not install libtcnative-1.so"
+}
+
+pkg_postinst() {
+ elog
+ elog " APR should be available with Tomcat, for more information"
+ elog " please see http://tomcat.apache.org/tomcat-6.0-doc/apr.html"
+ elog
+ elog " Please report any bugs to http://bugs.gentoo.org/"
+ elog
+}