summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2015-03-28 15:37:56 +0000
committerMiroslav Šulc <fordfrog@gentoo.org>2015-03-28 15:37:56 +0000
commit078f3a3809db3e9ee964b57044868bd76357f9f9 (patch)
treecfecafbc1c294a88885de809d74b21f502589939 /dev-java/tomcat-native
parentversion bump (diff)
downloadgentoo-2-078f3a3809db3e9ee964b57044868bd76357f9f9.tar.gz
gentoo-2-078f3a3809db3e9ee964b57044868bd76357f9f9.tar.bz2
gentoo-2-078f3a3809db3e9ee964b57044868bd76357f9f9.zip
dev-java/tomcat-native: version bump
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key CFE47E2F)
Diffstat (limited to 'dev-java/tomcat-native')
-rw-r--r--dev-java/tomcat-native/ChangeLog8
-rw-r--r--dev-java/tomcat-native/tomcat-native-1.1.33.ebuild47
2 files changed, 54 insertions, 1 deletions
diff --git a/dev-java/tomcat-native/ChangeLog b/dev-java/tomcat-native/ChangeLog
index 3394e1197abf..0e000e0b7220 100644
--- a/dev-java/tomcat-native/ChangeLog
+++ b/dev-java/tomcat-native/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-java/tomcat-native
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/tomcat-native/ChangeLog,v 1.52 2015/02/25 15:34:47 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/tomcat-native/ChangeLog,v 1.53 2015/03/28 15:37:56 fordfrog Exp $
+
+*tomcat-native-1.1.33 (28 Mar 2015)
+
+ 28 Mar 2015; Miroslav Šulc <fordfrog@gentoo.org>
+ +tomcat-native-1.1.33.ebuild:
+ version bump
25 Feb 2015; Agostino Sarubbo <ago@gentoo.org> tomcat-native-1.1.32.ebuild:
Stable for x86, wrt bug #535096
diff --git a/dev-java/tomcat-native/tomcat-native-1.1.33.ebuild b/dev-java/tomcat-native/tomcat-native-1.1.33.ebuild
new file mode 100644
index 000000000000..d67d5febf29f
--- /dev/null
+++ b/dev-java/tomcat-native/tomcat-native-1.1.33.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/tomcat-native/tomcat-native-1.1.33.ebuild,v 1.1 2015/03/28 15:37:56 fordfrog Exp $
+
+EAPI="5"
+
+inherit base eutils java-pkg-2
+
+DESCRIPTION="Native APR library for Tomcat"
+
+SLOT="0"
+SRC_URI="mirror://apache/tomcat/tomcat-connectors/native/${PV}/source/${P}-src.tar.gz"
+HOMEPAGE="http://tomcat.apache.org/"
+KEYWORDS="~amd64 ~x86"
+LICENSE="Apache-2.0"
+IUSE=""
+
+RDEPEND="=dev-libs/apr-1*
+ dev-libs/openssl:=
+ >=virtual/jre-1.5:*"
+
+DEPEND=">=virtual/jdk-1.5:*
+ ${RDEPEND}"
+
+S=${WORKDIR}/${P}-src/jni/native
+
+src_configure(){
+ econf --with-apr=/usr/bin/apr-1-config \
+ --with-ssl=/usr || die "Could not configure native sources"
+}
+
+src_compile() {
+ base_src_compile
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Could not install libtcnative-1.so"
+}
+
+pkg_postinst() {
+ elog
+ elog " APR should be available with Tomcat, for more information"
+ elog " please see http://tomcat.apache.org/tomcat-6.0-doc/apr.html"
+ elog
+ elog " Please report any bugs to http://bugs.gentoo.org/"
+ elog
+}