summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSaleem Abdulrasool <compnerd@gentoo.org>2005-10-23 04:29:00 +0000
committerSaleem Abdulrasool <compnerd@gentoo.org>2005-10-23 04:29:00 +0000
commit82b6a8b5a5f01a6078eb4d1c7d55fa3db6511217 (patch)
treedfb5b97136842c125609ae46f8cd7a7b3cce24e0 /dev-java/swt
parentStable on x86; bug #106448 (diff)
downloadgentoo-2-82b6a8b5a5f01a6078eb4d1c7d55fa3db6511217.tar.gz
gentoo-2-82b6a8b5a5f01a6078eb4d1c7d55fa3db6511217.tar.bz2
gentoo-2-82b6a8b5a5f01a6078eb4d1c7d55fa3db6511217.zip
Fixing up deps; Cleaning the ebuild a bit; Resolves bug #105587
(Portage version: 2.0.53_rc6)
Diffstat (limited to 'dev-java/swt')
-rw-r--r--dev-java/swt/ChangeLog5
-rw-r--r--dev-java/swt/Manifest2
-rw-r--r--dev-java/swt/swt-3.2_pre1.ebuild24
3 files changed, 13 insertions, 18 deletions
diff --git a/dev-java/swt/ChangeLog b/dev-java/swt/ChangeLog
index 6d8b52efa4e6..c3dc955838e5 100644
--- a/dev-java/swt/ChangeLog
+++ b/dev-java/swt/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-java/swt
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/swt/ChangeLog,v 1.27 2005/10/22 17:11:03 compnerd Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/swt/ChangeLog,v 1.28 2005/10/23 04:29:00 compnerd Exp $
+
+ 24 Oct 2005; Saleem Abdulrasool <compnerd@gentoo.org> swt-3.2_pre1.ebuild:
+ Updating CAIRO depend. Minor ebuild cleanup.
23 Oct 2005; Saleem Abdulrasool <compnerd@gentoo.org> swt-3.2_pre1.ebuild:
Fixing dependency on GTK+ Resolves bug #109267
diff --git a/dev-java/swt/Manifest b/dev-java/swt/Manifest
index 4c619737bb6f..bfb56fcde5df 100644
--- a/dev-java/swt/Manifest
+++ b/dev-java/swt/Manifest
@@ -7,4 +7,4 @@ MD5 b246c6ca2f33a241ab92d5a8c74da665 files/swt-cairo-0.9.2-amd64.patch 8325
MD5 86a056e193ce8f351e3b12d7f5751861 files/swt-cairo-0.9.2.patch 8692
MD5 5ea14ff7e96eeb0ce1c8a161b7f1ce3f metadata.xml 541
MD5 f387ebc54db186eb59aeb42a256517eb swt-3.1-r1.ebuild 5319
-MD5 e80d9ebeae200e70f49b21dfc850c1fb swt-3.2_pre1.ebuild 5499
+MD5 20ca3bf8635e617b6030c509a9e57323 swt-3.2_pre1.ebuild 5166
diff --git a/dev-java/swt/swt-3.2_pre1.ebuild b/dev-java/swt/swt-3.2_pre1.ebuild
index e7bb3531a203..fbac1ef38410 100644
--- a/dev-java/swt/swt-3.2_pre1.ebuild
+++ b/dev-java/swt/swt-3.2_pre1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/swt/swt-3.2_pre1.ebuild,v 1.3 2005/10/22 17:11:03 compnerd Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/swt/swt-3.2_pre1.ebuild,v 1.4 2005/10/23 04:29:00 compnerd Exp $
inherit eutils java-pkg
@@ -25,7 +25,7 @@ RDEPEND=">=virtual/jre-1.4
!firefox? ( >=www-client/mozilla-1.4 )
)
gnome? ( =gnome-base/gnome-vfs-2* =gnome-base/libgnomeui-2* )
- cairo? ( >=x11-libs/cairo-0.3.0 )"
+ cairo? ( >=x11-libs/cairo-1.0.2 )"
DEPEND=">=virtual/jdk-1.4
${RDEPEND}
dev-util/pkgconfig
@@ -49,13 +49,7 @@ pkg_setup() {
src_unpack() {
# Extract based on architecture
- if [[ ${ARCH} == 'amd64' ]] ; then
- unpack swt-${MY_VERSION}-gtk-linux-x86_64.zip || die "Unable to unpack sources"
- elif [[ ${ARCH} == 'ppc' ]] ; then
- unpack swt-${MY_VERSION}-gtk-linux-ppc.zip || die "Unable to unpack sources"
- else
- unpack swt-${MY_VERSION}-gtk-linux-x86.zip || die "Unable to unpack sources"
- fi
+ unpack ${A} || die "Unable to unpack sources"
# Clean up the directory structure
for f in $(ls); do
@@ -73,12 +67,10 @@ src_unpack() {
rm -f .classpath .project
# CARIO 0.9.2 API Patch
- if has_version '>=x11-libs/cairo-0.9.2' ; then
- if [[ ${ARCH} == 'amd64' ]] ; then
- epatch ${FILESDIR}/swt-cairo-0.9.2-amd64.patch
- else
- epatch ${FILESDIR}/swt-cairo-0.9.2.patch
- fi
+ if [[ ${ARCH} == 'amd64' ]] ; then
+ epatch ${FILESDIR}/swt-cairo-0.9.2-amd64.patch
+ else
+ epatch ${FILESDIR}/swt-cairo-0.9.2.patch
fi
# Replace the build.xml to allow compilation without Eclipse tasks
@@ -174,7 +166,7 @@ pkg_postinst() {
ewarn
ewarn "CAIRO Support is experimental! We are not responsible if"
ewarn "enabling support for CAIRO corrupts your Gentoo install,"
- ewarn "if it blows up your computer, or if it becoming sentient"
+ ewarn "if it blows up your computer, or if it becomes sentient"
ewarn "and chases you down the street yelling random binary!"
ewarn
ebeep 5