summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVlastimil Babka <caster@gentoo.org>2010-06-30 21:12:21 +0000
committerVlastimil Babka <caster@gentoo.org>2010-06-30 21:12:21 +0000
commit1b42b8ecc4053044bcaf5327aad841c4785d8f3b (patch)
tree738ddff270dd41e52e2e6e3601bab95fcb949a3c /dev-java/sun-jre-bin
parentRemoval to java-overlay due to 1.5 jdk dependency. (diff)
downloadgentoo-2-1b42b8ecc4053044bcaf5327aad841c4785d8f3b.tar.gz
gentoo-2-1b42b8ecc4053044bcaf5327aad841c4785d8f3b.tar.bz2
gentoo-2-1b42b8ecc4053044bcaf5327aad841c4785d8f3b.zip
Removal due to EOL and security #306579.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-java/sun-jre-bin')
-rw-r--r--dev-java/sun-jre-bin/ChangeLog7
-rw-r--r--dev-java/sun-jre-bin/files/construct.sh282
-rw-r--r--dev-java/sun-jre-bin/files/sun-jre-bin-1.5.env16
-rw-r--r--dev-java/sun-jre-bin/sun-jre-bin-1.5.0.22.ebuild114
-rw-r--r--dev-java/sun-jre-bin/sun-jre-bin-1.6.0.19.ebuild149
5 files changed, 6 insertions, 562 deletions
diff --git a/dev-java/sun-jre-bin/ChangeLog b/dev-java/sun-jre-bin/ChangeLog
index dc683517882f..8e134e4a0987 100644
--- a/dev-java/sun-jre-bin/ChangeLog
+++ b/dev-java/sun-jre-bin/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-java/sun-jre-bin
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jre-bin/ChangeLog,v 1.176 2010/04/26 19:09:20 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jre-bin/ChangeLog,v 1.177 2010/06/30 21:12:21 caster Exp $
+
+ 30 Jun 2010; Vlastimil Babka <caster@gentoo.org>
+ -sun-jre-bin-1.5.0.22.ebuild, -files/sun-jre-bin-1.5.env,
+ -sun-jre-bin-1.6.0.19.ebuild, -files/construct.sh:
+ Removal due to EOL and security #306579.
26 Apr 2010; Markus Meier <maekke@gentoo.org> sun-jre-bin-1.6.0.20.ebuild:
amd64 stable, bug #314531
diff --git a/dev-java/sun-jre-bin/files/construct.sh b/dev-java/sun-jre-bin/files/construct.sh
deleted file mode 100644
index aef91c267280..000000000000
--- a/dev-java/sun-jre-bin/files/construct.sh
+++ /dev/null
@@ -1,282 +0,0 @@
-#!/bin/bash
-# construct.sh
-# example construction of JRE and JDK directories from the DLJ bundles
-#
-# Copyright © 2006 Sun Microsystems, Inc.
-#
-# Permission is hereby granted, free of charge, to any person obtaining
-# a copy of this software and associated documentation files (the
-# "Software"), to deal in the Software without restriction, including
-# without limitation the rights to use, copy, modify, merge, publish,
-# distribute, sublicense, and/or sell copies of the Software, and to
-# permit persons to whom the Software is furnished to do so, subject to
-# the following conditions:
-#
-# The above copyright notice and this permission notice shall be
-# included in all copies or substantial portions of the Software.
-#
-# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
-# EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
-# MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND
-# NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE
-# LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION
-# OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION
-# WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
-#
-# Sun, Sun Microsystems, the Sun logo and Java, Java HotSpot,
-# and JVM trademarks or registered trademarks of Sun Microsystems,
-# Inc. in the U.S. and other countries.
-
-
-program=`basename $0`
-
-usage () {
- echo "usage: ${program} path/to/unbundle-jdk path/to/linux-jdk path/to/linux-jre"
-}
-
-getargs() {
- undir=$1
- jdkdir=$2
- jredir=$3
- if [ ! -d $undir ]; then
- echo "${program}: unbundle directory not found: $undir"
- exit 2
- fi
- # make sure javahome is the JDK
- javahome=`echo $undir/*/demo`
- if [ ! -d $javahome ]; then
- echo "${program}: unbundle directory incorrect: $undir"
- echo " expecting $undir/jdk1.5.0_xx"
- exit 2
- else
- javahome=`dirname $javahome`
- fi
- # verify JDK dir
- jdkdirp=`dirname $jdkdir`
- jdkbase=`basename $jdkdir`
- if [ ! -d $jdkdirp ]; then
- echo "${program}: parent directory for JDK does not exist: $jdkdirp"
- exit 2
- fi
- savedir=`pwd`
- cd $jdkdirp
- jdkdirp=`pwd`
- cd $savedir
- jdkdir=$jdkdirp/$jdkbase
- # verify JRE dir
- jredirp=`dirname $jredir`
- jrebase=`basename $jredir`
- if [ ! -d $jredirp ]; then
- echo "${program}: parent directory for JRE does not exist: $jredirp"
- exit 2
- fi
- savedir=`pwd`
- cd $jredirp
- jredirp=`pwd`
- cd $savedir
- jredir=$jredirp/$jrebase
-}
-
-checkfiles() {
- if [ -r $jdkdir ]; then
- echo "${program}: directory for JDK already exists: $jdkdir"
- exit 2
- fi
- if [ -r $jredir ]; then
- echo "${program}: directory for JRE already exists: $jredir"
- exit 2
- fi
-}
-
-copytree() {
- echo "copying over the JDK tree..."
- cp -a $javahome $jdkdir
-}
-
-linkrel() {
- target=$1
- link=$2
- # make a softlink from the $link to the $target
- # make this a relative link
- targetb=(`echo $target | tr '/' ' '`)
- linkb=(`echo $link | tr '/' ' '`)
- (( n = ${#targetb[*]} ))
- (( m = ${#linkb[*]} ))
- c=$n # common length
- if [ $m -lt $c ]; then
- (( c = m ))
- fi
- for (( i = 0 ; i < c ; i++ )); do
- if [ ${targetb[$i]} != ${linkb[$i]} ]; then
- # echo components differ, stopping
- break
- fi
- done
- rel=""
- for (( j = i + 1; j < m ; j++ )); do
- if [ -z $rel ]; then
- rel=".."
- else
- rel="$rel/.."
- fi
- done
- for (( j = i; j < n ; j++ )); do
- if [ -z $rel ]; then
- rel=${targetb[$j]}
- else
- rel="$rel/${targetb[$j]}"
- fi
- done
- ln -s $rel $link
-}
-
-createjre() {
- echo "creating JRE directory..."
- # absolute link
- # ln -s $jdkdir/jre $jredir
- # relative link
- linkrel $jdkdir/jre $jredir
-}
-
-unpackjars() {
- echo "unpacking jars..."
- unpack200=$jdkdir/bin/unpack200
- if [ ! -x $unpack200 ]; then
- echo "${program}: file missing $unpack200"
- exit 1
- fi
- cd $jdkdir
- PACKED_JARS=`find . -name '*.pack'`
- for i in $PACKED_JARS; do
- # echo $i
- jdir=`dirname $i`
- jbase=`basename $i .pack`
- if ! $unpack200 $jdkdir/$jdir/$jbase.pack $jdkdir/$jdir/$jbase.jar; then
- echo "${program}: error unpacking $jdkdir/$jdir/$jbase.jar"
- fi
- if [ ! -r $jdkdir/$jdir/$jbase.jar ]; then
- echo "${program}: missing $jdkdir/$jdir/$jbase.jar"
- else
- echo " $jdir/$jbase.jar"
- # remove pack file
- rm $jdkdir/$jdir/$jbase.pack
- fi
- done
-}
-
-preparecds() {
- # if this is a client installation...
- compiler="`$jdkdir/bin/java -client -version 2>&1 | tail -n +3 | cut -d' ' -f1-4`"
- if [ "X$compiler" = "XJava HotSpot(TM) Client VM" ]; then
- # create the CDS archive
- echo "creating the class data sharing archive..."
- if ! $jdkdir/bin/java -client -Xshare:dump > /dev/null 2>&1; then
- echo "returned error code $?"
- fi
- fi
-}
-
-jreman () {
- echo "setting up the JRE man pages..."
- # note this list is slightly different for OpenSolaris bundles
- jreman="${T}/jre.man.txt"
-cat <<EOF > $jreman
-man/ja_JP.eucJP/man1/java.1
-man/ja_JP.eucJP/man1/javaws.1
-man/ja_JP.eucJP/man1/keytool.1
-man/ja_JP.eucJP/man1/kinit.1
-man/ja_JP.eucJP/man1/klist.1
-man/ja_JP.eucJP/man1/ktab.1
-man/ja_JP.eucJP/man1/orbd.1
-man/ja_JP.eucJP/man1/pack200.1
-man/ja_JP.eucJP/man1/policytool.1
-man/ja_JP.eucJP/man1/rmid.1
-man/ja_JP.eucJP/man1/rmiregistry.1
-man/ja_JP.eucJP/man1/servertool.1
-man/ja_JP.eucJP/man1/tnameserv.1
-man/ja_JP.eucJP/man1/unpack200.1
-man/man1/java.1
-man/man1/javaws.1
-man/man1/keytool.1
-man/man1/kinit.1
-man/man1/klist.1
-man/man1/ktab.1
-man/man1/orbd.1
-man/man1/pack200.1
-man/man1/policytool.1
-man/man1/rmid.1
-man/man1/rmiregistry.1
-man/man1/servertool.1
-man/man1/tnameserv.1
-man/man1/unpack200.1
-EOF
- # create jre/man directory
- # mkdir $jdkdir/jre/man
- # move the real JRE man pages to jre/man
- # link the JDK JRE man pages to jre/man
- # real JDK man pages stay where they are
- for m in `cat $jreman`; do
- manpath=`dirname $jdkdir/jre/$m`
- mkdir -p $manpath
- mv $jdkdir/$m $jdkdir/jre/$m
- linkrel $jdkdir/jre/$m $jdkdir/$m
- done
- # link in Japanese man pages
- ln -s ja_JP.eucJP $jdkdir/jre/man/ja
- rm $jreman
-}
-
-elimdups() {
- echo "eliminating duplication between the JDK and JDK/jre..."
- jdkcomm="${T}/jdk.bin.comm.txt"
-cat <<EOF > $jdkcomm
-bin/ControlPanel
-bin/java
-bin/javaws
-bin/keytool
-bin/kinit
-bin/klist
-bin/ktab
-bin/orbd
-bin/pack200
-bin/policytool
-bin/rmid
-bin/rmiregistry
-bin/servertool
-bin/tnameserv
-bin/unpack200
-EOF
- # note there is little point in linking these common files
- # COPYRIGHT
- # LICENSE
- # THIRDPARTYLICENSEREADME.txt
- # And this file is unique to the JDK
- # README.html
- # And these files are unique to the JDK/jre/
- # CHANGES
- # README
- # Welcome.html
- for p in `cat $jdkcomm`; do
- rm $jdkdir/$p
- # this is a relative link
- ln -s ../jre/$p $jdkdir/$p
- done
- rm $jdkcomm
-}
-
-if [ $# -eq 3 ] ; then
- getargs $1 $2 $3
- checkfiles
- copytree
- createjre
- unpackjars
- #preparecds
- jreman
- elimdups
-else
- usage
- exit 1
-fi
-
-exit 0
-
diff --git a/dev-java/sun-jre-bin/files/sun-jre-bin-1.5.env b/dev-java/sun-jre-bin/files/sun-jre-bin-1.5.env
deleted file mode 100644
index d4582f460222..000000000000
--- a/dev-java/sun-jre-bin/files/sun-jre-bin-1.5.env
+++ /dev/null
@@ -1,16 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jre-bin/files/sun-jre-bin-1.5.env,v 1.2 2008/01/18 15:05:14 caster Exp $
-
-VERSION="Sun JRE @PV@"
-JAVA_HOME=/opt/@P@
-JRE_HOME=/opt/@P@
-PATH="${JAVA_HOME}/bin:${JAVA_HOME}/javaws"
-ROOTPATH="${JAVA_HOME}/bin:${JAVA_HOME}/javaws"
-LDPATH="${JAVA_HOME}/lib/@PLATFORM@/:${JAVA_HOME}/lib/@PLATFORM@/native_threads/:${JAVA_HOME}/lib/@PLATFORM@/xawt/:${JAVA_HOME}/lib/@PLATFORM@/server/"
-MANPATH="/opt/@P@/man"
-PROVIDES_TYPE="JRE"
-PROVIDES_VERSION="1.5"
-BOOTCLASSPATH="${JAVA_HOME}/lib/rt.jar:${JAVA_HOME}/lib/jsse.jar:${JAVA_HOME}/lib/jce.jar:${JAVA_HOME}/lib/charsets.jar"
-GENERATION="2"
-ENV_VARS="JAVA_HOME JRE_HOME PATH ROOTPATH LDPATH MANPATH"
diff --git a/dev-java/sun-jre-bin/sun-jre-bin-1.5.0.22.ebuild b/dev-java/sun-jre-bin/sun-jre-bin-1.5.0.22.ebuild
deleted file mode 100644
index 7eefa4dac944..000000000000
--- a/dev-java/sun-jre-bin/sun-jre-bin-1.5.0.22.ebuild
+++ /dev/null
@@ -1,114 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jre-bin/sun-jre-bin-1.5.0.22.ebuild,v 1.3 2009/11/05 21:28:43 maekke Exp $
-
-inherit pax-utils versionator eutils java-vm-2
-
-UPDATE="$(get_version_component_range 4)"
-UPDATE="${UPDATE#0}"
-MY_PV="$(get_version_component_range 2-3)u${UPDATE}"
-
-X86_AT="jdk-${MY_PV}-dlj-linux-i586.bin"
-AMD64_AT="jdk-${MY_PV}-dlj-linux-amd64.bin"
-
-DESCRIPTION="Sun's Java SE Runtime Environment"
-HOMEPAGE="http://java.sun.com/j2se/1.5.0/"
-SRC_URI="x86? ( http://download.java.net/dlj/binaries/${X86_AT} )
- amd64? ( http://download.java.net/dlj/binaries/${AMD64_AT} )"
-SLOT="1.5"
-LICENSE="dlj-1.1"
-KEYWORDS="-* amd64 x86"
-RESTRICT="strip"
-IUSE="X alsa nsplugin odbc"
-
-RDEPEND="sys-libs/glibc
- alsa? ( media-libs/alsa-lib )
- X? (
- x11-libs/libXext
- x11-libs/libXi
- x11-libs/libXp
- x11-libs/libXtst
- x11-libs/libXt
- x11-libs/libX11
- )
- odbc? ( dev-db/unixODBC )"
-DEPEND=""
-
-JAVA_PROVIDE="jdbc-stdext jdbc-rowset"
-
-QA_TEXTRELS_x86="opt/${P}/lib/i386/motif21/libmawt.so
- opt/${P}/lib/i386/libdeploy.so"
-
-src_unpack() {
- mkdir bundled-jdk
- cd bundled-jdk
- sh "${DISTDIR}/${A}" --accept-license --unpack || die "Failed to unpack"
-
- cd ..
- bash "${FILESDIR}/construct.sh" bundled-jdk sun-jdk-${PV} ${P} || die "construct.sh failed"
-}
-
-src_compile() {
- # Set PaX markings on all JDK/JRE executables to allow code-generation on
- # the heap by the JIT compiler. This has to be done before CDS - #215225
- pax-mark m $(list-paxables "${S}"/bin/*)
-
- # see bug #207282
- if use x86; then
- einfo "Creating the Class Data Sharing archives"
- "${S}"/bin/java -client -Xshare:dump || die
- fi
-}
-
-src_install() {
- local dirs="bin lib man"
- # only X86 has the plugin and javaws
- use x86 && dirs="${dirs} javaws plugin"
- dodir /opt/${P}
-
- cp -pPR ${dirs} "${D}/opt/${P}/" || die "failed to copy"
-
- dodoc CHANGES README THIRDPARTYLICENSEREADME.txt || die
- dohtml Welcome.html || die
-
- if use nsplugin; then
- local plugin_dir="ns7-gcc29"
- if has_version '>=sys-devel/gcc-3' ; then
- plugin_dir="ns7"
- fi
-
- if use x86 ; then
- install_mozilla_plugin /opt/${P}/plugin/i386/$plugin_dir/libjavaplugin_oji.so
- else
- eerror "No plugin available for amd64 arch"
- fi
- fi
-
- # FIXME figure out how to handle the control pannel conflict with
- # sun-jdk-bin
-
- # install control panel for Gnome/KDE
-# sed -e "s/INSTALL_DIR\/JRE_NAME_VERSION/\/opt\/${P}\/jre/" \
-# -e "s/\(Name=Java\)/\1 Control Panel ${SLOT}/" \
-# ${D}/opt/${P}/plugin/desktop/sun_java.desktop > \
-# ${T}/sun_java-${SLOT}.desktop
-
-# domenu ${T}/sun_java-${SLOT}.desktop
-
- # bug #56444
- insinto /opt/${P}/lib/
- newins "${FILESDIR}"/fontconfig.Gentoo.properties \
- fontconfig.properties || die
-
- set_java_env
- java-vm_revdep-mask
-}
-
-pkg_postinst() {
- # Set as default VM if none exists
- java-vm-2_pkg_postinst
-
- elog "The epoll-based implementation of SelectorProvider is not selected by"
- elog "default."
- elog "Use java -Djava.nio.channels.spi.SelectorProvider=sun.nio.ch.EPollSelectorProvider"
-}
diff --git a/dev-java/sun-jre-bin/sun-jre-bin-1.6.0.19.ebuild b/dev-java/sun-jre-bin/sun-jre-bin-1.6.0.19.ebuild
deleted file mode 100644
index 12ddd48b9ed8..000000000000
--- a/dev-java/sun-jre-bin/sun-jre-bin-1.6.0.19.ebuild
+++ /dev/null
@@ -1,149 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jre-bin/sun-jre-bin-1.6.0.19.ebuild,v 1.3 2010/04/15 20:34:02 maekke Exp $
-
-inherit versionator pax-utils eutils java-vm-2
-
-UPDATE="$(get_version_component_range 4)"
-UPDATE="${UPDATE#0}"
-MY_PV="$(get_version_component_range 2)u${UPDATE}"
-
-SUFFIX=".bin"
-X86_AT="jdk-${MY_PV}-dlj-linux-i586${SUFFIX}"
-AMD64_AT="jdk-${MY_PV}-dlj-linux-amd64${SUFFIX}"
-
-DESCRIPTION="Sun's Java SE Runtime Environment"
-HOMEPAGE="http://java.sun.com/javase/6/"
-URL_BASE="http://download.java.net/dlj/binaries"
-SRC_URI="x86? ( ${URL_BASE}/${X86_AT} )
- amd64? ( ${URL_BASE}/${AMD64_AT} )"
-SLOT="1.6"
-LICENSE="dlj-1.1"
-KEYWORDS="-* amd64 x86"
-RESTRICT="strip"
-IUSE="X alsa jce nsplugin odbc"
-
-DEPEND="jce? ( =dev-java/sun-jce-bin-1.6.0* )"
-RDEPEND="${DEPEND}
- sys-libs/glibc
- x86? ( =virtual/libstdc++-3.3 )
- alsa? ( media-libs/alsa-lib )
- X? (
- x11-libs/libXext
- x11-libs/libXi
- x11-libs/libXp
- x11-libs/libXtst
- amd64? ( x11-libs/libXt )
- x11-libs/libX11
- )
- odbc? ( dev-db/unixODBC )"
-
-JAVA_PROVIDE="jdbc-stdext jdbc-rowset"
-
-QA_TEXTRELS_x86="opt/${P}/lib/i386/client/libjvm.so
- opt/${P}/lib/i386/motif21/libmawt.so
- opt/${P}/lib/i386/libdeploy.so
- opt/${P}/lib/i386/server/libjvm.so"
-
-src_unpack() {
- mkdir bundled-jdk
- cd bundled-jdk
- sh "${DISTDIR}"/${A} --accept-license --unpack || die "Failed to unpack"
-
- cd ..
- bash "${FILESDIR}/construct-1.6.sh" bundled-jdk sun-jdk-${PV} ${P} || die "construct.sh failed"
-}
-
-src_compile() {
- # Set PaX markings on all JDK/JRE executables to allow code-generation on
- # the heap by the JIT compiler. This has to be done before CDS - #215225
- pax-mark m $(list-paxables "${S}"/bin/*)
-
- # see bug #207282
- if use x86; then
- einfo "Creating the Class Data Sharing archives"
- "${S}"/bin/java -client -Xshare:dump || die
- "${S}"/bin/java -server -Xshare:dump || die
- fi
-}
-
-src_install() {
- local dirs="bin lib man"
-
- # only X86 has the plugin and javaws
- use x86 && dirs="${dirs} javaws plugin"
- dodir /opt/${P}
-
- cp -pPR $dirs "${D}/opt/${P}/" || die "failed to copy"
-
- dodoc README THIRDPARTYLICENSEREADME.txt || die
- dohtml Welcome.html || die
- dodir /opt/${P}/share/
-
- if use jce; then
- cd "${D}/opt/${P}/lib/security"
- dodir /opt/${P}/lib/security/strong-jce
- mv "${D}"/opt/${P}/lib/security/US_export_policy.jar \
- "${D}"/opt/${P}/lib/security/strong-jce || die
- mv "${D}"/opt/${P}/lib/security/local_policy.jar \
- "${D}"/opt/${P}/lib/security/strong-jce || die
- dosym /opt/sun-jce-bin-1.6.0/jre/lib/security/unlimited-jce/US_export_policy.jar /opt/${P}/lib/security/
- dosym /opt/sun-jce-bin-1.6.0/jre/lib/security/unlimited-jce/local_policy.jar /opt/${P}/lib/security/
- fi
-
- if use nsplugin; then
- local plugin_dir="ns7-gcc29"
- if has_version '>=sys-devel/gcc-3' ; then
- plugin_dir="ns7"
- fi
-
- if use x86 ; then
- install_mozilla_plugin /opt/${P}/lib/i386/libnpjp2.so
- install_mozilla_plugin /opt/${P}/plugin/i386/$plugin_dir/libjavaplugin_oji.so old_oji
- else
- install_mozilla_plugin /opt/${P}/lib/amd64/libnpjp2.so
- fi
- fi
-
- # install control panel for Gnome/KDE
- if [[ -e "${D}/opt/${P}/plugin/desktop/sun_java.desktop" ]]; then
- sed -e "s/\(Name=Java\)/\1 Control Panel for Sun JRE ${SLOT}/" \
- -e "s#Exec=.*#Exec=/opt/${P}/bin/ControlPanel#" \
- -e "s#Icon=.*#Icon=/opt/${P}/plugin/desktop/sun_java.png#" \
- "${D}/opt/${P}/plugin/desktop/sun_java.desktop" > \
- "${T}/sun_jre-${SLOT}.desktop" || die
- domenu "${T}/sun_jre-${SLOT}.desktop" || die
- fi
-
- # bug #56444
- insinto /opt/${P}/lib/
- newins "${FILESDIR}"/fontconfig.Gentoo.properties fontconfig.properties
-
- set_java_env
- java-vm_revdep-mask
-}
-
-pkg_postinst() {
- # Set as default VM if none exists
- java-vm-2_pkg_postinst
-
- if use x86 && use nsplugin; then
- elog
- elog "Two variants of the nsplugin are available via eselect java-nsplugin:"
- elog "Note that starting with ${PN}-1.6.0.18-r1 their naming and the default changed,"
- elog "users with the old plugin set are switched to the new default automatically."
- elog "The default ${VMHANDLE} is the new 'plugin2' which works in Firefox 3 (xulrunner-1.9)"
- elog "and newer, the ${VMHANDLE}-old_oji is the old plugin using the OJI API"
- elog "that was removed in Firefox 3.6 (xulrunner-1.9.2)."
- elog "For more info see https://jdk6.dev.java.net/plugin2/"
- elog
- fi
-
- if use amd64 && use nsplugin; then
- elog
- elog "The amd64 version ships the new 'plugin2' browser plugin which works"
- elog "in Firefox 3+ and other recent browser versions."
- elog "For more info see https://jdk6.dev.java.net/plugin2/"
- elog
- fi
-}