summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Aniszczyk <zx@gentoo.org>2004-02-18 03:31:41 +0000
committerChris Aniszczyk <zx@gentoo.org>2004-02-18 03:31:41 +0000
commitc8cb7d4b46140bc51de6a70e82a760d04f145501 (patch)
treecab6e9eca4b27594eb0ba970046a105235ad15d6 /dev-java/sablecc/sablecc-2.18.2.ebuild
parentfixed metadata error (diff)
downloadgentoo-2-c8cb7d4b46140bc51de6a70e82a760d04f145501.tar.gz
gentoo-2-c8cb7d4b46140bc51de6a70e82a760d04f145501.tar.bz2
gentoo-2-c8cb7d4b46140bc51de6a70e82a760d04f145501.zip
Initial import.
Diffstat (limited to 'dev-java/sablecc/sablecc-2.18.2.ebuild')
-rw-r--r--dev-java/sablecc/sablecc-2.18.2.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-java/sablecc/sablecc-2.18.2.ebuild b/dev-java/sablecc/sablecc-2.18.2.ebuild
new file mode 100644
index 000000000000..a069366a7d4e
--- /dev/null
+++ b/dev-java/sablecc/sablecc-2.18.2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/sablecc/sablecc-2.18.2.ebuild,v 1.1 2004/02/18 03:31:39 zx Exp $
+
+inherit java-pkg
+
+DESCRIPTION="Java based compiler / parser generator"
+HOMEPAGE="http://www.sablecc.org/"
+SRC_URI="mirror://sourceforge/sablecc/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="jikes"
+
+DEPEND=">=virtual/jdk-1.4
+ >=dev-java/java-getopt-1.0.9
+ >=dev-java/ant-1.5.1
+ jikes? ( >=dev-java/jikes-1.17 )"
+RDEPEND=">=virtual/jre-1.4"
+
+src_compile () {
+ local antflags="jar"
+ if [ `use jikes` ] ; then
+ :; # Do nothing, jikes is enable by default
+ else
+ antflags="${antflags} -Dbuild.compiler=modern"
+ fi
+ ant ${antflags}
+}
+
+src_install () {
+ java-pkg_dojar lib/*
+
+ # Create wrapper script
+ echo "#!/bin/sh" > ${PN}
+ echo "cd /usr/share/${PN}" >> ${PN}
+ echo '${JAVA_HOME}'/bin/java -jar lib/${PN}.jar '$*' >> ${PN}
+
+ dobin ${PN}
+
+ dodoc AUTHORS LICENSE THANKS
+ dohtml README.html
+}