summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2012-04-26 21:51:17 +0000
committerMiroslav Šulc <fordfrog@gentoo.org>2012-04-26 21:51:17 +0000
commit02894a677b5b9c226e4a23ad1580edc61a27108a (patch)
tree48c86332dfbe457aa59f2c9f7bf3ea32b1b49166 /dev-java/netbeans-websvccommon
parentdev-java/netbeans-profiler: version bump in 7.1 slot (diff)
downloadgentoo-2-02894a677b5b9c226e4a23ad1580edc61a27108a.tar.gz
gentoo-2-02894a677b5b9c226e4a23ad1580edc61a27108a.tar.bz2
gentoo-2-02894a677b5b9c226e4a23ad1580edc61a27108a.zip
dev-java/netbeans-websvccommon: version bump in 7.1 slot
(Portage version: 2.1.10.57/cvs/Linux x86_64)
Diffstat (limited to 'dev-java/netbeans-websvccommon')
-rw-r--r--dev-java/netbeans-websvccommon/ChangeLog8
-rw-r--r--dev-java/netbeans-websvccommon/netbeans-websvccommon-7.1.2.ebuild95
2 files changed, 102 insertions, 1 deletions
diff --git a/dev-java/netbeans-websvccommon/ChangeLog b/dev-java/netbeans-websvccommon/ChangeLog
index 7a906eaca211..c8d78fbf8f94 100644
--- a/dev-java/netbeans-websvccommon/ChangeLog
+++ b/dev-java/netbeans-websvccommon/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-java/netbeans-websvccommon
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/netbeans-websvccommon/ChangeLog,v 1.9 2012/03/05 14:20:53 fordfrog Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/netbeans-websvccommon/ChangeLog,v 1.10 2012/04/26 21:51:17 fordfrog Exp $
+
+*netbeans-websvccommon-7.1.2 (26 Apr 2012)
+
+ 26 Apr 2012; Miroslav Šulc <fordfrog@gentoo.org>
+ +netbeans-websvccommon-7.1.2.ebuild:
+ Version bump in 7.1 slot
*netbeans-websvccommon-7.1.1 (05 Mar 2012)
diff --git a/dev-java/netbeans-websvccommon/netbeans-websvccommon-7.1.2.ebuild b/dev-java/netbeans-websvccommon/netbeans-websvccommon-7.1.2.ebuild
new file mode 100644
index 000000000000..454a22114d9a
--- /dev/null
+++ b/dev-java/netbeans-websvccommon/netbeans-websvccommon-7.1.2.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/netbeans-websvccommon/netbeans-websvccommon-7.1.2.ebuild,v 1.1 2012/04/26 21:51:17 fordfrog Exp $
+
+EAPI="4"
+WANT_ANT_TASKS="ant-nodeps"
+inherit eutils java-pkg-2 java-ant-2
+
+DESCRIPTION="Netbeans Web Services Common Cluster"
+HOMEPAGE="http://netbeans.org/"
+SLOT="7.1"
+SOURCE_URL="http://dlc.sun.com.edgesuite.net/netbeans/7.1.2/final/zip/netbeans-7.1.2-201204101705-src.zip"
+SRC_URI="${SOURCE_URL}
+ http://dev.gentoo.org/~fordfrog/distfiles/netbeans-9999-r1-build.xml.patch.bz2"
+LICENSE="|| ( CDDL GPL-2-with-linking-exception )"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+S="${WORKDIR}"
+
+CDEPEND="~dev-java/netbeans-platform-${PV}
+ ~dev-java/netbeans-ide-${PV}"
+DEPEND="virtual/jdk:1.6
+ app-arch/unzip
+ ${CDEPEND}
+ dev-java/javahelp:0"
+RDEPEND=">=virtual/jdk-1.6
+ ${CDEPEND}"
+
+INSTALL_DIR="/usr/share/${PN}-${SLOT}"
+
+EANT_BUILD_XML="nbbuild/build.xml"
+EANT_BUILD_TARGET="rebuild-cluster"
+EANT_EXTRA_ARGS="-Drebuild.cluster.name=nb.cluster.websvccommon -Dext.binaries.downloaded=true"
+EANT_FILTER_COMPILER="ecj-3.3 ecj-3.4 ecj-3.5 ecj-3.6 ecj-3.7"
+JAVA_PKG_BSFIX="off"
+
+src_unpack() {
+ unpack $(basename ${SOURCE_URL})
+
+ einfo "Deleting bundled jars..."
+ find -name "*.jar" -type f -delete
+
+ unpack netbeans-9999-r1-build.xml.patch.bz2
+}
+
+src_prepare() {
+ einfo "Deleting bundled class files..."
+ find -name "*.class" -type f | xargs rm -vf
+
+ epatch netbeans-9999-r1-build.xml.patch
+
+ # Support for custom patches
+ if [ -n "${NETBEANS9999_PATCHES_DIR}" -a -d "${NETBEANS9999_PATCHES_DIR}" ] ; then
+ local files=`find "${NETBEANS9999_PATCHES_DIR}" -type f`
+
+ if [ -n "${files}" ] ; then
+ einfo "Applying custom patches:"
+
+ for file in ${files} ; do
+ epatch "${file}"
+ done
+ fi
+ fi
+
+ einfo "Symlinking external libraries..."
+ java-pkg_jar-from --build-only --into javahelp/external javahelp jhall.jar jhall-2.0_05.jar
+
+ einfo "Linking in other clusters..."
+ mkdir "${S}"/nbbuild/netbeans || die
+ pushd "${S}"/nbbuild/netbeans >/dev/null || die
+
+ ln -s /usr/share/netbeans-platform-${SLOT} platform || die
+ cat /usr/share/netbeans-platform-${SLOT}/moduleCluster.properties >> moduleCluster.properties || die
+ touch nb.cluster.platform.built
+
+ ln -s /usr/share/netbeans-ide-${SLOT} ide || die
+ cat /usr/share/netbeans-ide-${SLOT}/moduleCluster.properties >> moduleCluster.properties || die
+ touch nb.cluster.ide.built
+
+ popd >/dev/null || die
+
+ java-pkg-2_src_prepare
+}
+
+src_install() {
+ pushd nbbuild/netbeans/websvccommon >/dev/null || die
+
+ insinto ${INSTALL_DIR}
+ grep -E "/websvccommon$" ../moduleCluster.properties > "${D}"/${INSTALL_DIR}/moduleCluster.properties || die
+ doins -r *
+
+ popd >/dev/null || die
+
+ dosym ${INSTALL_DIR} /usr/share/netbeans-nb-${SLOT}/websvccommon
+}