summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2011-01-18 13:37:34 +0000
committerMiroslav Šulc <fordfrog@gentoo.org>2011-01-18 13:37:34 +0000
commit1d70ff7db21da0f2a2918831ad7764aff663dfc9 (patch)
tree32f87460b0d8c57e55aec150cafa78dd7fbd5fba /dev-java/junit
parentx86 stable, bug 348987 (diff)
downloadgentoo-2-1d70ff7db21da0f2a2918831ad7764aff663dfc9.tar.gz
gentoo-2-1d70ff7db21da0f2a2918831ad7764aff663dfc9.tar.bz2
gentoo-2-1d70ff7db21da0f2a2918831ad7764aff663dfc9.zip
dev-java/junit: version bump
(Portage version: 2.1.9.33/cvs/Linux x86_64)
Diffstat (limited to 'dev-java/junit')
-rw-r--r--dev-java/junit/ChangeLog9
-rw-r--r--dev-java/junit/junit-4.8.2.ebuild73
2 files changed, 80 insertions, 2 deletions
diff --git a/dev-java/junit/ChangeLog b/dev-java/junit/ChangeLog
index 3dc03ee32fa7..fa21cb5ee54d 100644
--- a/dev-java/junit/ChangeLog
+++ b/dev-java/junit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-java/junit
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/junit/ChangeLog,v 1.58 2010/08/29 11:10:48 ali_bush Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/junit/ChangeLog,v 1.59 2011/01/18 13:37:33 fordfrog Exp $
+
+*junit-4.8.2 (18 Jan 2011)
+
+ 18 Jan 2011; Miroslav Šulc <fordfrog@gentoo.org> +junit-4.8.2.ebuild:
+ Version bump
29 Aug 2010; Alistair Bush <ali_bush@gentoo.org> junit-4.6.ebuild:
Make dep on hamcrest-core more specific to avoid slotting issues
diff --git a/dev-java/junit/junit-4.8.2.ebuild b/dev-java/junit/junit-4.8.2.ebuild
new file mode 100644
index 000000000000..cd57a311160e
--- /dev/null
+++ b/dev-java/junit/junit-4.8.2.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/junit/junit-4.8.2.ebuild,v 1.1 2011/01/18 13:37:34 fordfrog Exp $
+
+# WARNING: JUNIT.JAR IS _NOT_ SYMLINKED TO ANT-CORE LIB FOLDER AS JUNIT3 IS
+
+JAVA_PKG_IUSE="doc examples source test"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="Simple framework to write repeatable tests"
+SRC_URI="https://github.com/downloads/KentBeck/${PN}/${PN}${PV}.zip"
+HOMEPAGE="http://www.junit.org/"
+LICENSE="CPL-1.0"
+SLOT="4"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+CDEPEND="=dev-java/hamcrest-core-1.1*"
+RDEPEND=">=virtual/jre-1.5
+ ${CDEPEND}"
+DEPEND=">=virtual/jdk-1.5
+ userland_GNU? ( >=sys-apps/findutils-4.3 )
+ app-arch/unzip
+ ${CDEPEND}"
+
+S="${WORKDIR}/${PN}${PV}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ mkdir -p src/main/java src/test/java || die
+ unzip -qq -d src/main/java ${P}-src.jar || die "unzip failed"
+
+ # fix javadoc compilation
+ if use doc ; then
+ cp "${S}"/javadoc/stylesheet.css "${S}" || die
+ fi
+
+ rm -rf javadoc temp.hamcrest.source *.jar || die
+ find . -name "*.class" -delete || die
+}
+
+src_compile() {
+ eant build jars -Dhamcrestlib=$(java-pkg_getjars hamcrest-core) $(use_doc javadoc)
+}
+
+src_test() {
+ mkdir classes || die
+ cd junit/tests || die
+ local cp=$(java-pkg_getjars hamcrest-core):${S}/${PN}${PV}/${PN}-dep-${PV}.jar
+ ejavac -sourcepath java -classpath ${cp} -d "${S}"/classes $(find . -name "*.java")
+
+ cd "${S}"/classes || die
+ for FILE in $(find . -name "AllTests\.class"); do
+ local CLASS=$(echo ${FILE} | sed -e "s/\.class//" | sed -e "s%/%.%g" | sed -e "s/\.\.//")
+ java -classpath .:${cp} org.junit.runner.JUnitCore ${CLASS} || die "Test ${CLASS} failed"
+ done
+}
+
+src_install() {
+ java-pkg_newjar ${PN}${PV}/${PN}-dep-${PV}.jar
+ dodoc README.html doc/ReleaseNotes${PV}.txt || die
+
+ use examples && java-pkg_doexamples org/junit/samples
+ use source && java-pkg_dosrc src/main/java/org src/main/java/junit
+
+ if use doc; then
+ dohtml -r doc/*
+ java-pkg_dojavadoc ${PN}${PV}/javadoc
+ fi
+}