summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlistair Bush <ali_bush@gentoo.org>2010-06-26 12:06:07 +0000
committerAlistair Bush <ali_bush@gentoo.org>2010-06-26 12:06:07 +0000
commit7a90ac524e1230c342252bbd04f8791cf795c56d (patch)
tree4670d0ccd5e554a257f00871e27dcfdba3f0b943 /dev-java/jruby
parentppc stable #323027 (diff)
downloadgentoo-2-7a90ac524e1230c342252bbd04f8791cf795c56d.tar.gz
gentoo-2-7a90ac524e1230c342252bbd04f8791cf795c56d.tar.bz2
gentoo-2-7a90ac524e1230c342252bbd04f8791cf795c56d.zip
Bump 1.4.1 to 1.4.1-r1 as last commit will change installed files. Clean 1.3.1.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-java/jruby')
-rw-r--r--dev-java/jruby/ChangeLog9
-rw-r--r--dev-java/jruby/jruby-1.4.1-r1.ebuild (renamed from dev-java/jruby/jruby-1.3.1-r1.ebuild)115
2 files changed, 71 insertions, 53 deletions
diff --git a/dev-java/jruby/ChangeLog b/dev-java/jruby/ChangeLog
index 017eaf90af77..4ce6dec32aa0 100644
--- a/dev-java/jruby/ChangeLog
+++ b/dev-java/jruby/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-java/jruby
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/jruby/ChangeLog,v 1.61 2010/06/26 11:58:41 ali_bush Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jruby/ChangeLog,v 1.62 2010/06/26 12:06:07 ali_bush Exp $
+
+*jruby-1.4.1-r1 (26 Jun 2010)
+
+ 26 Jun 2010; Alistair Bush <ali_bush@gentoo.org> -jruby-1.3.1-r1.ebuild,
+ +jruby-1.4.1-r1.ebuild:
+ Bump 1.4.1 to 1.4.1-r1 as last commit will change installed files. Clean
+ 1.3.1.
*jruby-1.5.1-r2 (26 Jun 2010)
diff --git a/dev-java/jruby/jruby-1.3.1-r1.ebuild b/dev-java/jruby/jruby-1.4.1-r1.ebuild
index 526d0c04722b..52215ad2a4a1 100644
--- a/dev-java/jruby/jruby-1.3.1-r1.ebuild
+++ b/dev-java/jruby/jruby-1.4.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/jruby/jruby-1.3.1-r1.ebuild,v 1.3 2010/02/09 17:10:23 caster Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jruby/jruby-1.4.1-r1.ebuild,v 1.1 2010/06/26 12:06:07 ali_bush Exp $
EAPI="2"
JAVA_PKG_IUSE="doc source test"
@@ -10,11 +10,12 @@ MY_PV="${PV/_rc1/RC1}"
DESCRIPTION="Java-based Ruby interpreter implementation"
HOMEPAGE="http://jruby.codehaus.org/"
-SRC_URI="http://dist.codehaus.org/${PN}/${MY_PV}/${PN}-src-${MY_PV}.tar.gz"
+#SRC_URI="http://jruby.kenai.com/downloads/${PV}/${PN}-src-${MY_PV}.tar.gz"
+SRC_URI="http://jruby.org.s3.amazonaws.com/downloads/${PV}/${PN}-src-${MY_PV}.tar.gz"
LICENSE="|| ( CPL-1.0 GPL-2 LGPL-2.1 )"
SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="bsf java6 ssl"
+KEYWORDS="~amd64 ~x86"
+IUSE="bsf ssl"
CDEPEND=">=dev-java/bytelist-1.0.2:0
>=dev-java/constantine-0.6:0
@@ -22,32 +23,29 @@ CDEPEND=">=dev-java/bytelist-1.0.2:0
>=dev-java/joni-1.1.3:0
>=dev-java/jna-posix-1.0.1:0
>=dev-java/jvyamlb-0.2.5:0
- dev-java/asm:3
- dev-java/jcodings:0
- dev-java/jffi:0.4
+ >=dev-java/asm-3.2:3
+ >=dev-java/jcodings-1.0.4:0
+ >=dev-java/jffi-0.7_pre:0.4
dev-java/jna:0
dev-java/joda-time:0
dev-util/jay:0[java]
- dev-java/nailgun:0"
+ dev-java/nailgun:0
+ dev-java/jaffl:0
+ dev-java/jgrapht:0"
RDEPEND="${CDEPEND}
- !java6? ( =virtual/jre-1.5* )
- java6? ( >=virtual/jre-1.6 )"
+ >=virtual/jre-1.6"
-# using 1.6 produces 1.6 bytecode, not sure why
DEPEND="${CDEPEND}
- !java6? ( =virtual/jdk-1.5* )
- java6? ( >=virtual/jdk-1.6 )
+ >=virtual/jdk-1.6
bsf? ( dev-java/bsf:2.3 )
test? (
dev-java/ant-junit
dev-java/ant-trax
- )"
+ )
+ !!<dev-ruby/jruby-1.3.1-r1"
-PDEPEND="dev-ruby/rubygems
- >=dev-ruby/rake-0.7.3
- >=dev-ruby/rspec-1.0.4
- ssl? ( dev-ruby/jruby-openssl )"
+PDEPEND="ssl? ( dev-ruby/jruby-openssl )"
# Tests work for ali_bush. But fail for flameeyes see #282439.
# Tests work for ali_bush inside the ebuild env
@@ -64,7 +62,7 @@ GEMS=${RUBY_HOME}/gems
JAVA_ANT_REWRITE_CLASSPATH="true"
JAVA_ANT_IGNORE_SYSTEM_CLASSES="true"
EANT_GENTOO_CLASSPATH="asm-3 bytelist constantine jay jcodings jffi-0.4 jline \
-joda-time joni jna jna-posix jvyamlb,nailgun"
+joda-time joni jna jna-posix jvyamlb nailgun jaffl jgrapht"
EANT_NEEDS_TOOLS="true"
pkg_setup() {
@@ -72,20 +70,22 @@ pkg_setup() {
local fail
- if [[ ! -d "${GEMS}" && -L "${GEMS}" ]]; then
- eerror "${GEMS} is a symlink. Please remove this symlink."
- fail="true"
- fi
-
- # the symlink creates a collision with rubygems, bug #270953
- # cannot be currently solved by removing in pkg_preinst, bug #233278
- if [[ -L "${SITE_RUBY}" ]]; then
- eerror "${SITE_RUBY} is a symlink. Please remove this symlink."
- fail="true"
- fi
+ for directory in "${GEMS}" "${SITE_RUBY}"; do
+ if [[ -L ${directory} ]]; then
+ eerror "${directory} is a symlink. Please do the following to resolve the situation:"
+ echo 'emerge -an app-portage/gentoolkit'
+ echo 'equery -qC b '"${directory}"' | sort | uniq | sed s/^/=/ > ~/jruby.fix'
+ echo 'emerge -1C $(< ~/jruby.fix)'
+ echo "rm ${directory}"
+ echo 'emerge -1 $(< ~/jruby.fix)'
+ echo 'rm ~/jruby.fix'
+
+ eerror "For more information, please see http://bugs.gentoo.org/show_bug.cgi?id=302187"
+ fail="true"
+ fi
+ done
if [[ -n ${fail} ]]; then
- eerror "Unmerging the old jruby version should also fix the problem(s)."
die "Please address the above errors, then run emerge --resume"
fi
}
@@ -93,6 +93,8 @@ pkg_setup() {
java_prepare() {
epatch "${FILESDIR}/ftype-test-fixes.patch"
epatch "${FILESDIR}/user-test-fixes.patch"
+ epatch "${FILESDIR}"/${PN}-1.4.0-system-jars-r2.patch
+ epatch "${FILESDIR}"/${PN}-1.4.0-bindir.patch
# We don't need to use Retroweaver. There is a jarjar and a regular jar
# target but even with jarjarclean, both are a pain. The latter target
@@ -103,9 +105,15 @@ java_prepare() {
-e "/<zipfileset .+\/>/d" \
build.xml || die
+ sed -i -e '/Arndt/d' src/org/jruby/RubyBigDecimal.java
+
# Delete the bundled JARs but keep invokedynamic.jar.
# No source is available and it's only a dummy anyway.
- find build_lib lib -name "*.jar" ! -name "invokedynamic.jar" -delete || die
+ find build_lib -name "*.jar" ! -name "jsr292-mock.jar" -delete || die
+ rm lib/profile.jar || die
+
+ use bsf && java-pkg_jar-from --into build_lib \
+ --build-only bsf-2.3
if ! use bsf; then
# Remove BSF test cases.
@@ -118,7 +126,8 @@ java_prepare() {
}
src_compile() {
- eant jar $(use_doc create-apidocs) -Djdk1.5+=true
+ eant jar $(use_doc apidocs) $(use bsf && echo "-Dbsf.present") \
+ -Djdk1.5+=true
}
src_test() {
@@ -131,7 +140,7 @@ src_test() {
# ali_bush was getting crashes while attempting to run a test.
# No info about why it crashed seemed to be produced.
# remove it as temp fix.
- sed -i -e '/MRI/d' build.xml || die "Failed to sed build.xml"
+ #sed -i -e '/MRI/d' build.xml || die "Failed to sed build.xml"
# BSF is a compile-time only dependency because it's just the adapter
# classes and they won't be used unless invoked from BSF itself.
@@ -152,27 +161,29 @@ src_install() {
use doc && java-pkg_dojavadoc docs/api
use source && java-pkg_dosrc src/org
- dobin "${FILESDIR}/jruby" || die
- exeinto "/usr/share/${PN}/bin"
- doexe "${S}/bin/jruby" || die
-
- # Install some jruby tools.
- dobin "${S}"/bin/j{gem,irb{,_swing},rubyc} || die
+ # We run the sed here in install so that we don't get the wrong
+ # data during the test phase!
+ sed \
+ -e '/++ebuild-cut-here++/, /--ebuild-cut-here--/ d' \
+ -e '/^JRUBY_HOME=/s:=:=/usr/share/jruby:' \
+ bin/jruby > "${T}"/jruby
- # Symlink some common tools so that jruby can launch them internally.
- for bin in {j,}gem jirb jrubyc rake rdoc ri spec{,_translator} ; do
- dosym "/usr/bin/${bin}" "/usr/share/${PN}/bin/${bin}" || die
- done
+ dobin "${T}"/jruby "${S}"/bin/j{irb{,_swing},rubyc} || die
insinto "${RUBY_HOME}"
- doins -r "${S}/lib/ruby/1.8" || die
- doins -r "${S}/lib/ruby/site_ruby" || die
+ doins -r "${S}"/lib/ruby/{1.8,1.9,site_ruby} || die
- # Autoload rubygems and append regular site_ruby to $LOAD_PATH.
- # Unfortunately the -I option prepends instead.
- insinto "${SITE_RUBY}"
- doins "${FILESDIR}/gentoo.rb" || die
- doenvd "${FILESDIR}/10jruby" || die
+ # Remove all the references to RubyGems as we're just going to
+ # install it through dev-ruby/rubygems.
+ find "${D}${RUBY_HOME}" -type f \
+ '(' '(' -path '*rubygems*' -not -name 'jruby.rb' ')' -or -name 'ubygems.rb' -or -name 'datadir.rb' ')' \
+ -delete || die
+}
- keepdir "${GEMS}"/1.8/{cache,doc}
+pkg_postinst() {
+ ewarn "If you're updating from <=jruby-1.4.0, you're going to get errors related"
+ ewarn "to gentoo.rb load failure."
+ ewarn "This is due to a stray definition of JRUBY_OPTS variable from the previous ebuilds."
+ ewarn "To solve the problem, either login in a new shell, use 'env -i ${SHELL} --login'"
+ ewarn "or explicitly unset the variable before running jruby."
}