summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVlastimil Babka <caster@gentoo.org>2008-12-23 11:27:01 +0000
committerVlastimil Babka <caster@gentoo.org>2008-12-23 11:27:01 +0000
commit0408450da1cab7453474f1795bf08d3c7c17ba9b (patch)
tree7ed3435dccfe656f0048a0c19279e8339c6d3098 /dev-java/jpfcodegen/jpfcodegen-0.4.ebuild
parentFix broken Manifest. (diff)
downloadgentoo-2-0408450da1cab7453474f1795bf08d3c7c17ba9b.tar.gz
gentoo-2-0408450da1cab7453474f1795bf08d3c7c17ba9b.tar.bz2
gentoo-2-0408450da1cab7453474f1795bf08d3c7c17ba9b.zip
New package - dependency of JabRef.
(Portage version: 2.2_rc17/cvs/Linux 2.6.27-gentoo-r1-perfctr x86_64)
Diffstat (limited to 'dev-java/jpfcodegen/jpfcodegen-0.4.ebuild')
-rw-r--r--dev-java/jpfcodegen/jpfcodegen-0.4.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-java/jpfcodegen/jpfcodegen-0.4.ebuild b/dev-java/jpfcodegen/jpfcodegen-0.4.ebuild
new file mode 100644
index 000000000000..9994764898c4
--- /dev/null
+++ b/dev-java/jpfcodegen/jpfcodegen-0.4.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jpfcodegen/jpfcodegen-0.4.ebuild,v 1.1 2008/12/23 11:27:01 caster Exp $
+
+EAPI=1
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="Generator of classes for accessing the attributes and extensions of JPF plug-ins."
+HOMEPAGE="http://jabref.sourceforge.net/"
+
+# packaging instructions:
+# svn export https://jabref.svn.sourceforge.net/svnroot/jabref/tags/jpfcodegen-0.4
+# rm jpfcodegen-0.4/lib/*.jar
+# sed -i 's/, unjarlib"/"/' jpfcodegen-0.4/build.xml
+
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+LICENSE="LGPL-3"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+COMMON_DEP="dev-java/velocity:0
+ dev-java/jpf:1.5"
+DEPEND="app-arch/unzip
+ >=virtual/jdk-1.5
+ ${COMMON_DEP}"
+RDEPEND=">=virtual/jre-1.5
+ ${COMMON_DEP}"
+
+# doc target is name="-javadoc" and would need a patch, on demand
+EANT_BUILD_TARGET="jars"
+EANT_GENTOO_CLASSPATH="jpf-1.5,velocity"
+JAVA_ANT_REWRITE_CLASSPATH="true"
+
+src_install() {
+ java-pkg_newjar JPFCodeGenerator-${PV}.jar JPFCodeGenerator.jar
+ java-pkg_newjar JPFCodeGenerator-${PV}-rt.jar JPFCodeGenerator-rt.jar
+ dohtml index.html
+}