summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Wijsman <tomwij@gentoo.org>2013-07-11 21:59:26 +0000
committerTom Wijsman <tomwij@gentoo.org>2013-07-11 21:59:26 +0000
commit5afd12d47e70de321b5424821a74318a6bc5673c (patch)
tree98888911654d54552e325e1ed79b7ab9ec2888b5 /dev-java/jnr-constants/jnr-constants-0.8.4.ebuild
parentVersion bump to 2.5.0. (diff)
downloadgentoo-2-5afd12d47e70de321b5424821a74318a6bc5673c.tar.gz
gentoo-2-5afd12d47e70de321b5424821a74318a6bc5673c.tar.bz2
gentoo-2-5afd12d47e70de321b5424821a74318a6bc5673c.zip
Version bump to 0.8.4.
(Portage version: 2.1.12.13/cvs/Linux x86_64, signed Manifest commit with key 6D34E57D)
Diffstat (limited to 'dev-java/jnr-constants/jnr-constants-0.8.4.ebuild')
-rw-r--r--dev-java/jnr-constants/jnr-constants-0.8.4.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-java/jnr-constants/jnr-constants-0.8.4.ebuild b/dev-java/jnr-constants/jnr-constants-0.8.4.ebuild
new file mode 100644
index 000000000000..a17b27d2cb7f
--- /dev/null
+++ b/dev-java/jnr-constants/jnr-constants-0.8.4.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jnr-constants/jnr-constants-0.8.4.ebuild,v 1.1 2013/07/11 21:59:26 tomwij Exp $
+
+EAPI="5"
+
+JAVA_PKG_IUSE="doc source test"
+
+inherit java-pkg-2 java-ant-2 vcs-snapshot
+
+DESCRIPTION="A set of platform constants (e.g. errno values)"
+HOMEPAGE="https://github.com/jnr/jnr-constants"
+SRC_URI="https://github.com/jnr/${PN}/tarball/${PV} -> ${P}.tar.gz"
+
+LICENSE="|| ( Apache-2.0 LGPL-3 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=virtual/jre-1.5"
+
+DEPEND="
+ >=virtual/jdk-1.5
+ test? (
+ dev-java/ant-junit:0
+ >=dev-java/junit-4.8:4
+ )"
+
+java_prepare() {
+ cp "${FILESDIR}"/${PN}_maven-build.xml build.xml || die
+}
+
+JAVA_ANT_ENCODING="UTF-8"
+JAVA_ANT_REWRITE_CLASSPATH="yes"
+
+EANT_EXTRA_ARGS="-Dmaven.build.finalName=${PN}"
+
+EANT_TEST_GENTOO_CLASSPATH="junit-4"
+src_test() {
+ java-pkg-2_src_test
+}
+
+src_install() {
+ java-pkg_dojar target/${PN}.jar
+
+ use doc && java-pkg_dojavadoc target/site/apidocs
+ use source && java-pkg_dosrc src/main/java/*
+}