summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVlastimil Babka <caster@gentoo.org>2007-06-08 20:42:53 +0000
committerVlastimil Babka <caster@gentoo.org>2007-06-08 20:42:53 +0000
commit7059620dfdba1b9d5465464888fe45f7d2575a50 (patch)
treeb3a14b308a1aca47995bfba27c4da997e2aa9845 /dev-java/jgroups
parentUse java-pkg_dojavadoc, add src_test and general ebuild cleanup. (diff)
downloadgentoo-2-7059620dfdba1b9d5465464888fe45f7d2575a50.tar.gz
gentoo-2-7059620dfdba1b9d5465464888fe45f7d2575a50.tar.bz2
gentoo-2-7059620dfdba1b9d5465464888fe45f7d2575a50.zip
Install docs to correct location and based on doc USE flag.
(Portage version: 2.1.2.9)
Diffstat (limited to 'dev-java/jgroups')
-rw-r--r--dev-java/jgroups/ChangeLog8
-rw-r--r--dev-java/jgroups/files/digest-jgroups-2.4.1_p1-r13
-rw-r--r--dev-java/jgroups/jgroups-2.4.1_p1-r1.ebuild79
3 files changed, 89 insertions, 1 deletions
diff --git a/dev-java/jgroups/ChangeLog b/dev-java/jgroups/ChangeLog
index c4b97e3430d7..bd958e884679 100644
--- a/dev-java/jgroups/ChangeLog
+++ b/dev-java/jgroups/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-java/jgroups
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/jgroups/ChangeLog,v 1.18 2007/06/02 18:01:14 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jgroups/ChangeLog,v 1.19 2007/06/08 20:42:53 caster Exp $
+
+*jgroups-2.4.1_p1-r1 (08 Jun 2007)
+
+ 08 Jun 2007; Vlastimil Babka <caster@gentoo.org>
+ +jgroups-2.4.1_p1-r1.ebuild:
+ Install docs to correct location and based on doc USE flag.
02 Jun 2007; nixnut <nixnut@gentoo.org> jgroups-2.4.1_p1.ebuild:
Stable on ppc wrt bug 179938
diff --git a/dev-java/jgroups/files/digest-jgroups-2.4.1_p1-r1 b/dev-java/jgroups/files/digest-jgroups-2.4.1_p1-r1
new file mode 100644
index 000000000000..3a00272a721e
--- /dev/null
+++ b/dev-java/jgroups/files/digest-jgroups-2.4.1_p1-r1
@@ -0,0 +1,3 @@
+MD5 dbe5417e129d63483b3277dd96aad9b0 JGroups-2.4.1-sp1.src.zip 7730494
+RMD160 d925f8f62a00edf29915b80b727d135102e563aa JGroups-2.4.1-sp1.src.zip 7730494
+SHA256 48229412ae47975cb0afcb3cbf24bb3e30fe5091f09a542d31e3e25964cdf051 JGroups-2.4.1-sp1.src.zip 7730494
diff --git a/dev-java/jgroups/jgroups-2.4.1_p1-r1.ebuild b/dev-java/jgroups/jgroups-2.4.1_p1-r1.ebuild
new file mode 100644
index 000000000000..0aafa90b8f8e
--- /dev/null
+++ b/dev-java/jgroups/jgroups-2.4.1_p1-r1.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jgroups/jgroups-2.4.1_p1-r1.ebuild,v 1.1 2007/06/08 20:42:53 caster Exp $
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-ant-2
+
+MY_PN="JGroups"
+MY_PV="${PV/_p/-sp}"
+MY_P="${MY_PN}-${MY_PV}"
+DESCRIPTION="JGroups is a toolkit for reliable multicast communication."
+SRC_URI="mirror://sourceforge/javagroups/${MY_P}.src.zip"
+HOMEPAGE="http://www.jgroups.org/javagroupsnew/docs/"
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ppc x86"
+RDEPEND=">=virtual/jre-1.4
+ dev-java/bsh
+ dev-java/commons-logging
+ dev-java/concurrent-util
+ dev-java/sun-jms
+ dev-java/sun-jmx"
+
+DEPEND=">=virtual/jdk-1.4
+ ${RDEPEND}
+ app-arch/unzip"
+
+S=${WORKDIR}/${MY_P}.src
+
+src_unpack() {
+ unpack ${A}
+
+ cd "${S}"
+ epatch "${FILESDIR}/2.4.1-jdk4.patch"
+
+ cd "${S}/lib" || die
+ rm -v *.jar || die
+
+ java-pkg_jar-from bsh
+ java-pkg_jar-from commons-logging
+ java-pkg_jar-from concurrent-util
+ java-pkg_jar-from sun-jms
+ java-pkg_jar-from sun-jmx
+
+ # Needed for unit tests
+ #java-pkg_jar-from --build-only junit
+ # One unit tests needs this
+ #java-pkg_jar-from --build-only bcprov
+
+ # Just get rid of these as they are of no use to us as we don't install them
+ # Always tries to compile them. Does not build on 1.4 if we don't remove
+ # these as they require java.lang.management
+ rm -vr "${S}"/tests/{junit,other}/org || die
+ java-pkg_filter-compiler jikes
+}
+
+# The jar target generates jgroups-all.jar that has the demos and tests in it
+EANT_BUILD_TARGET="jgroups-core.jar"
+
+src_install() {
+ java-pkg_dojar dist/jgroups-*.jar
+ dodoc CREDITS README || die
+
+ if use doc; then
+ java-pkg_dojavadoc dist/javadoc
+ insinto /usr/share/doc/${PF}
+ doins -r doc/* || die
+ fi
+ use source && java-pkg_dosrc src/*
+
+}
+
+RESTRICT="test"
+# A lot of these fail
+src_test() {
+ # run the report target for nice html pages
+ ANT_TASKS="ant-junit" eant unittests-xml
+}