summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVlastimil Babka <caster@gentoo.org>2010-04-20 20:31:41 +0000
committerVlastimil Babka <caster@gentoo.org>2010-04-20 20:31:41 +0000
commitcb73027b06054d4e875d6999760467d5cc0113ef (patch)
treea44c9104cb346e97156dba8af99e23305c07eb9c /dev-java/jgoodies-forms/jgoodies-forms-1.3.0.ebuild
parentFix documentation directory wrt #316423 by Chris Mayo. (diff)
downloadgentoo-2-cb73027b06054d4e875d6999760467d5cc0113ef.tar.gz
gentoo-2-cb73027b06054d4e875d6999760467d5cc0113ef.tar.bz2
gentoo-2-cb73027b06054d4e875d6999760467d5cc0113ef.zip
version bump.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-java/jgoodies-forms/jgoodies-forms-1.3.0.ebuild')
-rw-r--r--dev-java/jgoodies-forms/jgoodies-forms-1.3.0.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/dev-java/jgoodies-forms/jgoodies-forms-1.3.0.ebuild b/dev-java/jgoodies-forms/jgoodies-forms-1.3.0.ebuild
new file mode 100644
index 000000000000..ce7fc880da12
--- /dev/null
+++ b/dev-java/jgoodies-forms/jgoodies-forms-1.3.0.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jgoodies-forms/jgoodies-forms-1.3.0.ebuild,v 1.1 2010/04/20 20:31:41 caster Exp $
+
+JAVA_PKG_IUSE="doc examples source"
+
+inherit java-pkg-2 java-ant-2 eutils
+
+MY_PN="forms"
+MY_PV=${PV//./_}
+MY_P="${MY_PN}-${MY_PV}"
+DESCRIPTION="JGoodies Forms Library"
+HOMEPAGE="http://www.jgoodies.com/"
+SRC_URI="http://www.jgoodies.com/download/libraries/${MY_PN}/${MY_P}.zip"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND=">=virtual/jdk-1.4
+ app-arch/unzip"
+RDEPEND=">=virtual/jre-1.4"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+src_unpack() {
+ unpack ${A} || die "Unpack failed"
+ cd "${S}"
+
+ # Remove the packaged jars
+ rm -v *.jar || die "rm failed"
+}
+
+src_compile() {
+ # it does not like unset ${build.compiler.executable}
+ # feel free to fix if you want jikes back
+ java-pkg_filter-compiler jikes
+ # not setting the bootcp breaks ecj, javac apparently ignores nonsense
+ eant -Dbuild.boot.classpath="$(java-config -g BOOTCLASSPATH)" jar
+}
+
+#Needs X
+#src_test() {
+# ANT_TASKS="ant-junit" eant test \
+# -Djunit.jar="$(java-pkg_getjars junit)"
+#}
+
+src_install() {
+ java-pkg_dojar build/${MY_PN}.jar
+
+ dodoc RELEASE-NOTES.txt README.html || die
+
+ use doc && java-pkg_dohtml -r docs/*
+ use source && java-pkg_dosrc src/{core,extras}/com
+ use examples && java-pkg_doexamples src/tutorial
+}