summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Whyman <thev00d00@gentoo.org>2012-08-25 19:09:47 +0000
committerIan Whyman <thev00d00@gentoo.org>2012-08-25 19:09:47 +0000
commitdf0e01b166f49234ecec3b6d2f7a6c3e8860f5f8 (patch)
treee6ddbb23f55cc5e0bf16d24a52ad47065a0beb7c /dev-java/jffi
parent[bump] dev-perl/Getopt-Mixed-1.110.0 (diff)
downloadgentoo-2-df0e01b166f49234ecec3b6d2f7a6c3e8860f5f8.tar.gz
gentoo-2-df0e01b166f49234ecec3b6d2f7a6c3e8860f5f8.tar.bz2
gentoo-2-df0e01b166f49234ecec3b6d2f7a6c3e8860f5f8.zip
Fix build with GCC 4.7 #421501
(Portage version: 2.2.0_alpha121/cvs/Linux x86_64)
Diffstat (limited to 'dev-java/jffi')
-rw-r--r--dev-java/jffi/ChangeLog7
-rw-r--r--dev-java/jffi/jffi-0.6.0.2-r1.ebuild7
-rw-r--r--dev-java/jffi/jffi-0.6.0.2.ebuild7
-rw-r--r--dev-java/jffi/jffi-0.7_pre20100131.ebuild5
-rw-r--r--dev-java/jffi/jffi-1.0.0.ebuild5
-rw-r--r--dev-java/jffi/jffi-1.0.11.ebuild5
6 files changed, 28 insertions, 8 deletions
diff --git a/dev-java/jffi/ChangeLog b/dev-java/jffi/ChangeLog
index ed59cae35c9c..299579d6ac0c 100644
--- a/dev-java/jffi/ChangeLog
+++ b/dev-java/jffi/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-java/jffi
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/jffi/ChangeLog,v 1.22 2012/05/28 19:33:58 sera Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jffi/ChangeLog,v 1.23 2012/08/25 19:09:47 thev00d00 Exp $
+
+ 25 Aug 2012; <iwhyman@gentoo.org> jffi-0.6.0.2.ebuild,
+ jffi-0.6.0.2-r1.ebuild, jffi-0.7_pre20100131.ebuild, jffi-1.0.0.ebuild,
+ jffi-1.0.11.ebuild:
+ Fix build with GCC 4.7 #421501
28 May 2012; Ralph Sennhauser <sera@gentoo.org> jffi-1.2.2.ebuild:
use https for HOMEPAGE. Reported by Arfrever.
diff --git a/dev-java/jffi/jffi-0.6.0.2-r1.ebuild b/dev-java/jffi/jffi-0.6.0.2-r1.ebuild
index 393f86131f8b..6e66f46e9563 100644
--- a/dev-java/jffi/jffi-0.6.0.2-r1.ebuild
+++ b/dev-java/jffi/jffi-0.6.0.2-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/jffi/jffi-0.6.0.2-r1.ebuild,v 1.2 2010/01/24 20:56:13 betelgeuse Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jffi/jffi-0.6.0.2-r1.ebuild,v 1.3 2012/08/25 19:09:47 thev00d00 Exp $
# Probably best to leave the CFLAGS as they are here. See...
# http://weblogs.java.net/blog/kellyohair/archive/2006/01/compilation_of_1.html
@@ -56,6 +56,9 @@ java_prepare() {
sed -i '/<zipfileset src="archive\//d' custom-build.xml || die
sed -i '/libs.CopyLibs.classpath/d' lib/nblibraries.properties || die
sed -i '/copylibstask.jar/d' lib/nblibraries.properties || die
+
+ # Fix build with GCC 4.7 #421501
+ sed -i -e "s|-mimpure-text||g" jni/GNUmakefile || die
}
src_install() {
diff --git a/dev-java/jffi/jffi-0.6.0.2.ebuild b/dev-java/jffi/jffi-0.6.0.2.ebuild
index 286883d98a83..964b8d2a83ca 100644
--- a/dev-java/jffi/jffi-0.6.0.2.ebuild
+++ b/dev-java/jffi/jffi-0.6.0.2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/jffi/jffi-0.6.0.2.ebuild,v 1.1 2009/12/30 06:36:19 ali_bush Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jffi/jffi-0.6.0.2.ebuild,v 1.2 2012/08/25 19:09:47 thev00d00 Exp $
# Probably best to leave the CFLAGS as they are here. See...
# http://weblogs.java.net/blog/kellyohair/archive/2006/01/compilation_of_1.html
@@ -55,6 +55,9 @@ java_prepare() {
sed -i '/<zipfileset src="archive\//d' custom-build.xml || die
sed -i '/libs.CopyLibs.classpath/d' lib/nblibraries.properties || die
sed -i '/copylibstask.jar/d' lib/nblibraries.properties || die
+
+ # Fix build with GCC 4.7 #421501
+ sed -i -e "s|-mimpure-text||g" jni/GNUmakefile || die
}
src_install() {
diff --git a/dev-java/jffi/jffi-0.7_pre20100131.ebuild b/dev-java/jffi/jffi-0.7_pre20100131.ebuild
index cfca57a4c3a2..f2d44debcbe6 100644
--- a/dev-java/jffi/jffi-0.7_pre20100131.ebuild
+++ b/dev-java/jffi/jffi-0.7_pre20100131.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/jffi/jffi-0.7_pre20100131.ebuild,v 1.2 2012/05/03 07:42:51 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jffi/jffi-0.7_pre20100131.ebuild,v 1.3 2012/08/25 19:09:47 thev00d00 Exp $
# Probably best to leave the CFLAGS as they are here. See...
# http://weblogs.java.net/blog/kellyohair/archive/2006/01/compilation_of_1.html
@@ -61,6 +61,9 @@ java_prepare() {
sed -i '/<zipfileset src="archive\//d' custom-build.xml || die
sed -i '/libs.CopyLibs.classpath/d' lib/nblibraries.properties || die
sed -i '/copylibstask.jar/d' lib/nblibraries.properties || die
+
+ # Fix build with GCC 4.7 #421501
+ sed -i -e "s|-mimpure-text||g" jni/GNUmakefile || die
}
src_install() {
diff --git a/dev-java/jffi/jffi-1.0.0.ebuild b/dev-java/jffi/jffi-1.0.0.ebuild
index 9938b0afa3e7..3a19a3452de6 100644
--- a/dev-java/jffi/jffi-1.0.0.ebuild
+++ b/dev-java/jffi/jffi-1.0.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/jffi/jffi-1.0.0.ebuild,v 1.7 2012/05/03 07:42:51 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jffi/jffi-1.0.0.ebuild,v 1.8 2012/08/25 19:09:47 thev00d00 Exp $
# Probably best to leave the CFLAGS as they are here. See...
# http://weblogs.java.net/blog/kellyohair/archive/2006/01/compilation_of_1.html
@@ -50,6 +50,9 @@ java_prepare() {
sed -i '/<zipfileset src="archive\//d' custom-build.xml || die
sed -i '/libs.CopyLibs.classpath/d' lib/nblibraries.properties || die
sed -i '/copylibstask.jar/d' lib/nblibraries.properties || die
+
+ # Fix build with GCC 4.7 #421501
+ sed -i -e "s|-mimpure-text||g" jni/GNUmakefile || die
}
EANT_EXTRA_ARGS="-Duse.system.libffi=1"
diff --git a/dev-java/jffi/jffi-1.0.11.ebuild b/dev-java/jffi/jffi-1.0.11.ebuild
index 7c0fc514035e..532c6d5551cf 100644
--- a/dev-java/jffi/jffi-1.0.11.ebuild
+++ b/dev-java/jffi/jffi-1.0.11.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/jffi/jffi-1.0.11.ebuild,v 1.4 2012/05/09 17:10:15 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jffi/jffi-1.0.11.ebuild,v 1.5 2012/08/25 19:09:47 thev00d00 Exp $
EAPI="4"
@@ -39,6 +39,9 @@ java_prepare() {
epatch "${FILESDIR}"/${P}_no-werror.patch
find "${WORKDIR}" -iname '*.jar' -delete
+
+ # Fix build with GCC 4.7 #421501
+ sed -i -e "s|-mimpure-text||g" jni/GNUmakefile || die
}
JAVA_ANT_REWRITE_CLASSPATH="yes"