summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Brinkmann <luckyduck@gentoo.org>2005-01-29 21:50:11 +0000
committerJan Brinkmann <luckyduck@gentoo.org>2005-01-29 21:50:11 +0000
commit2a0c2c49b3f076850a7a73b2728a61896ad581a9 (patch)
tree03f63ba0095e39bebd65d8e555662556a28661dd /dev-java/jexcelapi/jexcelapi-2.5.1.ebuild
parentadded source useflag to dev-java/jexcelapi (diff)
downloadgentoo-2-2a0c2c49b3f076850a7a73b2728a61896ad581a9.tar.gz
gentoo-2-2a0c2c49b3f076850a7a73b2728a61896ad581a9.tar.bz2
gentoo-2-2a0c2c49b3f076850a7a73b2728a61896ad581a9.zip
added support for the source useflag. fixes #79966
(Portage version: 2.0.51-r15)
Diffstat (limited to 'dev-java/jexcelapi/jexcelapi-2.5.1.ebuild')
-rw-r--r--dev-java/jexcelapi/jexcelapi-2.5.1.ebuild12
1 files changed, 9 insertions, 3 deletions
diff --git a/dev-java/jexcelapi/jexcelapi-2.5.1.ebuild b/dev-java/jexcelapi/jexcelapi-2.5.1.ebuild
index 18056f377291..a8068356090f 100644
--- a/dev-java/jexcelapi/jexcelapi-2.5.1.ebuild
+++ b/dev-java/jexcelapi/jexcelapi-2.5.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/jexcelapi/jexcelapi-2.5.1.ebuild,v 1.1 2005/01/23 14:50:15 luckyduck Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jexcelapi/jexcelapi-2.5.1.ebuild,v 1.2 2005/01/29 21:50:11 luckyduck Exp $
inherit eutils java-pkg
@@ -15,12 +15,11 @@ LICENSE="LGPL-2.1"
SLOT="2.5"
KEYWORDS="~x86 ~amd64"
-IUSE="doc jikes"
+IUSE="doc jikes source"
DEPEND=">=virtual/jdk-1.3
dev-java/ant-core
jikes? ( dev-java/jikes )"
RDEPEND=">=virtual/jre-1.3"
-RESTRICT="nomirror"
S=${WORKDIR}/${PN}
@@ -46,6 +45,13 @@ src_install() {
mv jxl.jar ${PN}.jar
java-pkg_dojar ${PN}.jar
+ if use source; then
+ cd ${S}/src
+ jar cf ${PN}-src.jar *
+ dodir /usr/share/doc/${PF}/source
+ cp ${PN}-src.jar ${D}usr/share/doc/${PF}/source
+ fi
+
java-pkg_dohtml index.html tutorial.html
use doc && java-pkg_dohtml -r docs/*
}