summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDylan Carlson <absinthe@gentoo.org>2004-10-20 12:27:10 +0000
committerDylan Carlson <absinthe@gentoo.org>2004-10-20 12:27:10 +0000
commit1b2961c6d8d39fb99a0f191a9492ce8299740e15 (patch)
tree4c14e18da90e4182e9bf8d35c6dcd2455519ef37 /dev-java/jdbc2-firebird
parentRemoved extra quotes from net-setup and closing bug #68246. (diff)
downloadgentoo-2-1b2961c6d8d39fb99a0f191a9492ce8299740e15.tar.gz
gentoo-2-1b2961c6d8d39fb99a0f191a9492ce8299740e15.tar.bz2
gentoo-2-1b2961c6d8d39fb99a0f191a9492ce8299740e15.zip
Initial import. Closes bug 48331.
Diffstat (limited to 'dev-java/jdbc2-firebird')
-rw-r--r--dev-java/jdbc2-firebird/ChangeLog6
-rw-r--r--dev-java/jdbc2-firebird/Manifest6
-rw-r--r--dev-java/jdbc2-firebird/files/digest-jdbc3-firebird-1.5.31
-rw-r--r--dev-java/jdbc2-firebird/jdbc3-firebird-1.5.3.ebuild29
4 files changed, 37 insertions, 5 deletions
diff --git a/dev-java/jdbc2-firebird/ChangeLog b/dev-java/jdbc2-firebird/ChangeLog
index 7d8abf4fcc1e..0b8fe5985f08 100644
--- a/dev-java/jdbc2-firebird/ChangeLog
+++ b/dev-java/jdbc2-firebird/ChangeLog
@@ -1,10 +1,10 @@
# ChangeLog for dev-java/jdbc2-firebird
# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/jdbc2-firebird/ChangeLog,v 1.1 2004/10/20 12:07:08 absinthe Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jdbc2-firebird/ChangeLog,v 1.2 2004/10/20 12:27:10 absinthe Exp $
-*jdbc2-firebird-1.5.3 (20 Oct 2004)
+*jdbc3-firebird-1.5.3 (20 Oct 2004)
20 Oct 2004; Dylan Carlson <absinthe@gentoo.org> +metadata.xml,
- +jdbc2-firebird-1.5.3.ebuild:
+ +jdbc3-firebird-1.5.3.ebuild:
Initial import. Closes bug 48331.
diff --git a/dev-java/jdbc2-firebird/Manifest b/dev-java/jdbc2-firebird/Manifest
index 757e4a45f70f..a4157bcd80c9 100644
--- a/dev-java/jdbc2-firebird/Manifest
+++ b/dev-java/jdbc2-firebird/Manifest
@@ -1,2 +1,4 @@
-MD5 e031693aff89f0dcb92f9f3013d56b8b jdbc2-firebird-1.5.3.ebuild 743
-MD5 65355e69fa5bd7c91d6e79f143885bc0 files/digest-jdbc2-firebird-1.5.3 74
+MD5 a6ec7d7724fbd068ffb39b5be56134ed metadata.xml 157
+MD5 b092cd8a42174531f87fe02d60a35223 ChangeLog 393
+MD5 16a2e6899480a2a1b9c9ff74319f0357 jdbc3-firebird-1.5.3.ebuild 736
+MD5 a28064d667f1f2c8fda8f0d858cd08b8 files/digest-jdbc3-firebird-1.5.3 74
diff --git a/dev-java/jdbc2-firebird/files/digest-jdbc3-firebird-1.5.3 b/dev-java/jdbc2-firebird/files/digest-jdbc3-firebird-1.5.3
new file mode 100644
index 000000000000..04729900f93c
--- /dev/null
+++ b/dev-java/jdbc2-firebird/files/digest-jdbc3-firebird-1.5.3
@@ -0,0 +1 @@
+MD5 9700e05ec25b82f17d113486cc3a7c34 FirebirdSQL-1.5.3JDK_1.4.zip 2788095
diff --git a/dev-java/jdbc2-firebird/jdbc3-firebird-1.5.3.ebuild b/dev-java/jdbc2-firebird/jdbc3-firebird-1.5.3.ebuild
new file mode 100644
index 000000000000..1f9583618cd1
--- /dev/null
+++ b/dev-java/jdbc2-firebird/jdbc3-firebird-1.5.3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jdbc2-firebird/jdbc3-firebird-1.5.3.ebuild,v 1.1 2004/10/20 12:27:10 absinthe Exp $
+
+inherit java-pkg
+
+At="FirebirdSQL-${PV}JDK_1.4"
+DESCRIPTION="JDBC3 driver for Firebird SQL server"
+HOMEPAGE="http://www.firebird.sourceforge.net"
+SRC_URI="mirror://sourceforge/firebird/${At}.zip"
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~amd64"
+IUSE="doc"
+DEPEND=">=virtual/jdk-1.4"
+RDEPEND=">=virtual/jdk-1.4"
+S=${WORKDIR}
+
+src_compile() {
+ :;
+}
+
+src_install() {
+ java-pkg_dojar *.jar
+ java-pkg_dojar lib/*.jar
+
+ use doc && java-pkg_dohtml -r docs/
+ dodoc ChangeLog release_notes.html
+}