summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDylan Carlson <absinthe@gentoo.org>2004-10-20 09:14:23 +0000
committerDylan Carlson <absinthe@gentoo.org>2004-10-20 09:14:23 +0000
commit2aaadb9888bc991cdf26266eb5e5411cb4b08175 (patch)
tree8b13c5c87b00901e9e495b5f3a62d0300c7cb5e9 /dev-java/jcommon/jcommon-0.9.7.ebuild
parentKeywords ~amd64. (Manifest recommit) (diff)
downloadgentoo-2-2aaadb9888bc991cdf26266eb5e5411cb4b08175.tar.gz
gentoo-2-2aaadb9888bc991cdf26266eb5e5411cb4b08175.tar.bz2
gentoo-2-2aaadb9888bc991cdf26266eb5e5411cb4b08175.zip
Version bump. Added KEYWORDS ~amd64.
Diffstat (limited to 'dev-java/jcommon/jcommon-0.9.7.ebuild')
-rw-r--r--dev-java/jcommon/jcommon-0.9.7.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-java/jcommon/jcommon-0.9.7.ebuild b/dev-java/jcommon/jcommon-0.9.7.ebuild
new file mode 100644
index 000000000000..206f40e72107
--- /dev/null
+++ b/dev-java/jcommon/jcommon-0.9.7.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jcommon/jcommon-0.9.7.ebuild,v 1.1 2004/10/20 09:14:23 absinthe Exp $
+
+inherit java-pkg
+
+DESCRIPTION="JCommon is a collection of useful classes used by JFreeChart, JFreeReport and other projects."
+HOMEPAGE="http://www.jfree.org"
+SRC_URI="mirror://sourceforge/jfreechart/${P}.tar.gz"
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~amd64"
+IUSE="doc jikes"
+DEPEND=">=virtual/jdk-1.3
+ dev-java/ant
+ dev-java/junit
+ jikes? ( dev-java/jikes )"
+RDEPEND=">=virtual/jdk-1.3"
+
+src_compile() {
+ rm -f junit/*
+ local antflags="compile javadoc"
+ use jikes && antflags="${antflags} -Dbuild.compiler=jikes"
+ ant -f ant/build.xml ${antflags} || die "compile failed"
+}
+
+src_install() {
+ java-pkg_dojar ${P}.jar
+ dodoc README.txt licence-LGPL.txt
+ use doc && java-pkg_dohtml -r javadoc
+}
+