summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVlastimil Babka <caster@gentoo.org>2010-05-11 07:53:15 +0000
committerVlastimil Babka <caster@gentoo.org>2010-05-11 07:53:15 +0000
commit6773f657ff7629f3217c82daf76a04d6507e696d (patch)
tree1cdb54f7491b0b16f871e40da64639005e31c9dd /dev-java/java-sdk-docs
parentBug 313769: Mask new sys-libs/db-5* for testing and testsuite failures. (diff)
downloadgentoo-2-6773f657ff7629f3217c82daf76a04d6507e696d.tar.gz
gentoo-2-6773f657ff7629f3217c82daf76a04d6507e696d.tar.bz2
gentoo-2-6773f657ff7629f3217c82daf76a04d6507e696d.zip
Version bump, fixes bug #319235
(Portage version: 2.2_rc67/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'dev-java/java-sdk-docs')
-rw-r--r--dev-java/java-sdk-docs/ChangeLog8
-rw-r--r--dev-java/java-sdk-docs/java-sdk-docs-1.6.0.18.ebuild46
2 files changed, 53 insertions, 1 deletions
diff --git a/dev-java/java-sdk-docs/ChangeLog b/dev-java/java-sdk-docs/ChangeLog
index a1303ecc42c6..951211b63ec9 100644
--- a/dev-java/java-sdk-docs/ChangeLog
+++ b/dev-java/java-sdk-docs/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-java/java-sdk-docs
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/java-sdk-docs/ChangeLog,v 1.68 2010/01/03 20:49:01 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/java-sdk-docs/ChangeLog,v 1.69 2010/05/11 07:53:15 caster Exp $
+
+*java-sdk-docs-1.6.0.18 (11 May 2010)
+
+ 11 May 2010; Vlastimil Babka <caster@gentoo.org>
+ +java-sdk-docs-1.6.0.18.ebuild:
+ Version bump, fixes bug #319235
03 Jan 2010; Christian Faulhammer <fauli@gentoo.org>
java-sdk-docs-1.6.0.10.ebuild:
diff --git a/dev-java/java-sdk-docs/java-sdk-docs-1.6.0.18.ebuild b/dev-java/java-sdk-docs/java-sdk-docs-1.6.0.18.ebuild
new file mode 100644
index 000000000000..3dc82de230f4
--- /dev/null
+++ b/dev-java/java-sdk-docs/java-sdk-docs-1.6.0.18.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/java-sdk-docs/java-sdk-docs-1.6.0.18.ebuild,v 1.1 2010/05/11 07:53:15 caster Exp $
+
+ORIG_NAME="jdk-6u18-docs.zip"
+SRC_URI="jdk-6u18-docs.zip"
+DESCRIPTION="Sun's documentation bundle (including API) for Java SE"
+HOMEPAGE="http://java.sun.com/javase/6/docs/"
+LICENSE="sun-j2sl-6"
+SLOT="1.6.0"
+KEYWORDS="amd64 ppc ppc64 x86 ~amd64-linux ~x86-linux"
+IUSE=""
+DEPEND="app-arch/unzip"
+RDEPEND=""
+RESTRICT="fetch"
+
+DOWNLOAD_URL="https://cds.sun.com/is-bin/INTERSHOP.enfinity/WFS/CDS-CDS_Developer-Site/en_US/-/USD/ViewProductDetail-Start?ProductRef=jdk-6u18-docs-oth-JPR@CDS-CDS_Developer"
+S="${WORKDIR}/docs"
+
+pkg_nofetch() {
+ einfo "Please download ${ORIG_NAME} from "
+ einfo "${DOWNLOAD_URL}"
+ einfo "(select English and agree to the licence) and place it in ${DISTDIR}"
+
+# It appears they at least bump the filename nowadays
+# einfo "named as ${SRC_URI}. Because Sun changes the doc zip file"
+# einfo "without changing the filename, we have to resort to renaming to keep"
+# einfo "the md5sum verification working for existing and new downloads."
+# einfo ""
+
+ einfo "If you find the file on the download page replaced with a higher"
+ einfo "version, please report to the bug 67266 (link below)."
+ einfo "If emerge fails because of a checksum error it is possible that"
+ einfo "the upstream release changed without renaming. Try downloading the file"
+ einfo "again (or a newer revision if available). Otherwise report this to"
+ einfo "http://bugs.gentoo.org/67266 and we will make a new revision."
+}
+
+src_install(){
+ insinto /usr/share/doc/${P}/html
+ doins index.html
+
+ for i in *; do
+ [[ -d $i ]] && doins -r $i
+ done
+}