summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetteri Räty <betelgeuse@gentoo.org>2007-05-25 21:51:08 +0000
committerPetteri Räty <betelgeuse@gentoo.org>2007-05-25 21:51:08 +0000
commitc62943f3988a3644a589c31f9bb4959c4e0852de (patch)
tree0d923ab14e27e79b7f3b8c7183d32acc8128955c /dev-java/java-config
parentSync x86/2.6/use.mask with the one from default-linux/x86. Basically re-unmas... (diff)
downloadgentoo-2-c62943f3988a3644a589c31f9bb4959c4e0852de.tar.gz
gentoo-2-c62943f3988a3644a589c31f9bb4959c4e0852de.tar.bz2
gentoo-2-c62943f3988a3644a589c31f9bb4959c4e0852de.zip
Version bump. Multiple small fixes. Moves files out of PORTDIR to inside the tarball. Fixes bug #176781.
(Portage version: 2.1.2.7)
Diffstat (limited to 'dev-java/java-config')
-rw-r--r--dev-java/java-config/ChangeLog9
-rw-r--r--dev-java/java-config/files/digest-java-config-2.0.333
-rw-r--r--dev-java/java-config/java-config-2.0.33.ebuild44
3 files changed, 55 insertions, 1 deletions
diff --git a/dev-java/java-config/ChangeLog b/dev-java/java-config/ChangeLog
index 731158cc5490..c73f80c71c3c 100644
--- a/dev-java/java-config/ChangeLog
+++ b/dev-java/java-config/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-java/java-config
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/java-config/ChangeLog,v 1.157 2007/05/01 13:46:22 betelgeuse Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/java-config/ChangeLog,v 1.158 2007/05/25 21:51:08 betelgeuse Exp $
+
+*java-config-2.0.33 (25 May 2007)
+
+ 25 May 2007; Petteri Räty <betelgeuse@gentoo.org>
+ +java-config-2.0.33.ebuild:
+ Version bump. Multiple small fixes. Moves files out of PORTDIR to inside the
+ tarball. Fixes bug #176781.
*java-config-2.0.32 (01 May 2007)
diff --git a/dev-java/java-config/files/digest-java-config-2.0.33 b/dev-java/java-config/files/digest-java-config-2.0.33
new file mode 100644
index 000000000000..fe3854bb83bf
--- /dev/null
+++ b/dev-java/java-config/files/digest-java-config-2.0.33
@@ -0,0 +1,3 @@
+MD5 fb714ebd37a8186fa31a87aed99fa2fe java-config-2.0.33.tar.bz2 25491
+RMD160 f8ac8a9c8707ccc62e6258935b4578260f60eaf2 java-config-2.0.33.tar.bz2 25491
+SHA256 3576c22ffd474b02080f257f6ddedd92c453c786f29d893f2d4f7bafc98194da java-config-2.0.33.tar.bz2 25491
diff --git a/dev-java/java-config/java-config-2.0.33.ebuild b/dev-java/java-config/java-config-2.0.33.ebuild
new file mode 100644
index 000000000000..ad249d78fbbc
--- /dev/null
+++ b/dev-java/java-config/java-config-2.0.33.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/java-config/java-config-2.0.33.ebuild,v 1.1 2007/05/25 21:51:08 betelgeuse Exp $
+
+inherit distutils eutils
+
+DESCRIPTION="Java environment configuration tool"
+HOMEPAGE="http://www.gentoo.org/proj/en/java/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="2"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="dev-lang/python"
+RDEPEND="${DEPEND}
+ dev-java/java-config-wrapper"
+
+src_install() {
+ distutils_src_install
+
+ insinto /usr/share/java-config-2/config/
+ newins config/jdk-defaults-${ARCH}.conf jdk-defaults.conf || die "arch config not found"
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/share/java-config-2/pym/java_config
+}
+
+pkg_postinst() {
+ python_mod_optimize /usr/share/java-config-2/pym/java_config
+
+ elog "The way Java is handled on Gentoo has been recently updated."
+ elog "If you have not done so already, you should follow the"
+ elog "instructions available at:"
+ elog "\thttp://www.gentoo.org/proj/en/java/java-upgrade.xml"
+ elog
+ elog "While we are moving towards the new Java system, we only allow"
+ elog "1.3 or 1.4 JDKs to be used with java-config-1 to ensure"
+ elog "backwards compatibility with the old system."
+ elog "For more details about this, please see:"
+ elog "\thttp://www.gentoo.org/proj/en/java/why-we-need-java-14.xml"
+}