summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetteri Räty <betelgeuse@gentoo.org>2007-03-05 10:07:59 +0000
committerPetteri Räty <betelgeuse@gentoo.org>2007-03-05 10:07:59 +0000
commit3a625a61491c4b75997a10f02cb773fafe702bc3 (patch)
tree3f2fa178400156ed1cf338fc27de4682baedbeeb /dev-java/java-config
parentbad escaping on einfo comments thanks to johnny in irc (diff)
downloadgentoo-2-3a625a61491c4b75997a10f02cb773fafe702bc3.tar.gz
gentoo-2-3a625a61491c4b75997a10f02cb773fafe702bc3.tar.bz2
gentoo-2-3a625a61491c4b75997a10f02cb773fafe702bc3.zip
Install a revdep-rebuild control files to prevent revdep-rebuild from complaining about things like libjawt.so that are loaded by the vm. Fixes bug #152039.
(Portage version: 2.1.2-r12)
Diffstat (limited to 'dev-java/java-config')
-rw-r--r--dev-java/java-config/ChangeLog10
-rw-r--r--dev-java/java-config/files/60-java9
-rw-r--r--dev-java/java-config/files/digest-java-config-2.0.31-r43
-rw-r--r--dev-java/java-config/java-config-2.0.31-r4.ebuild61
4 files changed, 82 insertions, 1 deletions
diff --git a/dev-java/java-config/ChangeLog b/dev-java/java-config/ChangeLog
index 76372f6221d3..7111376e1daf 100644
--- a/dev-java/java-config/ChangeLog
+++ b/dev-java/java-config/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-java/java-config
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/java-config/ChangeLog,v 1.143 2007/02/28 10:40:47 betelgeuse Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/java-config/ChangeLog,v 1.144 2007/03/05 10:07:59 betelgeuse Exp $
+
+*java-config-2.0.31-r4 (05 Mar 2007)
+
+ 05 Mar 2007; Petteri Räty <betelgeuse@gentoo.org> +files/60-java,
+ +java-config-2.0.31-r4.ebuild:
+ Install a revdep-rebuild control files to prevent revdep-rebuild from
+ complaining about things like libjawt.so that are loaded by the vm. Fixes
+ bug #152039.
28 Feb 2007; Petteri Räty <betelgeuse@gentoo.org>
java-config-2.0.31-r3.ebuild:
diff --git a/dev-java/java-config/files/60-java b/dev-java/java-config/files/60-java
new file mode 100644
index 000000000000..1aca594a8ece
--- /dev/null
+++ b/dev-java/java-config/files/60-java
@@ -0,0 +1,9 @@
+# The VM dynamically loads these at runtime so they will end up as missing
+# but actually work just fine. See for example
+# https://bugs.gentoo.org/show_bug.cgi?id=152039
+#
+# This file should only have files the are used by things like swt. If there
+# are "broken" links inside the jre itself, the jre should install it's own
+# control file.
+
+LD_LIBRARY_MASK="libjvm.so libjawt.so"
diff --git a/dev-java/java-config/files/digest-java-config-2.0.31-r4 b/dev-java/java-config/files/digest-java-config-2.0.31-r4
new file mode 100644
index 000000000000..393d9dbec4ef
--- /dev/null
+++ b/dev-java/java-config/files/digest-java-config-2.0.31-r4
@@ -0,0 +1,3 @@
+MD5 36b7893b20b9f4b6f0af6dd632703745 java-config-2.0.31.tar.bz2 17001
+RMD160 4b3d8362538b435a642312ee7289824d6662e309 java-config-2.0.31.tar.bz2 17001
+SHA256 314ec1783da8190d60e757aaef2af8eae7281c3c9754024e3e59643ce7a30752 java-config-2.0.31.tar.bz2 17001
diff --git a/dev-java/java-config/java-config-2.0.31-r4.ebuild b/dev-java/java-config/java-config-2.0.31-r4.ebuild
new file mode 100644
index 000000000000..e20c814c477c
--- /dev/null
+++ b/dev-java/java-config/java-config-2.0.31-r4.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/java-config/java-config-2.0.31-r4.ebuild,v 1.1 2007/03/05 10:07:59 betelgeuse Exp $
+
+inherit base distutils eutils
+
+DESCRIPTION="Java environment configuration tool"
+HOMEPAGE="http://www.gentoo.org/proj/en/java/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="2"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="dev-lang/python"
+RDEPEND="${DEPEND}
+ dev-java/java-config-wrapper"
+
+src_install() {
+ distutils_src_install
+
+ insinto /usr/share/java-config-2/config/
+ for i in alpha amd64 hppa ia64 ppc ppc64 sparc x86 x86-fbsd; do
+ if use ${i}; then
+ newins config/jdk-defaults-${i}.conf jdk-defaults.conf || die "arch config not found"
+ fi
+ done
+
+ for tool in $(< config/symlink-tools); do
+ dosym /usr/bin/run-java-tool /usr/bin/${tool}
+ done
+
+ # Install profile.d for setting JAVA_HOME
+ dodir /etc/profile.d
+ exeinto /etc/profile.d
+ newexe ${FILESDIR}/${PN}-${SLOT}.profiled.sh ${PN}-${SLOT}.sh || die "newexe failed"
+ newexe ${FILESDIR}/${PN}-${SLOT}.profiled.csh ${PN}-${SLOT}.csh || die "newexe failed"
+
+ insinto /etc/revdep-rebuild/
+ doins "${FILESDIR}/60-java" || die
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/share/java-config-2/pym/java_config
+}
+
+pkg_postinst() {
+ python_mod_optimize /usr/share/java-config-2/pym/java_config
+
+ elog "The way Java is handled on Gentoo has been recently updated."
+ elog "If you have not done so already, you should follow the"
+ elog "instructions available at:"
+ elog "\thttp://www.gentoo.org/proj/en/java/java-upgrade.xml"
+ elog
+ elog "While we are moving towards the new Java system, we only allow"
+ elog "1.3 or 1.4 JDKs to be used with java-config-1 to ensure"
+ elog "backwards compatibility with the old system."
+ elog "For more details about this, please see:"
+ elog "\thttps://overlays.gentoo.org/proj/java/wiki/Why_We_Need_Java14"
+}