summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetteri Räty <betelgeuse@gentoo.org>2007-06-01 15:31:06 +0000
committerPetteri Räty <betelgeuse@gentoo.org>2007-06-01 15:31:06 +0000
commit4efad6aa858f5aed6a99eef5436b74cc6b443a32 (patch)
treea1d86bf7c0c16f1ac20a7e9ae4017d893119c306 /dev-java/jacl
parentStable on amd64 wrt security bug 180436 (diff)
downloadgentoo-2-4efad6aa858f5aed6a99eef5436b74cc6b443a32.tar.gz
gentoo-2-4efad6aa858f5aed6a99eef5436b74cc6b443a32.tar.bz2
gentoo-2-4efad6aa858f5aed6a99eef5436b74cc6b443a32.zip
Add einfo about tests being known to fail.
(Portage version: 2.1.2.7)
Diffstat (limited to 'dev-java/jacl')
-rw-r--r--dev-java/jacl/ChangeLog5
-rw-r--r--dev-java/jacl/jacl-1.3.3.ebuild8
-rw-r--r--dev-java/jacl/metadata.xml31
3 files changed, 37 insertions, 7 deletions
diff --git a/dev-java/jacl/ChangeLog b/dev-java/jacl/ChangeLog
index 44ea3c48617e..58e6888427cf 100644
--- a/dev-java/jacl/ChangeLog
+++ b/dev-java/jacl/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-java/jacl
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/jacl/ChangeLog,v 1.17 2007/06/01 12:51:21 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jacl/ChangeLog,v 1.18 2007/06/01 15:31:06 betelgeuse Exp $
+
+ 01 Jun 2007; Petteri Räty <betelgeuse@gentoo.org> jacl-1.3.3.ebuild:
+ Add einfo about tests being known to fail.
01 Jun 2007; nixnut <nixnut@gentoo.org> jacl-1.3.3.ebuild:
Stable on ppc wrt bug 180358
diff --git a/dev-java/jacl/jacl-1.3.3.ebuild b/dev-java/jacl/jacl-1.3.3.ebuild
index 37b436e457bc..36be5aa1874d 100644
--- a/dev-java/jacl/jacl-1.3.3.ebuild
+++ b/dev-java/jacl/jacl-1.3.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/jacl/jacl-1.3.3.ebuild,v 1.5 2007/06/01 12:51:21 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jacl/jacl-1.3.3.ebuild,v 1.6 2007/06/01 15:31:06 betelgeuse Exp $
inherit base java-pkg-2
@@ -33,6 +33,12 @@ src_compile() {
emake DESTDIR="/usr/share/${PN}" || die "emake failed"
}
+src_test() {
+ emake check || die "Tests failed"
+ einfo "Some tests are known to fail. We didn't restrict them"
+ einfo "because the ebuild doesn't die."
+}
+
src_install() {
#emake DESTDIR="${D}" install || die "emake install failed"
java-pkg_dojar *.jar
diff --git a/dev-java/jacl/metadata.xml b/dev-java/jacl/metadata.xml
index 70885784ac64..907d3c1bb445 100644
--- a/dev-java/jacl/metadata.xml
+++ b/dev-java/jacl/metadata.xml
@@ -3,12 +3,33 @@
<pkgmetadata>
<herd>java</herd>
<longdescription>
- The Tcl/Java project's goal is to make integrating the Java platform and the Tcl scripting language as easy as possible. The project actually consists of two distinct packages, called Tcl Blend and Jacl. It is important to understand what each package provides and in what situations one might choose to use Jacl or Tcl Blend.
-
- Tcl Blend is a Tcl extension that makes use of JNI to facilitate communication between a Java interpreter and a Tcl interpreter. Tcl Blend is typically used to load a Java interpreter into an existing Tcl process, so that functionality implemented in Java can be accessed via Tcl. One can also load Tcl Blend and Tcl into a Java process, which is a great way to add scripting functionality to an existing Java application. Because Tcl Blend is a normal Tcl extension, one can use it with other popular Tcl extensions like Tk, Expect, and Itcl.
+The Tcl/Java project's goal is to make integrating the Java platform and the
+Tcl scripting language as easy as possible. The project actually consists of
+two distinct packages, called Tcl Blend and Jacl. It is important to
+understand what each package provides and in what situations one might choose
+to use Jacl or Tcl Blend.
- Jacl is a self-contained implementation of a Tcl interpreter, written entirely in Java. Jacl also includes features that facilitate communication between a Java interpreter and a Tcl interpreter. Jacl is typically used to incorporate scripting functionality into an existing Java application. For users who want to avoid adding any native code to their Java applications, Jacl is the ideal solution.
+Tcl Blend is a Tcl extension that makes use of JNI to facilitate communication
+between a Java interpreter and a Tcl interpreter. Tcl Blend is typically used
+to load a Java interpreter into an existing Tcl process, so that functionality
+implemented in Java can be accessed via Tcl. One can also load Tcl Blend and
+Tcl into a Java process, which is a great way to add scripting functionality
+to an existing Java application. Because Tcl Blend is a normal Tcl extension,
+one can use it with other popular Tcl extensions like Tk, Expect, and Itcl.
- Tcl Blend and Jacl define both a Tcl API and a Java API that make it easy to call Java code from Tcl or call Tcl code from Java. For example, one could allocate a Java object in a Tcl script and interactively invoke Java methods on the object. It is also easy to use the supplied API to evaluate a Tcl procedure from a Java method or implement Tcl procudures in Java. The flexible API and wealth of implementation options provided by the Tcl/Java project make integrating Tcl and Java easy.
+Jacl is a self-contained implementation of a Tcl interpreter, written entirely
+in Java. Jacl also includes features that facilitate communication between a
+Java interpreter and a Tcl interpreter. Jacl is typically used to incorporate
+scripting functionality into an existing Java application. For users who want
+to avoid adding any native code to their Java applications, Jacl is the ideal
+solution.
+
+Tcl Blend and Jacl define both a Tcl API and a Java API that make it easy to
+call Java code from Tcl or call Tcl code from Java. For example, one could
+allocate a Java object in a Tcl script and interactively invoke Java methods
+on the object. It is also easy to use the supplied API to evaluate a Tcl
+procedure from a Java method or implement Tcl procudures in Java. The flexible
+API and wealth of implementation options provided by the Tcl/Java project make
+integrating Tcl and Java easy.
</longdescription>
</pkgmetadata>